RPC over HTTP access issue

I am having issues setting up RPC over HTTP (will be https once i get it working). Its on a single server and i believe i have carried out all the tasks however when i try and access http:\\myserver\rpc within my Lan i get access denied after three attempts.

I think its might be related to Global Catalogue,= as i never really understood how to configure that bit. I don't think exchange server can be GC but since there is already one on the subnet, i did not think it would be an issue. Quite how you would use exchange with out a GC is another question which i don;t want to know about.

OWA works fine.

so if someone could help me that would be great.


LVL 1
Carpe--DiemAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dfxdeimosCommented:
First off, an Exchange server CAN also have the Global Catalog role. That however is unrelated to RPC over HTTPS.

Secondly, why are you trying to access http://myserver/rpc? RPC over HTTPS has nothing to do with Internet Explorer or accessing a website. It is a way for Outlook to connect to an Exchange server when it is outside of the network.

Read through this article and follow all the steps listed. If you are still having trouble let us know.

http://www.msexchange.org/tutorials/Troubleshooting-RPC-over-HTTPS-Part1.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dfxdeimosCommented:
Also, you have to use HTTPS with RPC over HTTPS, it is hard coded into the rpcproxy.dll file to only accept SSL connections, no matter what the directory security settings are.
0
Carpe--DiemAuthor Commented:
schoolboy error, forgot to restart server after making reg changes... now just got a certificate issue to resolve.

cheers anyway.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.