Issues using bridging on 2811 router

I have two Cisco 2811 routers connecting my my main and remote sites with private T1 connection. Both routers configured in IRB Bridge mode with BVI1 interface on each router. IP address assigned only to BVI interface.

So, I went to my main 2811 router and assigned an IP address to a FastEthernet interface. My thought is also to use this router as default gateway for my main site. This router in term would connect to my Cisco PIX.

I am using Class C public IP address on my network. So, my IP addresses on the interfaces as follows:

Chicago 2811:
BVI1 - XXX.XXX.XXX.221
FA 0/1 - XXX.XXX.XXX.1
Subnet Mask: 255.255.255.255.

Without even physically reconnecting devices, as soon as I added IP address to FA 0/1, everyone lost internet connection. When I removed that IP address, everything went back to normal. I deleted ARP cache on one of the workstations and it found internet.

What am I doing wrong?
Thanks
Lev KaytsnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
Can you give a bit more information? Seeing the actual config would help. A bunch of "x"'s with a digit at the end doesn't really help.
0
Lev KaytsnerAuthor Commented:
Thanks for reply. Here is my current config on Chicago router. DC Router has similar config. Interesting fact, when I added IP address to FastEthernet0/1 to make it a future default gateway, my Chicago users lost internet connection, but my DC staff were surfing without any problems. However, all these routers do today is connect a private T1 connection between our offices.

Chicago router connects today to the same 3560 switch as all servers and inside interface from my PIX.

*************************************************************************************************************************
Current configuration : 1670 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco2811_1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$CVT8$ywVvmxZXxo4IfCnEXItlo/
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip routing
!
!
no ip cef
!
!
ip domain name ift.org
!
!
bridge irb
!
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 no ip route-cache
!
interface FastEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-LAN$
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description $ES_LAN$$ETH-LAN$
 no ip address
 ip flow ingress
 ip flow egress
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Serial0/0/0
 no ip address
 no ip route-cache
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 12.47.2.221 255.255.255.0
!
ip classless
ip flow-top-talkers
 top 10
 sort-by bytes
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
snmp-server community public RO
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
 line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

*********************************************************************************************************************
Thanks,
Lev
0
Don JohnstonInstructorCommented:
But you're bridging... You don't assign as IP address as that will stop the bridged traffic.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Lev KaytsnerAuthor Commented:
So, what is my solution. I still need to connect both offices and use same router as gateway.
0
Don JohnstonInstructorCommented:
I thought you were bridging the two sites?

If you're bridging, there is no default-gateway.

0
Lev KaytsnerAuthor Commented:
Yes, I am bridging two sites, but I was wondering if I can utilize same router for two different purposes.
0
Don JohnstonInstructorCommented:
What are you trying to route to? We're going to need more information of you topology and what you're trying accomplish.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Lev KaytsnerAuthor Commented:
Here is what I am trying to accomplish. Basically in a nutshell I want to be able with two 2811 routers do the following:

1. Chicago 2811 Router should be able:
1.1 Make a connection with Washington DC via T1
1.2 Be in the middle between my PIX Firewall and the rest of my LAN in Chicago. This will give me a
chance to monitor my network using NetFlow Analyzer.
1.3 Esentially it will become a default gateway for my LAN

2. Washington DC 2811 Router should be able:
2.1 Make a connection with Chicago via T1
2.2 Optionally accept separate Internet Connection only for DC Office.
2.3 Currently all Internet traffic for DC is going thru Chicago
2.4 Router has 2 FA and 1 Serial ports.
I currently use one public Class C address. But, I do have additional IP addresses assigned to me by AT&T, so I might be able to restructure my network to allow this. My understanding that by setting up routers in bridged mode, I am unable to use them in the true routing mode.
Thanks,
Lev
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.