Permission Refused to read my external hard drive

Hi.
I can't access my WD external hard drive anymore (firewire).
I have an Imac with leopard.
Two weeks ago, my system wouldn't boot anymore. Nothing worked of the classical solutions (safe mode, etc...), so i decided do restore the system from Leopard CD. It created a user called 'previous system' and kept all my datas. The only problem is that now when i try to acces my hard drive, it says that i don't have the permissions to do so (the drive appears on the desktop with a little lock).
 When I try to change the permissions, it doesn't let me do so, even though i have the administrator's rights (unelss i mistake). Safe Mode doesn't help...The otpion 'repair permissions' isnt available in the disk utilities.. I am clueless!! Thanks for your help
rotemwebAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
There is a discussion of the problem with a propose solution here:  http://forums.macosxhints.com/showthread.php?t=90894
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rotemwebAuthor Commented:
Excellent! This post completely solved my problem. I couldn't find it myself.

For info: (in case the link becomes broken)  I executed this command in the terminal:

ls -alO /Volumes     # Use this command for Leopard   <--- or delete this line or comment
ls -alo /Volumes    # Use this command for Tiger or previous   <--- or delete this line or comment
id
diskutil list
df
echo "done"


The line concerning my volume showed:

drw-rw-r-T+ 18 agentggd  staff  uchg    680 May 28 08:56 rotemdrive ext

The "uchg" means that the user immutable flag is set
To undo this, I typed:  (don't forget to esape a space in the volume name with \)

chflags nouchg /Volumes/rotemdrive\ ext
sudo chmod 1775 /Volumes/rotemdrive\ ext
echo "done"
 
It asks for the password (doesn't work with password set to nothing -->must create a password)

And then you can change the permissions in the Volume Infos
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Hardware

From novice to tech pro — start learning today.