• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 331
  • Last Modified:

Failed to load psoftapi.dll with v8.22 of external API.

Have a 3rd party app that uses the peoplesoft external API.  Server is now at version 8.22.  API v. 8.20 can connect but get error message saying wrong version of API being used.  8.22 API gets unable to load PSOFTAPI.DLL error.  Wireshark shows no attempt at connection.
0
pint21
Asked:
pint21
2 Solutions
 
oleggoldCommented:
0
 
pint21Author Commented:
Not sure what squid is.  Installed 8.22.17 of Peopletools(full install) and got around dll problem.  Installed Wireshark, and see an error message from the Peoplesoft app server that says my client is at v. 8.22 when my server is at 8.22.17.  

It is a getCertificate request, built into the API (I know this from analyzing IP Packets) that is passing 8.22 as the installed version, even though it is 8.22.17 that is installed.

Ideas would be extremely helpful?
0
 
James MurrellProduct SpecialistCommented:
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. It reduces bandwidth and improves response times by caching and reusing frequently-requested web pages. Squid has extensive access controls and makes a great server accelerator. It runs on Unix and Windows and is licensed under the GNU GPL.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now