?
Solved

How to connect Cable modem thru Linksys router  with Cisco routers and switch ?

Posted on 2008-11-03
7
Medium Priority
?
1,085 Views
Last Modified: 2013-12-14
I have cable internet and my provider is Northwestel Inc. My question is I am trying to setup two routers and 1 switch thrun linksys router that is connected thru cable modem. I don't have fixed IP address, using dynamic and also using DynDNS for DNS services. Please provide me the steps to connect my linksys router and cisco router and cisco swith together without having fixed IP address.
0
Comment
Question by:SPNABI
  • 2
  • 2
5 Comments
 
LVL 15

Expert Comment

by:bkepford
ID: 22876734
Well your cable modem should provid you with an ethernet port. Plug that into the WAN port on the Linksys. The Linksys by default should be setup to NAT.  It should also be a default dhcp server. You need two ehternet ports in your router. Plug the Ethernet connected to one of the open ports on your linksys. Go ahead and set the port to accept a dhcp address (ip address dhcp) Then connect your second ethernet port to your first switch. Then connect your first switch to your second switch using a cross over cable.
You can address your internal network (anything attached to the 2 cisco switches) to anything you want just point them to the router as the default gateway. On your router you have to put an IP address on your inside interface (ip address 10.0.0.1 255.255.255.0) and a static route to point to the linksys router (ip route 0.0.0.0 0.0.0.0 192.168.100.1)
0
 

Author Comment

by:SPNABI
ID: 23243863
I am sorry I was out of country but the good news is I got my CCNA
and working towards CCNP.

Just for clarification I have two routers and one switch not two switches.

My modem is directly connected to WAN port of the linksys router. From the
linksys router RJ45 cable is connected to my cisco router and both cisco
router is connected through serial interface.

From the cisco router RJ45 cable is connected to my cicso catalyst switch.

LINKSYS router configuration:

Automatic configuration-DHCP
DHCP Server Setting:
Start IP address 192.168.1.100
IP Address range 192.168.1.100 to 50

NAT Enabled

Internet IP Address 216.108.184.12
Subnet Mask 255.255.255.0
Default Gateway 216.108.187.254

DNS1 208.67.222.222
DNS2 208.67.220.220
DNS3 216.108.1.1

MTU 1500
DHCP Lease Time 24 Hour



Cisco Router configuration:

Using 504 out of 32762 bytes
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname Router
!
!
no ip domain-lookup
x29 access-list 1 permit www
!
interface Ethernet0
 ip address 192.168.100.10 255.255.255.0
 ip nat outside
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!        
interface Serial1
 no ip address
 shutdown
!
no ip classless
!
!
line con 0
 exec-timeout 60 0
 password cisco
 login
line aux 0
line vty 0 4
 password cisco
 login
!
end

I haven't done the cisco switch configuration.

Somehow whatever I am doing its not working at all.

Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 23249121
If I understand correctly:

Cable modem -> Linksys -> CiscoR1-->serial-->CiscoR2-->switch

Inside IP of Linksys = 192.168.1.1
                 |
LAN IP of R1 = 192.168.1.99 /24
Serial IP R1 = 10.0.0.1 /24
                 |
Serial IP R2 = 10.0.0.2 /24
LAN IP of R2 = 192.168.100.1 /24

Configurations:
R1interface Ethernet0
 ip address 192.168.1.99 255.255.255.0
 no ip nat outside
 no shut

interface Serial0
 ip address 10.0.0.1 255.255.255.0
 no ip nat inside
 no shut
!        
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 10.0.0.2
!

R2
interface Ethernet 0
 ip address 192.168.100.1 255.255.255.0
 no shut
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 no shut
ip route 0.0.0.0 0.0.0.0 10.0.0.1

On the Linksys:
Add Static route for 192.168.100.0/24 - gateway LAN 192.168.1.99
Add Static route for 10.0.0.0/24 - gateway LAN 192.168.1.99

Done.

0
 

Author Comment

by:SPNABI
ID: 23268273
I am not sure how to setup static route in linksys router. I don't have fixed IP address, I am using DHCP based. After setting both cisco router my connection still not working thorugh cisco switch via cisco router.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 23269816
Every Linksys router I've seen has a static route section regardless of whether or not it uses DHCP on the WAN interface.
Add a static routes shown above or it will never work.

LinksysRoute.JPG
0

Featured Post

NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question