Cannot see messages in OWA; red crosses

When we try to open owa from the internet to the company where it should work, we can login, see something which looks like outlook web access, but we cannot see messages at all.

Everywhere we see red crosses. When we do the same within the company, when typing; https://ipaddress/exchange, it works great and we can see the whole graphical owa screen.

I already have tried updates, hotfixes, reinstall exchange 2003 sp2;remove website; add website (exchange,owa). This is NOT a windows vista problem, because it also happens with windows xp

Also tried to open owa in firefox; same problem
thisis_itIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

buddholeCommented:
Do you have a firewall installed ? If so, make sure it allows webdav on the http port.
0
thisis_itIT ManagerAuthor Commented:
Simple firewall via simple router. Port 443 is open and also port 80 is rerouted to internal sbs 2003 server.
0
buddholeCommented:
Does https work or does it gives problems as well ? Double check the router and firewall for http traffic inspection.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

thisis_itIT ManagerAuthor Commented:
https gives the same problem; we can login, but after that we cannot see any mails or graphical layout ( only some titles like inbox outbox send items on the left side)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
thisis_itIT ManagerAuthor Commented:
I will check the articles you suggested. The http does not work. We bought a certificate for webmail for the company. Only https://webmail.domainname.com/exchange works
0
thisis_itIT ManagerAuthor Commented:
The problem is solved. This was a user right problem in IIS. I only accepted the internal domain to connect to webmail. The suggestions from buddhole pointed me into the right answer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.