can get SSh to work

Dear Experts,

Im in my way to deploy SSH on 1812w cisco routers with out success, bellow you can find actual config. When i try to connect im getting access deny with user diego.Any help its well come, thanks in advance

Current configuration : 1538 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname test
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxx
!
no aaa new-model
!
!
!
!
!
!
ip cef
!
!
ip domain name uicc.org
!
multilink bundle-name authenticated
!
!
username diego privilege 15 password 7 xxxxxxxxxxxxxxxxx
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
!
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!        
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Dot11Radio0
 no ip address
 shutdown
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
!
interface Dot11Radio1
 no ip address
 shutdown
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
banner motd ^C
****************************

DO NOT LOG ON

****************************^C
!
line con 0
 password 7 xxxxxxxxxxxxxxxxxx
 login
line aux 0
line vty 0 4
 password 7 xxxxxxxxxxxxxxxx
 login
 transport input telnet ssh
!

!
webvpn cef
end
diegomirnerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

karwakCommented:
Have you had a chance to look at this document on the Cisco website: http://www.cisco.com/en/US/customer/tech/tk583/tk617/technologies_tech_note09186a00800949e2.shtml

It's pretty straight forward to configure ssh access :-)...

You might need to create the rsa key, if you haven't done so.

Let me know if this was working for you!
0
diegomirnerAuthor Commented:
Sorry but i dont have a Cisco contract to access , any other idea ?
0
karwakCommented:
Have you already created the rsa key? You could do so with 'cry key generate rsa'...
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

karwakCommented:
Confirm that you have it with: 'show cry key mypubkey rsa '
0
diegomirnerAuthor Commented:
yeap , i have it

% Key pair was generated at: 13:48:39 UTC Nov 4 2008
Key name: test.mydomain.org
 Storage Device: not specified
 Usage: General Purpose Key
 Key is not exportable.
 Key Data:
  30819F30 0D06092A ......
% Key pair was generated at: 13:48:40 UTC Nov 4 2008
Key name: test.mydomain.org.server
Temporary key
 Usage: Encryption Key
 Key is not exportable.
 Key Data:
  307C300D 06092A86 .......
0
karwakCommented:
Ok, where you able to use ssh to login afterwards?
0
karwakCommented:
Oh, I see that you have "aaa new-model" disabled...

Can you change this to: 'aaa new-model' instead of 'no aaa new-model'?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
diegomirnerAuthor Commented:
exelent , thanks a lot
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.