Windows see 4GB - Bios just 2GB

Hello,
I have Windows Vista Ultimate 64-Bit SP1 OS with all the updates.
I've just put 2 memory sticks 2GB each and got the following problem:
Bios only recognize 2GB while Windows (In some parts) is saying that I have 4GB. But not everywhere.
When I go to the system properties, It says 4GB. When I'm looking at the sidebar, It says 2GB.
In bios, It says 2GB. My 2 previous memory sticks were 1GB each and were apparently high-density (128X8)
Those 2 sticks are apparently 128x16 (8 on each side) which is apparently following the standards (I might be wrong here)
Does that mean that my mainboard doesn't suport 2GB modules?
Thanks in advance!
seoproAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob_OBobsonCommented:
Seopro,
If you know you motherboard's make and model you can go here to find out it's maximum memory capacity:
http://www.memoryexpress.com/ToolsResources/kingston.aspx
If find that the motherboard does actually support 4Gb, then flash the bios with the latest ver.
 
Good luck,
Bob
 
0
PeaceChaserCommented:
What is your model of motherboard / processor?
0
seoproAuthor Commented:
Hello,Thanks for your response!My mainboard is Gigabyte GA-G31M-S2LI've already tried to update to the latest beta bios.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

seoproAuthor Commented:
Just checked the website:"Maximum Memory:  4GB"So in theory, It should support 2GB since it only has 2 memory  slots.
0
compfixer101Commented:
did you get the correct type of memory?
0
seoproAuthor Commented:
I've got 2 modules 2GB each.The module's type is DDR2 PC-6400 800MHZSo the ram is apparently valid.
0
stevepoCommented:
Most of the time motherboards / system will work with the modules they were designed for and there is some flexibility regarding speed, memory timings, etc., but in some instances boards can be very picky about the types of RAM that will work in them.  Below is a list of the Fully Qualified Modules supported by your motherboard:

http://www.gigabyte.com.tw/FileList/MemorySupport/motherboard_memory_ga-g31m-s2l.pdf

There is only one DDR2 800 MHz 2 GB stick listed as qualified on this list, outside of these modules Gigabyte makes no guarantee other modules will work.  The board may also be defaulting in the wrong voltage or timing settings.  The specs on that Micron 2 GB module from the compatibility list are a voltage of 1.8 and CL of 6:
http://www.micron.com/products/partdetail?part=MT16HTF25664AY-800

If you are using 2 GB modules from a different manufacturer make sure they support that same voltage and timing as the micron model and then make sure your motherboard is set for that same memory voltage and timing, you should be able to change these settings in the CMOS settings.

Good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
seoproAuthor Commented:
HmmThe voltage is 1.8, But the CL is 5.How do I change this setting?
0
stevepoCommented:
I am not familiar with your motherboard but you can access the CMOS / System Setup by pressing the "Delete" key when you first boot up the PC.  The settings you're looking for are most likely under the Motherboard Intelligent Tweaker (M.I.T) under the "High Speed DRAM DLL Settings" as shown on page(s) 49 & 50 of the motherboard manual: http://america.giga-byte.com/FileList/Manual/motherboard_manual_ga-g31m-s2l(s2c)_e.pdf

Chapter 2 of the manual contains all information about the BIOS and its settings, you should heed all warnings in the manual when making any settings changes.

Also try running MemTest86 to ensure the RAM you have is good:
http://www.memtest86.com/
Click the "Free Download" link on the left hand side and download the .iso file and you can create your own bootable CD of this utility
0
everxrayCommented:
I'd suggest try one stick of the ram at a time - if they both shown correct info everywhere (BIOS+in system), then try to use one of the 2Gb stick with one of your old 1Gb ram.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.