[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

How to configure DNS to send mails to a partner's domain that is the same that our local domain

Posted on 2008-11-04
9
Medium Priority
?
366 Views
Last Modified: 2012-05-05
I'm working in a company that some time ago had to be divided in 2. So, now we have Company-1 and Company-2 and both are completely independent. Recently the other company choose a public domain name that is exactly the same that our Active Directory domain name and now when we send mails to them, it stucks in queue with a "Cannot connect to remote host" message.

How can I solve this?

Thanks in advance
0
Comment
Question by:oswaldofarith
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 5

Expert Comment

by:buddhole
ID: 22876740
Remove the active directory domain name from the Exchange Recipient policies. Make sure you have your internet domain name listed in the recipient polices.
Possible Workaround: Open the Exchange recipient policies in the system manager, double click on the policy concerning the domain name of the client  and uncheck the option "This Exchange Organization is responsible for all mail delivery to this address."

The first suggestion is nicer/better if you ask me.
0
 
LVL 13

Assisted Solution

by:Nuno Martins
Nuno Martins earned 450 total points
ID: 22876854
Hi,
That situation is very unlucky :)

Ok, what I recommend you to do is to rename your local domain name from AD.
We could resolve the e-mail situation by creating a smtp connector or maybe using the solution refered above but other problems could come from that kind of situation &. This why Microsoft recommends never to use public domains on your active directory .

To rename your AD here are some articles that explain how to do it:
Windows Server 2003 Active Directory Domain Rename Tools
http://technet.microsoft.com/en-us/windowsserver/bb405948.aspx
How Domain Rename Works
http://technet.microsoft.com/en-us/library/cc738208.aspx

If you don´t want to do that kind of operation and you prefer to stay as you are (Not Recommended in my opinion)
Try creating a SMTP connector for the domain and specify manually the ip of theirs e-mail server
0
 
LVL 6

Author Comment

by:oswaldofarith
ID: 22876998
I'm not using Exchange and I don't want to rename the AD domain, so, it is possible to make a workaround using DNS only?
0
A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

 
LVL 26

Expert Comment

by:jar3817
ID: 22877706
You had the name first, make them change it!
0
 
LVL 5

Accepted Solution

by:
buddhole earned 1050 total points
ID: 22878150
Do not rename your domain for this !
What e-mail server are you using ? Check the dns settings for the mail server, it should lookup the MX record for the domain.  Usually there is not an MX record in the AD dns. The solution should be searched in the mail server / dns setup you're using. Having the same AD domain name shouldn't be a problem if you configure your mail sever correctly.
0
 
LVL 6

Author Comment

by:oswaldofarith
ID: 22878431
I'm using Kerio Mailserver for Windows Server 2003.

I get the point, so I will search in Kerio documentation.
0
 
LVL 5

Expert Comment

by:buddhole
ID: 22879950
Look at the optios for setting to use a smarthost for mail delivery, if possible for certain domains.
0
 
LVL 13

Expert Comment

by:Nuno Martins
ID: 22884673
Buddhole,
Has you probably know that kind of settings that oswaldofarith is using on the internal domain, can bring him a lot of problems. What is happening is just one example. So recommending some one not to permanently resolve the issue, i don´t think is a good idea.
But the Admin of the system as the last word on the subject.

To resolve the issue without having to rename using kerio mailserver check this link:
http://www.securitypronews.com/it/networksystems/spn-21-20040217KerioMailServer.html

There you can see where you can create an SMTP/relay:
Relaying is configured under Configuration->SMTP Server

NM
0
 
LVL 6

Author Closing Comment

by:oswaldofarith
ID: 31513090
What I had to do to solve this problem was to create a new domain without users, with the name of the other company (the same that I using in AD) and in the Forwarding option, mark "If recipient was not found in this domain, forward the message to another host" with the IP of the partners mailserver. Thanks to buddhole and the other guys for your help.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As cyber crime continues to grow in both numbers and sophistication, a troubling trend of optimization has emerged over the last year.
Stellar Exchange Toolkit: this 5 in 1 toolkit comes loaded with mega-software tool. Here’s an introduction to tools’ usage and advantages:
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question