[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1173
  • Last Modified:

ADVAPi32.dll Error after registering DLL file

HI there,
Bit of a strange one this.
I was working my way though this article
http://www.windowsecurity.com/articles/Implementing-Troubleshooting-Account-Lockout.html
trying to trouble shoot a user account lockout error.
I followed the procedures mentioned on AD1 and then did the same on AD2
(both servers are identical Windows 2000 Advanced Server builds)
and when I did this bit
"Copy ALockout.dll to the System32 directory and double-click on Appinit.reg to register the DLL. Then restart the machine and when the lockout problem happens again you can view the log file %WinDir%\debug\ALockout.txt to troubleshoot."
and restarted I suddenly started getting the following error message on startup.

"The procedure entry point LogonUserExa could not be located in the dynamic link library ADVAPI32.dll"

I can click OK to get past it and the server seems to be working fine but the error keeps popping up.

I've deleted the original version of the file and copied over a new one but still the same problem.

Any ideas?
Thanks,
C
0
Crafu
Asked:
Crafu
1 Solution
 
CrafuAuthor Commented:
First link did the job!
Thanks for the advice.
Outstanding answer in less than ten mins. Very impressed!
Cheers,
C
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now