Solaris printer error

Hello,

As per a user request, I configured a Solaris machine to send print jobs to a Printer. I just set the Printer as the default printer using CUPS and after that when we issue the print jobs from OS shell, it is going fine. Whereas when the print jobs are going from Oracle application, it is giving the following error:

Printing output file.
               Request ID : 5230259  
         Number of copies : 1  
                  Printer : minolta
 
lp: Error - priority must be between 1 and 100.
APP-FND-00500: AFPPRN received a return code of failure from routine FDUPRN. Cannot write to the communication channel
 
Cause: AFPPRN received a return code of failure from the OSD routine FDUPRN. Cannot write to the communication channel.


Since it tells that we need to set priority for the print jobs, I tried to do so but couldn't succeed. Could you please tell me what is this error about and how can i fix it? Please let me know if you require more information on this.


Thanks,
AR
LPSTAT OUTPUT
 
bash-3.00# lpstat minolta -t
scheduler is running
system default destination: minolta
device for minolta: lpd://172.16.96.30
minolta accepting requests since Mon Nov 03 15:13:23 2008
printer minolta is idle.  enabled since Mon Nov 03 15:13:23 2008
bash-3.00#

Open in new window

rdashokrajAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

schwertnerCommented:
lp -o job-priority=30


Setting the Job Priority
The -o job-priority=NNN option tells CUPS to assign a priority to your job from 1 (lowest) to 100 (highest), which influences where the job appears in the print queue. Higher priority jobs are printed before lower priority jobs, however submitting a new job with a high priority will not interrupt an

http://www.cups.org/documentation.php/options.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rdashokrajAuthor Commented:
Hi schwertner, Thanks for your input. However I don't have any specific job name or JobID in my hand, for which I can set the priority. The print jobs are actually sent by Oracle application, for those jobs we have to set the priority. So my basic requirement is whatever the print jobs goes from a client, it should go with some priority values.

We looked into the Oracle application to see if we can set any priority for the print jobs it sends. But unfortunately we couldn't find any. Hence from client perspective, whichever the print jobs goes to a printer, I want it to go with a priority value set.
0
schwertnerCommented:
There are so much Oracle applications!
There should be a documentation for the application.
Or possibly in the Minolta doc is explained how to set default value for the priority.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

rdashokrajAuthor Commented:
Hi schwertner,  We have spend considerable amount of time in finding an option for setting priority for the print jobs issued by Oracle application but we couldn't find any :(

Apologize for asking you again. Is there a way that we can set priority for all the print jobs (irrespective of whether it is from Application or OS)  going out from a machine ?
0
rdashokrajAuthor Commented:
The /etc/printers.conf file shows as following:

bash-3.00# cat /etc/printers.conf
# This file was automatically generated by cupsd(8) from the
# /etc/cups/printers.conf file.  All changes to this file
# will be lost.
_all:all=minolta
_default:use=minolta
minolta:\
        :bsdaddr=stride01s-dev,minolta:\
        :description=minolta:


Where 'minolta' is the name of the printer and stride01s-dev is the hostname of the solaris box from where we are sending the print jobs.

0
rdashokrajAuthor Commented:
Sometimes Solaris really sucks :)
0
schwertnerCommented:
Please look Google for this - use "CUPS minolta" as search words
http://foo2zjs.rkkda.com/cups/2300dl.html
http://linux.derkeiler.com/Newsgroups/alt.os.linux/2004-02/2572.html.
I am Oracle guy, so I have no experience in printer configuration.
0
peter991Commented:
Hi!
Have you looked around in the printmanager?

#> /usr/sadm/admin/bin/printmgr

Perhaps you have to "add access to printer" or check the "user access list".

0
peter991Commented:
If you got access to metalink you will get alot of hits on your error and a good note to start with is: Note:269129.1

metalink.oracle.com

Regards
0
rdashokrajAuthor Commented:
Thankyou so much for all your help. Let me work on your inputs and get back to you.
0
rdashokrajAuthor Commented:
Finally the issue got resolved after setting the priority for print jobs using the following command:

lpsusers -l

lpusers -d 0


Thanks for all your inputs.
0
rdashokrajAuthor Commented:
There is a Typo: its "lpusers"

0
schwertnerCommented:
Hope you fix the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.