• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 722
  • Last Modified:

GRANDSTREAM IP PHONE DISCONNECTED USING SIP ACCOUNT

Hi Everybody,
i'm recently buy a GRANDSTREAM IP PHONE  GXP12000.
and i set just one line with a SIP account and all works really good.... but if i wait some minutes the sip account logout from the phone  (because i call to the phone and this phone never receive the call).
i don't know what it's happened.
any ideas?
thanks a lot

Gustavo
0
gesquivel
Asked:
gesquivel
  • 6
  • 5
1 Solution
 
michofreihaCommented:
you need to check the keep alive timer on the server and adjust your Grandstream timer to send a keep alive message within the period specified on the server...Try this and let me know

Regards
0
 
gesquivelAuthor Commented:
i already test it.
i don't have an own server.
it's a provider... so i'm posting the screen shot of the keepalive function of the phone

thanks!
Gustavo
Phone1.jpg
Phone2.jpg
0
 
michofreihaCommented:
try to put keep alive interval to 2 and wait...Let's see if you'll loose connection to the server
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
michofreihaCommented:
and please put register expiration to 3600
0
 
gesquivelAuthor Commented:
i already change the register expiration to 3600
but the administration pago don't let me put "2" in the keep alive interval.
when i put "2" and i update and reboot the phone. the value "20" appears again.

Thanks!
0
 
michofreihaCommented:
ok...can you check the status tab and let me know which value you are getting for account 1 when the device logoff?
0
 
gesquivelAuthor Commented:
Hey Michofreiha,
apparently now the phone works perfectly with the Register experitaion set to 3600.
let me test it to accept your solution and pay the points!

thanks a lot

Gustavo
0
 
michofreihaCommented:
please let me know if you need something...I can help
0
 
gesquivelAuthor Commented:
thank u very much michofreiha!
i will let u know if this solution works!
thanks a lot again

Gustavo
0
 
gesquivelAuthor Commented:
Hi Michofreiha,

the phone is still having the problem. but now is getting more time online (the phone)
now i'm detecting the phone just can't receive calls elapsed that specific time. because i can use the phone to make calls and all works fine.

anyway i'm posting 2 screenshots of the status when the phone by working good and when i don't receive any call.

thanks a lot

Gustavo

Receving-Calls.jpg
NoReceivingCalls.jpg
0
 
lormareCommented:
I see you have a private address, I assume you are beind NAT,  so you have to set and enable the STUN server for correct registration.
P.s. Delete the value in outboundproxy if you don't need it.
0
 
gesquivelAuthor Commented:
the problem was my SIP provider, anyway guys the keepalive option was really important

thanks a lot
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now