?
Solved

How do I map a network drive that I disconnected but now it does not show up in the map network window, it is visible from server 2003?

Posted on 2008-11-04
46
Medium Priority
?
528 Views
Last Modified: 2010-05-18
Computers are running Windows Xp.
Server is running SBS 2003 R2.
External network harddrive used to be accesible by client cs till today.
The server can access it and view its contents but the clients cannot.
I disconnected the drive from my computer then when i tried to map the drive it does not show up.
I right-click "My Computer", select "Map Network Drive".
Select Drive "Q".
Click "Browse".
But none of the folders show up.
What can I do to make it accessible?

I forgot to mention that the external drive I disconnect everyday at the end of the day and reconnect the next day first thing in the morning.  It is a backup drive for SBS and each user's My Documents.

When I try to enter q:\\servername\folder from the command line i get the following error message:
"The system cannot find the drive specified."
When i try to enter q:\\servername\folder from the map network and browse section i get the following error message:
"Attempting to connect."
"The network path q:\\servername\folder could not be found."
This drive is accessible through the server in which it is connected but not from the client PCs.
On other computers that I did not disconnect the drive I get the following error message when I try to click on the network drive letter from My Computer:
"An error occurred while connecting Q: to server name\folder
Microsoft Windows Network: The network name cannot be found.
This connection has not been restored."

This happens once in a while.
Usually we restart the server and that takes care of the problem.
This time it did not.
I even increased the IRPStackSize to 21.

What can I do to fix this problem?
Should I increase the IRPStackSize to 24?
0
Comment
Question by:j_rameses
  • 23
  • 18
  • 5
46 Comments
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22880084
Mapped network drives are a per user setting.. IE
User A can log onto workstation A and have a set of mapping
User B can log onto workstation A and ahve a completely different set of mappings...
The fact that it works on the server only proves that the path is correct...
HAve you tried restarting the client machines and then trying to readd the mapped network drive...

When you click browse you are then using microsoft (very iffy) network browsing feature.. There server that you ar looking for might not be listed, especially if NetBIOS / WINS / network browsing are not set up correctly.... Why cant you just copy the path in the box and then map the drive that way...?
0
 

Author Comment

by:j_rameses
ID: 22880123
JohnGerhardt,

I will restart my PC to see if that works.
Regarding your last comment, I need the users to have a shortcut on their laptop to the shared folder.
Will your method create a shortcut?
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22880167
create a batch file
inside put;
net use x: \\server\share

where "x" is the drive letter you want to use and "\\server\share is the path that the mapped drive shoudl go to...

Place the batch file on the server and create shortcuts for the users to it...
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:j_rameses
ID: 22880293
How do I create the batch file?
Please provide step by step instructions since I am new to this.
I have to leave for the day so I won't be able to play with this till tomorrow.
I hope to read from you tomorrow.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22880328
Ok..
Open notepad
type in

net use x: \\server\share

where "x" is the drive letter you want to use and "\\server\share is the path that the mapped drive shoudl go to...
Repeat as necessay
Choose File => Save As => choose a filename like mapdrives.bat (make sure that the extension is ".bat")
All your users have to do is double click the batch file and it will map the drive you have entered.
Hope that is ok - Shall check tomorrow..
0
 

Author Comment

by:j_rameses
ID: 22885914
John,
I did as per your instructions but the only thing that happens is that a DOS window opens up quickly and disappear in a blink of an eye.
I did it as follows:
q:\\name_of_server\name_of_drive
and a s well
q:\\name_of_server\name_of_drive\name_of_folder\

I forgot to mention that the accountant has a program that does a backup of its data on the external Q drive.  But now they are unable to do so.  That is how I found out that the Q drive was not allowing access to it.
I restarted server with the drive attached to it and without it but still the PCs have no access to it.
What can be done to fix this problem?
Because the bat file would only allow the user to open the folder when they need to get into it but it will not help the program that automatically saves to the Q drive.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22886615
You need to put exactly what I typed above;

net use q: \\name_of_server\name_of_drive\name_of_folder\
0
 

Author Comment

by:j_rameses
ID: 22886700
i just tried it with the wording "net use" with both a space between the q and \\ and with a space between the q and \\.
The DOS windows appears and then disappears.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22887351
Is the drive then mapped..?
If you type
pause
on a new line at the end of the batch file, the window will stay open and then you can see the error...
0
 

Author Comment

by:j_rameses
ID: 22887428
I checked my computer and the network drive is not there, therefore it is not mapped.
Here is what the DOS output has:

C:\Documents and Settings\Administrator.BDRN\Desktop>net use q:\\name_of_server\ba
ckup drive\joshua's folder\
The syntax of this command is:

NET USE
[devicename | *] [\\computername\sharename[\volume] [password | *]]
        [/USER:[domainname\]username]
        [/USER:[dotted domain name\]username]
        [/USER:[username@dotted domain name]
        [/SMARTCARD]
        [/SAVECRED]
        [[/DELETE] | [/PERSISTENT:{YES | NO}]]

NET USE {devicename | *} [password | *] /HOME

NET USE [/PERSISTENT:{YES | NO}]



C:\Documents and Settings\Administrator.BDRN\Desktop>pause
Press any key to continue . . .
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22887992
You need a space between the q: and the UNC path name of the server..

net use q: \\name_of_server\backup drive\joshua's folder
0
 

Author Comment

by:j_rameses
ID: 22888070
I tried it that way and the same thing I get:

C:\Documents and Settings\Administrator.BDRN\Desktop>net use q: \\svr-bleeding\b
ackup drive\joshua's folder\
The syntax of this command is:

NET USE
[devicename | *] [\\computername\sharename[\volume] [password | *]]
        [/USER:[domainname\]username]
        [/USER:[dotted domain name\]username]
        [/USER:[username@dotted domain name]
        [/SMARTCARD]
        [/SAVECRED]
        [[/DELETE] | [/PERSISTENT:{YES | NO}]]

NET USE {devicename | *} [password | *] /HOME

NET USE [/PERSISTENT:{YES | NO}]

C:\Documents and Settings\Administrator.BDRN\Desktop>pause
Press any key to continue . . .
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888104
Oh, You have a space in the UNC path name and so you will need to enclose it is quites, like this..:

net use q: "\\name_of_server\backup drive\joshua's folder"

0
 

Author Comment

by:j_rameses
ID: 22888182
this is the error message I get:

C:\Documents and Settings\Administrator.domain\Desktop>net use q: "\\name_of_server\
Back-Up Drive\Joshua's Backup\"
System error 53 has occurred.

The network path was not found.


C:\Documents and Settings\Administrator.BDRN\Desktop>pause
Press any key to continue . . .


The name of the server  and the path is correct I looked over it and made corrections but I still get the same error message as listed above.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888230
You need to replace "name_of_server" with the name of our server!!!!!!!!!!!!!!!!!

;)
so: taking from previous posts..
net use q: "\\svr-bleeding\backup drive\joshua's folder"
0
 

Author Comment

by:j_rameses
ID: 22888246
This is what I am using:
net use q: "\\svr-bleeding\Back-Up Drive\Joshua's Backup\"
pause
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888260
That should work...
0
 

Author Comment

by:j_rameses
ID: 22888364
Why is it I can't map the network drive through right clicking my computer?
Is there a way to fix this?
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888386
There is a no reason why that wont work as well,
I though you wanted somehting so that your users could mapp network drives easily...!
0
 

Author Comment

by:j_rameses
ID: 22888479
They had mapped drives but they are no longer accessible they get the following error message:
An error occurred while connecting Q:\\Svr-bleeding\Back-Up Drive
Microsoft Windows Network: The local device name is already in use.
This connection has not beeb restored.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888504
and what happens if you are and open the mapped drive q: on the client machines...
Start => Run => q:
??
0
 

Author Comment

by:j_rameses
ID: 22888601
if i use a different computer other than my own I get the same error message as mentioned above.
if i use my pc i get the following error message:

Q:\ Refers to a location that is unavailable.  It could be on a hard drive on this computer, or on a network.  Check to make sure that the disk is prooperly inserted, or that you are connected to the internet or your network, and then try again.  If it still cannot be located, the information might have been moved to a different location.
0
 

Author Comment

by:j_rameses
ID: 22888737
Can it be that the configuratiions on the server share drive have to be in a specific setting?
Can we go over that scenario?
Can that have an affect on the network drive working one day and then not the next day?
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888780
on one onf the machines that doesnt work try..
Start => run => type cmd and press enter
type
"net use q: /delete" then press enter..
net use q: "\\svr-bleeding\Back-Up Drive\Joshua's Backup\" then press enter

Now see if you can access the q drive.. also confirm that the users can actually actually the path by typing "\\svr-bleeding\Back-Up Drive\Joshua's Backup\" into run, it should then show the folder...

0
 

Author Comment

by:j_rameses
ID: 22888949
It does not show the folder.
All I get is the message:
The syntax of this command is:

NET USE
[devicename | *] [\\computername\sharename[\volume] [password | *]]
        [/USER:[domainname\]username]
        [/USER:[dotted domain name\]username]
        [/USER:[username@dotted domain name]
        [/SMARTCARD]
        [/SAVECRED]
        [[/DELETE] | [/PERSISTENT:{YES | NO}]]

NET USE {devicename | *} [password | *] /HOME

NET USE [/PERSISTENT:{YES | NO}]
---------------
If I click on the Q: drive icon in My Computer the following error message is displayed after the net use Q: /delete :::

Q:\ Refers to a location that is unavailable.  It could be on a hard drive on this computer, or on a network.  Check to make sure that the disk is prooperly inserted, or that you are connected to the internet or your network, and then try again.  If it still cannot be located, the information might have been moved to a different location.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22888987
Ok, if you put the UNC "\\svr-bleeding\Back-Up Drive\Joshua's Backup\" into run and it didnt work for the users then it means that either the share / folder dont exist or they dont have access to it..
Until you can get this fixed then the mapping of the network drive will never work...

lets go back to square 1...
What path do you wanted mapped for a user...?
What letter would you like it mapped to.....?
How woudl you like the user to create this mapping....?
0
 

Author Comment

by:j_rameses
ID: 22889039
The path would be:
name of server/name of drive(which is the q drive)/name of folder
Svr-Bleeding/Back-Up Driv I take home everyday.e/Joshua's Backup

The letter it should be mapped to is Q, which is the external drive USB 2 drive from Buffalo that I take home everyday.

I want the mapping to be done through right-clicking My Computer.

Should we go through the settings that I have for the network drive?
0
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22889055
A couple things to check
1) Just type in 'net use' into cmd box - see if there are any mapped drives still hanging around.
2) Is "\\svr-bleeding\Back-Up Drive\Joshua's Backup\" the share name? Going to assume it is here.
3) The problem with the above script is that it ends with a \     when you map a drive, do not end with a backslash.  So you would want:
Start - run - 'cmd' - [Enter] (or put below into .bat file)
net use q: /delete
net use q: "\\svr-bleeding\Back-Up Drive\Joshua's Backup"


For the last line you might also consider:
net use q: "\\svr-bleeding\Back-Up Drive\Joshua's Backup" /persistent:yes

If you need/want to add username information you can do that as well, if you do you can also provide password info (if not provided then it should prompt).  Replace values in {} and remove {}:

net use q: /delete
net use q: "\\svr-bleeding\Back-Up Drive\Joshua's Backup" /user:{DomainName}\{UserName} {YourPassword} /persistent:yes
0
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22889097
You should be able to through My Computer from Tools - Map Network drive and fill in the values there as well, remember to leave out the \ at the end if typing in - usually easiest to Browse... to it so it gets entered correctly.  Sometimes this interface is kind of quirky which is why we tend to go to command line when mapping drives.
If still having problems in this area, reboot the client machine.
0
 

Author Comment

by:j_rameses
ID: 22889179
Paranormastic,

I tried in the past to map using the map network drive through tools and right clicking my computer but the name of the shared folder is not there.
When I did it in the past it was there.
That is how we were able to access the external drive folders.
Now for some reason we cannot access the drive.
I also tried rebooting my machine.
I will do it again right now to confirm that it does not work.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22889180
You are going to have a trouble mapping anetwork drive if the USB key is on the same drive letter..  Can you not just pick another..
0
 

Author Comment

by:j_rameses
ID: 22889207
Are you asking me to change the drive letter for the external harddrive?
if yes, how is it done?
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22889249
The external drive is more difficult to change as it will vary per computer... It is quite weired that is getting q: anyway...
How about changing the drive letter for the netowkr drive you want to map?
0
 

Author Comment

by:j_rameses
ID: 22889331
I gave the external network drive the letter Q because it was too close to d,e,f,.
I did not want it use those by default so I assigned it the letter Q.  I named the drive Back-Up Drive.
0
 

Author Comment

by:j_rameses
ID: 22889344
Paranormastic,
I tried restartiing my PC ut I still cannot map the drive/folder
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22889386
0
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22889649
Can you pull up the share OK from the run box?
Are there any errors in the system event log?
0
 

Author Comment

by:j_rameses
ID: 22889657
yes the USB Drive is attached to  the server
0
 

Author Comment

by:j_rameses
ID: 22889685
Paranormastic,
I do not understand your first question?
Your second question from where should I check the system logs, the server or the client pc?
0
 

Author Comment

by:j_rameses
ID: 22890063
I will be out tomorrow, Thursday.
I hope we can continue this on Friday.
If you have any suggestions please post them and I'll read them first thing tomorrow morning.
0
 

Author Comment

by:j_rameses
ID: 22890075
John, should I give full permission in SBS for the Q drive?
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22893825
have a read of these..
They explain about sharing a drive and then the pitfall to lookout for regarding sharing a removebale device...

http://support.microsoft.com/kb/324267

http://www.tomshardware.co.uk/forum/198505-36-share-removable-drive
0
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22894586
To explain:
1) Start - Run - type "\\svr-bleeding\Back-Up Drive\Joshua's Backup" and click ok to see if it comes up
  -- if not, then try just \\srv-bleeding and see if that comes up and see what shares are actually available to browse through.  
  -- If you're folder is not shared, then go into the properties of that folder on the server and enable sharing for it.

2) Check the System event log in Event Viewer on both client and server, although I would check the client first.
0
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22894603
More for 1)...
  -- If you don't see the share, also check the permissions for both the share and NTFS permissions on the folder - i.e. check both sharing tab - permissions, and the security tab, on the server.
0
 

Accepted Solution

by:
j_rameses earned 0 total points
ID: 22908127
John,

What I did was shared the Q drive instead of the folder and it recognized the drive and its folder.
Something this simple was overlooked.
Weird that it worked temporarily without permissions.
Thank you for your help, but I cannot award points for this.
Thanks anyways.
0
 
LVL 17

Expert Comment

by:JohnGerhardt
ID: 22908622
Glad you fixed it...
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question