Problems migrating Active directory from Server 2000r4 to 2003r2 Enterprise

When following the following article http://support.microsoft.com/kb/325379 

Started at Overview: Upgrading Windows 2000 domain controllers to Windows Server 2003.  

All worked really well till running winnt32.exe /checkupgradeonly.  The system tells me that upgrading from 2000 to 2003 Enterprise is not possible.  Ouch!  Any thoughts on migrating my AD to the new 2003 server.  Went with enterprise because of CAL's included.
X-spookAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dusan_BajicCommented:
Fresh install on another piece of hardware?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dfxdeimosCommented:
Can you tell me the exact error message that you recieve when running "winnt32.exe /checkupgradeonly" and any event log entries that pop up as a result?
0
dfxdeimosCommented:
Also, are you upgrading from 32 Bit -> 32 Bit or 64 Bit -> 64 Bit ? You can upgrade to a different architecture.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Dusan_BajicCommented:
Or fresh install on the same hardware (if you have another DC running, which you should)?
0
X-spookAuthor Commented:
I have already reinstalled.

We have an older IBM platform and I am replacing with a new Power edge 1900. First thing I thought of was to reinstall as DELL did the initial.  Same result.

Not on site at the moment but will be within the next day or so and can rerun to give a snippet of the exact error.  I am 99.9% positive that the error referanced that upgrading from 2000 to 2003 Enterprise was not supported. Which just blew me away.  

32 bit to 32 bit upgrade also.

Thanks for all the great responces.
0
dfxdeimosCommented:
So you did a FRESH install of Server 2003 on the new Dell server and then attempted to join that server do the domain and promote it to a DC, and that is when this occured?

Did you run the ADPrep from Disc 2 of the 2003 R2 Setup CDs? You have to run the one from Disc 2, the one on Disc 1 will not work when upgrading a 2000 domain to 2003.
0
X-spookAuthor Commented:
Yes I ran a fresh install on the new Dell system, and Yes that is when it occured.  After Adprep and Forest prep I then ran.  winnt32.exe /checkupgradeonly.

This is the same process that I have run on every other server that I have ever done.  This was why I was so surprised in the responce back form the program.  Granted I was using the restore disk that came with the server for the reload.  I have another copy that I am thinking of trying the reload from instead.

And yes I ran them from disc 2.  I actually have the files on a USB as I commonly do these sort of upgrades for customers.  Pulled from \CMPNENTS\R2\ folder on CD2.

Thanks

0
dfxdeimosCommented:
Please let us know how that second reload goes. I will keep a watch on the thread.
0
Henrik JohanssonSystems engineerCommented:
Upgrading Windows 2000 Server to Windows Server 2003 Enterprise Edition is supported.
http://www.microsoft.com/windowsserver2003/evaluation/whyupgrade/supportedpaths.mspx
http://support.microsoft.com/kb/810613
0
X-spookAuthor Commented:
I have not forgotten about the questions just have not been back to the customer to attempt.  Will be doing this later in the week and will post results.

I do believe also that it is the load of software on the machine as there may be a flaw with the disc that came with it.  Will try with my other known good disk and see.

Thanks all.
0
dfxdeimosCommented:
Great, let us know.
0
X-spookAuthor Commented:
Still working on the reload.  Updating the forum to keep this alive.
0
X-spookAuthor Commented:
System reloaded with other system disks.  Reran the adprep forest and domain from the command prompt from disk 2 and all was well.

Took the original disks to a spare system that reloaded with those disks and tried the same thing again.  same error telling me that the upgrade was not supported.  Ordered new set of replacement disks from manufacturer and tested again.  Reinstalled the new system with the new disks run process and all was well.

Wild problem but persistance prevailed.  Has now cost me quadruple the time.

Thanks to all.
0
X-spookAuthor Commented:
Thank you all for the help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.