Error printing from Mac OS 10.5.5 to Windows Server 2008 via LPD

I am trying to setup a new Windows Server 2008 print server, and I can print just fine from OS X via SMB, but I cannot print via LPD.  We have a lot of clients currently setup to print via LPD to our Windows Server 2003 print server, and I would like the transition to be as smooth as possible.  When I print from my Mac to the print server with via  LPD (lpd://xxx.xxx.xxx.xxx/CIT03p), I see the following error in the System log:

Log Name:      System
Source:        Microsoft-Windows-Spooler-LPDSVC
Date:          11/4/2008 3:19:58 PM
Event ID:      4009
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      printserver.domain.com
Description:
The Line Printer Daemon (LPD) service refused a print job from xxx.xxx.xxx.xxx for printer \\xxx.xxx.xxx.xxx\CIT03p because the specified printer does not exist on this computer. Retry printing from the client using the correct printer name.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-Windows-Spooler-LPDSVC" Guid="{9F44821F-1FD9-46BF-A09A-C7F751159AAF}" EventSourceName="LPDSVC" />
    <EventID Qualifiers="49152">4009</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2008-11-04T20:19:58.000Z" />
    <EventRecordID>20315</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>printserver.domain.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">\\xxx.xxx.xxx.xxx\CIT03p</Data>
    <Data Name="param2">xxx.xxx.xxx.xxx</Data>
  </EventData>
</Event>

I have tried changing the queue from Standard TCP/IP using RAW on port 9100 to LPR on port 515, and have even tried installing the LPR Port Monitor and using that, but I get the same result every time.  I would appreciate any suggestions.
LVL 1
craigjmAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Naga Bhanu Kiran KotaCommented:
Hi

i think the error seems to more for the type of printer the MAC OS x is referring to and that printer not being correctly configured.

http://technet.microsoft.com/en-us/library/cc773861.aspx

check this article and update

bhanu
0
craigjmAuthor Commented:
I saw that article, but it didn't seem to help.  By default, the Printer Name or IP Address field in the Port Settings is set to the IP address of the printer.  The Protocol is set to Raw, and the Port Number is set to 9100.  No matter what I change, if I use the queue name for the Printer Name or IP Address Field, or change the Protocol to LPR and the LPR Queue Name to match the Queue name, it still doesn't work.
0
craigjmAuthor Commented:
Well it looks like I found the problem and the solution.  After creating printers, I assigned them a standard set of permission for a bunch of different domain groups.  During the process, I removed the Local Administrators group permissions for the printers.  It appears the Local Administrators group needs the "Manage printers" permission for LPR printing to work.  I'll verify it with some more testing, but this looks like what was causing the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
craigjmAuthor Commented:
Yes, looks like that was it.  I can print from from any user account on a Mac to any printer on the Windows Server 2008 box without any issues now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.