Visual Studio 2005, All toolbox controls grey.  How to get them enabled?

Posted on 2008-11-04
Last Modified: 2013-11-26

Can't figure out why all my toolbox items are grey.

Status to date:
Brand clean os install about 3 weeks ago.  Been building this system moving things over bit at a time.  Installed VS 2005 a week ago along with SQL 2005 (not express).  Built some views and a stored procedure in SQL Server Management studio - no problem.

Yesterday I cranked up Visual Studio, told it new console app, and no controls were present in the toolbox no matter what module or what-have-you I open.

The Toolbox was there, and the only grouping was "Default" and it says "There are no usable controls in this group.  Drag an item onto this text to add it to the toolbox."

I have googled and tried everthing I could find.  I even uninstalled VS & SQL and uninstalled .net.  Did as thorough a clean up as I could.

Reinstalled SQL (which installed the .net 2.0) and then installed VS 2005.

Ran in the service packs and updates.  No errors.

No runs either.  Same problem.  

I tried the delete the 8.0 directory, did the devenv /setup, logged on a user that had never been on this machine.

Nada, zip, scratcharola.  Nothing shows up.  If I put on "show all" I can see the groups and the controls under it are grey/disabled.

Please help me fix this blankety-blank thing so I can get on with my work.

Question by:OuttaCyTE
    LVL 5

    Accepted Solution

    Hey.. This looks odd..
    Can you try a windows application and open the form view as attahed screen.
    LVL 3

    Expert Comment

    Console applications do not have a graphical user interface...therefore no controls can be put on a form.
    Console apps are "old school" have to write it all yourself.

    Author Closing Comment

    Thank you for the quick response.  What you noted was sufficent by itself, the pictures made it extra clear.

    Expert Comment

    Just for the record.  I had this problem and resolved it by right clicking the toolbox and "show all".  They still came up grayed out, but then when I uncheked "show all" they all came back and were working: odd but true!

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Join & Write a Comment

    The object model of .Net can be overwhelming at times – so overwhelming that quite trivial tasks often take hours of research. In this case, the task at hand was to populate the datagrid from SQL Server database in Visual Studio 2008 Windows applica…
    More often than not, we developers are confronted with a need: a need to make some kind of magic happen via code. Whether it is for a client, for the boss, or for our own personal projects, the need must be satisfied. Most of the time, the Framework…
    how to add IIS SMTP to handle application/Scanner relays into office 365.
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now