?
Solved

What is the reason to " Connection time out" whit Postfix??

Posted on 2008-11-04
4
Medium Priority
?
2,052 Views
Last Modified: 2013-12-05
Hello, I am using Postfix in a OpenSuse box fresh install. This linux is a backup for my domain (NS and MX).  When I try to use this Postfix to send messages I always receive a Conection timed out.

I attached the mail log. Thanks for any help.


Nov  4 23:55:49 ns postfix/smtpd[5168]: connect from localhost[127.0.0.1]
Nov  4 23:55:49 ns postfix/smtpd[5168]: 6C7172C0A79: client=localhost[127.0.0.1]
Nov  4 23:55:49 ns postfix/pickup[4981]: 724182C0A7E: uid=0 from=<root@ns.abc.org>
Nov  4 23:55:49 ns postfix/cleanup[5157]: 724182C0A7E: message-id=<alpine.LNX.1.10.0811042354520.5159@ns.abc.org>
Nov  4 23:55:49 ns postfix/smtpd[5168]: disconnect from localhost[127.0.0.1]
Nov  4 23:55:49 ns postfix/qmgr[3037]: 724182C0A7E: from=<root@ns.abc.org>, size=621, nrcpt=1 (queue active)
Nov  4 23:56:19 ns postfix/smtp[5173]: connect to yahoo.com[68.180.206.184]:25: Connection timed out
Nov  4 23:56:31 ns postfix/qmgr[3037]: EC0842C0A7A: from=<root@ns.abc.org>, size=611, nrcpt=1 (queue active)
Nov  4 23:56:49 ns postfix/smtp[5173]: connect to yahoo.com[206.190.60.37]:25: Connection timed out
Nov  4 23:56:49 ns postfix/smtp[5173]: 724182C0A7E: to=<baratous@yahoo.com>, relay=none, delay=60, delays=0.07/0.01/60/0, dsn=4.4.1, status=deferred (connect to yahoo.com[206.190.60.37]:25: Connection timed out)
Nov  4 23:57:01 ns postfix/smtp[5175]: connect to yahoo.com[68.180.206.184]:25: Connection timed out
Nov  4 23:57:31 ns postfix/smtp[5175]: connect to yahoo.com[206.190.60.37]:25: Connection timed out
Nov  4 23:57:31 ns postfix/smtp[5175]: EC0842C0A7A: to=<baratous@yahoo.com>, relay=none, delay=19562, delays=19502/0.02/60/0, dsn=4.4.1, status=deferred (connect to yahoo.com[206.190.60.37]:25: Connection timed out)
0
Comment
Question by:Bayardo_Rivas
  • 2
4 Comments
 

Author Comment

by:Bayardo_Rivas
ID: 22883505
I forgot to give you my main.cf file:


sendmail_path = /usr/sbin/sendmail
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
setgid_group = maildrop
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/packages/postfix/samples
readme_directory = /usr/share/doc/packages/postfix/README_FILES
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = abc.org
mydomain = abc.org
mynetworks = 127.0.0.0/8 192.168.0.0/24 200.85.160.20
mynetworks_style = subnet
myorigin = $mydomain
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
program_directory = /usr/lib/postfix
relay_domains = abc.org, $mydestination, $mynetworks
inet_interfaces = all
masquerade_domains = abc.org
defer_transports =
disable_dns_lookups = yes
relayhost =
content_filter =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access, permit_mynetworks
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases,hash:/var/lib/mailman/data/aliases
local_recipient_maps = proxy:unix:passwd.byname $alias_maps
mailbox_size_limit = 0
message_size_limit = 10240000
html_directory = /usr/share/doc/packages/postfix/html

Open in new window

0
 
LVL 43

Expert Comment

by:ravenpl
ID: 22883937
I suspect it's not postfix problem anyhow.

try: telnet yahoo.com 25 # any luck?

Now, verify if Your server's IP is blacklisted on some of those (in)famous dnsbl.
Start from http://www.kloth.net/services/dnsbl.php , google others
0
 
LVL 2

Accepted Solution

by:
antoniogc earned 2000 total points
ID: 22890604

Chance setting "disable_dns_lookups" to "no" or comment it. Other wise postfix try to get record "A", not the "MX" one. Check the man.

 http://www.postfix.org/postconf.5.html


0
 

Author Closing Comment

by:Bayardo_Rivas
ID: 31513421
Exactly, this is the solution. Once i set "disable_dns_lookups" to "no" everything is working fine.

More info uust for help to others. My server is behind a router and my postfix is a MX backup for my domain.

The "disable_dns_lookups" directive must be set to yes only if you are using other server to send messages.

Thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
We aren’t perfect, just like everyone else.  Check out the email errors our community caught and learn the top errors every email marketer should avoid.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses
Course of the Month15 days, 12 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question