How to perform Group Policy software installation on wireless clients?

Hi,

I've created a gpo to roll out a software installation to our network. On the desktops it works fine, but on the wireless laptops nothing happens (since they're not connected to the network til the user logs on). Can anyone tell me how to get round this? (other than plugging in a network cable during boot up)

- Lenny
Mad_LennyAsked:
Who is Participating?
 
JaredJ1Connect With a Mentor Commented:
Unfortunately the only way for it to work with wireless is to get an expensive wireless solution that supports 802.11x and use certficate based authentication. The domain based laptops will then be able to connect to the wireless network before users login. Probably not a realistic option though.

0
 
Brian PiercePhotographerCommented:
They must be on the domain before the user logs on - otherwise the user could not log on - that said, you could try assigning the software to the users rather than assigning it to the computers.
0
 
Mad_LennyAuthor Commented:
Thanks guys, I've been reading about some kind of Pre-Logon configuration you can do...but havent found a definitive article yet.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Mad_LennyAuthor Commented:
OK - have cracked it. Under Computer Configuration in the gpo editor i also enabled the 'Administrative Templates \ Network \ Network Connections \  IEEE802.1x Certificate Authority for Machine Authentication' setting, entered a random Certificate Authority Hash (sausages) and hey presto when i rebooted the test laptop the software installed pre-logon

Also made sure that the wireless network connection properties were configured:

http://www.experts-exchange.com/Networking/Windows_Networking/Q_22150511.html
0
 
JaredJ1Commented:
Told ya - 802.11x rocks!
0
 
dcadlerCommented:
Mad_Lenny,

All you had to do was enable that GPO you described? You dodn't have to configure your access points for 802.11x?

Dave
0
 
DowerCommented:
dcadler

I am having the same issue. I assume that Mad_Lenny's network was already configured for 802.1x authentication? Does anyone else have this issue?

Thanks

Dowerr
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.