inetd offline in solaris

In Solaris 10 SPARC server, inetd service is offline. I am unable to start the services and as a result all the network services like telnet, ssh, ftp etc.. are not running, hence I am unable to connect to the server remotely.
Deepti_vobilineniAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Hi,
did you look at /var/adm/messages?
Do you find there messages related to inetd?
 
wmp
0
awa2008Commented:
hello

in solaris 10  there is special coommand for that

if you want telnet for example

type :
inetadm | grep telnet

you must see disabled

then do

inetadm -e telnet

or the exact name you see on the line the command before

and then normally telnet is active now

to see that redo  the first command

inetadm | grep telnet

and see enabled online ¨¨
Regards
0
Deepti_vobilineniAuthor Commented:
I have already run the command "inetadm -e svc:/network/telnet:default". This dint work.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

woolmilkporcCommented:
Hi,
without knowing the error messages we won't be able to help, I guess.
So, please, look at  /var/adm/messages or wherever your message log is.
wmp
0
awa2008Commented:
you must check if inetd service run

with svcs command

svcs -a | grep inet

and with svcadm command start it if disabled

I hope that help you

0
RowleyCommented:
Post the output of:

svcs -x inetd

This will give you extended attributes including its state, and a reason for being in that state. Example:

bash-3.2# svcadm disable inetd
bash-3.2# svcs -x inetd
svc:/network/inetd:default (inetd)
 State: disabled since  5 November 2008 11:45:47 GMT
Reason: Disabled by an administrator.
   See: http://sun.com/msg/SMF-8000-05
   See: inetd(1M)
   See: /var/svc/log/network-inetd:default.log
Impact: 5 dependent services are not running.  (Use -v for list.)
0
Brian UtterbackPrinciple Software EngineerCommented:
First, check the status of the inetd service with this command:

 svcs -x svc:/network/inetd:default

If it is disabled, then enable it with this command:

svcadm enable svc:/network/inetd:default

Then do the svcs command again. If it is now in maintenance mode or it was in maintenance before,
look for the reason. It will possible say that there is a prerequisit service that is also not running, or it
will say to look in the file /var/svc/log/network-inetd:default.log. If the latter, take a look there.  The next step
depends on what you find.
0
TintinCommented:
There are very few services that run via inetd in Solaris 10.  ssh certainly doesn't and I'm pretty sure ftpd doesn't either.
0
SaranyakkaliCommented:
are you getting any errors...

svcs -xv

and post me.. so that i can assist you..

0
Deepti_vobilineniAuthor Commented:
Hi,

Below is the output of the command "svcs -x -v inetd",

svc:/network/inetd:default (inetd)
 State: offline since Fri Dec 05 06:49:45 2008
Reason: Service svc:/network/dns/client:default has missing dependencies.
   See: http://sun.com/msg/SMF-8000-GE
  Path: svc:/network/inetd:default
          svc:/milestone/name-services:default
            svc:/network/dns/client:default
   See: man -M /usr/share/man -s 1M inetd
Impact: 3 dependent services are not running:
        svc:/milestone/multi-user:default
        svc:/milestone/multi-user-server:default
        svc:/system/zones:default
0
RowleyCommented:
Now check what the problem is with the dns client service:

svcs -x svc:/network/dns/client:default
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Deepti_vobilineniAuthor Commented:
Now the inetd services are up and running.

The problem was with /etc/resolv.conf file.

Thank you.
0
RowleyCommented:
It seems to me like we helped this user track down the cause of the problem. This, in my view and going by the grading recommendations would indicate at minimum a grade B answer.
0
RowleyCommented:
OK...all is forgiven.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.