Linux Mailserver POSTFIX as MTA

Dear Sir/Madam:

I have mail server in redhat enterprsie linux POSTFIX as an MTA and dovecot imap,  for the web access iam using squirrelmail but when the mail is sent from the squirrelmail users are receiving as username.localhost.domainname.com
1, please tell me how to make only as username.domainname.com
2, in the webmail (squirrelmail)sent folder i can see username.localhost.com
please tell me in this.







D_wathiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fosiul01Commented:
whats in your /etc/hosts file ??

it should be   domain.com

127.0.0.1  yourdomain.com  localhost localhost.localdomain
0
D_wathiAuthor Commented:
sir , i just changed it to

127.0.0.1 mail.domainname.com  mail localhost.localdomain localhost

please tell me is this correct or should i change it.
0
fosiul01Commented:
ok if your mx record say primary mailserver is mail.domainname.com

then its seems right.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

D_wathiAuthor Commented:
also after this change when the mail is sent from the webmail(squirrelmail) still the users receive as username.localhost.domainname.com , please help me to solve this .
0
fosiul01Commented:
i setup squirrelmail onece, as far i know , when you configure squirrelmail first time, you had to give him the domain name information

can you check the server configuration of squirrelmail, see if you can insert domain.com by hand or not.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fosiul01Commented:
check thsi one

http://www.nabble.com/SM-Appends-the-Wrong-Domain-td19442861.html

as i said, you will have to check server configuration for squirrelmail.
0
bevhostCommented:
In SquirrelMail, goto

Options -> Personal Information

set the email address and Users Full name in there.

Also, if the users login with their email address as their username, then is will be set correctly from the start.
But this depends on who you setup the authentication.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.