microsoft, microsoft exchange will not router e-mail to assigned user

We have microsoft exchange handling mail from 5 different domains, eg *@mydomain.com, *@hisdomain.co.uk etc.

Initially the MX records pointed to the public ip address of the server and all worked well..... mail sent to info@anyofthedomains.com were forwarded via the exhange server to the appropriate user.  

Now with with horrendous spam problems we have decided to change the mx records of the domains and point them back to the ISP's mail software.

We have create mail forwarding accounts from all the live e-mail accounts from the various domain and are forwarding them all to 'allmail@primarydomain.com, (bouncing all mail and undeliverable)

We now get the exchange server to collect from thepop account called allmail@primarydomain.com, which it does fine,  and it forwards all the *@primarydomain.com mail to the correct users, however it sends all other mail to the administrator@primarydomain.com.

Any suggestions would be appreciated.

johnkcarsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AdamRobinsonCommented:
There is a setting in Exchange to forward all mail that is not to your userlist to the administrator account.  It sounds like you have this checked.  Unless you're regularly monitoring such mail for some reason, you may want to just turn that off.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnkcarsonAuthor Commented:
Where is this setting please ??
0
AdamRobinsonCommented:
Exchange System Manager -> Servers -> Servername -> Protocols -> SMTP -> Right click Default SMTP Virtual Server -> Click Properties -> Messages Tab -> make sure administrator@yourdomain.com isn't in the "forward all mail with unresolved recipients" box.
0
johnkcarsonAuthor Commented:
Unfortunatley there are no addresses in the "forward all mail with unresolved recipients"

Two additional pieces of information:

When I look at the summary of the 'Default Microsoft Exhange Services is show Stopped under Critical, however when you look at the services they are all running... have stopped and restarted all service but still shows Stopped.


0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.