Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 617
  • Last Modified:

Changed ACPI driver in device manager, rebooted, can't find ntfs.sys anymore!

Hi guys,

I have a Windows Server 2003 SP1 system.  It's using an intel ICH8R SATA RAID controller.  I originally had a piece of software (Ardence RTX) that required the ACPI driver to be set to uniprocessor.  A new version of RTX is now available, and it supports multi-core CPUs.  I performed the following steps:

1.  Removed RTX,
2.  Rebooted -- system booted fine
3.  Changed ACPI setting from Uniprocessor ACPI PC to Multiprocessor ACPI PC
4.  Rebooted -- system fails to boot, presents the following message:

 Windows could not start because the following file is missing or corrupt: System32\Drivers\Ntfs.sys

I'm not sure exactly what happened.  I tried the troubleshooting steps listed here (http://support.microsoft.com/kb/822800), but they didn't help.  The ntfs.sys file on disk and the one on my Windows 2003 disc are identical at a binary level according to a file comparison program that I have.

Does anyone know how I can revert to the old uniprocessor ACPI HAL driver in order to get the system to boot again?

Thanks!
0
TomPro
Asked:
TomPro
1 Solution
 
Netman66Commented:
You can't change the HAL like that.  I'm not certain we can recover this properly.

Have you tried Last Known Good Configuration from the F8 menu?

0
 
TomProAuthor Commented:
I ended up wiping the disk and re-staging the system.  Lesson learned:  don't change the HAL unless you know it's absolutely necessary.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now