• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2152
  • Last Modified:

Cisco MWI stays on red after voice mail is deleted

I have a problem with Cisco Unity Express Version 4.1 with MWI when I recieve voice mail for all my users the MWI stays red on the phone and does not go off.

Below is run configure

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SCL2851
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$vxe1$LGY2a7paEmN8bUPsp332s0
!
no aaa new-model
!
resource policy
!
clock timezone London 0
clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
network-clock-participate wic 0
!
!
ip cef
ip dhcp excluded-address 10.103.255.30 10.103.255.254
ip dhcp excluded-address 10.103.248.200 10.103.248.254
!
!
!
isdn switch-type basic-net3
!
voice-card 0
 no dspfarm
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 h323
 sip
  registrar server expires max 3600 min 3600
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^455082/ /208/
!
voice translation-rule 9
 rule 1 /^911$/ /911/
 rule 2 /^9\(.*\)/ /\1/
!
!
voice translation-profile Incoming
 translate called 1
!
!
!
!
username level15
username citylearning privilege 15 secret 5 $1$Z5bE$C02bQvdO4KDOBnyaAcBK20
!
!
class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
class-map match-all SIP
 match protocol sip
class-map match-all RTP
 match protocol rtp
!
!
policy-map EthOut
 class RTP
policy-map output-L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description $ES_LAN$
 no ip address
 no ip mroute-cache
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.20
 description ** Data VLAN **
 encapsulation dot1Q 20 native
 ip address 10.103.248.254 255.255.0.0
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.103.248.254
!
interface GigabitEthernet0/1.100
 description ** Voice VLAN **
 encapsulation dot1Q 100
 service-policy output output-L3-to-L2
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn tei-negotiation first-call
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing-voice info-transfer-capability 3.1kHz-audio
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn outgoing-voice info-transfer-capability 3.1kHz-audio
 isdn static-tei 0
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1.20
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
!
!
tftp-server flash:P00307020200.sbn
tftp-server flash:P00307020200.bin
tftp-server flash:cmterm_7920.4.0-02-00.bin
tftp-server flash:P00307020200.sb2
tftp-server flash:P00307020200.loads
tftp-server flash:S00104000100.sbn
!
control-plane
!
!
!
voice-port 0/0/0
 input gain -3
 output attenuation 5
 compand-type a-law
!
voice-port 0/0/1
 input gain -3
 output attenuation 5
 compand-type a-law
!
!
!
!
dial-peer cor custom
 name internal
 name local
 name domestic
 name international
 name 900
 name 976
!
!
dial-peer cor list call-internal
 member internal
!
dial-peer cor list call-local
 member local
!
dial-peer cor list call-domestic
 member domestic
!
dial-peer cor list call-international
 member international
!
dial-peer cor list call-900
 member 900
!
dial-peer cor list call-976
 member 976
!
dial-peer cor list user-internal
 member internal
!
dial-peer cor list user-local
 member internal
 member local
!
dial-peer cor list user-domestic
 member internal
 member local
 member domestic
!
dial-peer cor list user-international
 member internal
 member local
 member domestic
 member international
!
dial-peer cor list user900-internal
 member internal
 member 900
 member 976
!
dial-peer cor list user900-local
 member internal
 member local
 member 900
 member 976
!
dial-peer cor list user900-domestic
 member internal
 member local
 member domestic
 member 900
 member 976
!
dial-peer cor list user900-international
 member internal
 member local
 member domestic
 member international
 member 900
 member 976
!
!
dial-peer voice 1 pots
 description ** BRI pots dial-peer **
 destination-pattern 911
 port 0/0/0
 forward-digits all
!
dial-peer voice 2 pots
 description ** BRI pots dial-peer **
 destination-pattern 9911
 port 0/0/0
 forward-digits 3
!
dial-peer voice 3 pots
 corlist outgoing call-local
 description ** BRI pots dial-peer **
 destination-pattern 9T
 port 0/0/0
!
dial-peer voice 4 pots
 corlist outgoing call-domestic
 description ** BRI pots dial-peer **
 destination-pattern 91T
 port 0/0/0
!
dial-peer voice 5 pots
 corlist outgoing call-international
 description ** BRI pots dial-peer **
 destination-pattern 9011T
 port 0/0/0
 prefix 011
!
dial-peer voice 6 pots
 corlist outgoing call-900
 description ** BRI pots dial-peer **
 destination-pattern 91900.......
 port 0/0/0
!
dial-peer voice 7 pots
 corlist outgoing call-976
 description ** BRI pots dial-peer **
 destination-pattern 91976.......
 port 0/0/0
!
dial-peer voice 8 pots
 description ** BRI pots dial-peer **
 translation-profile incoming Incoming
 incoming called-number .
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 9 pots
 description ** BRI pots dial-peer **
 destination-pattern 911
 port 0/0/1
 forward-digits all
!
dial-peer voice 10 pots
 description ** BRI pots dial-peer **
 destination-pattern 9911
 port 0/0/1
 forward-digits 3
!
dial-peer voice 11 pots
 corlist outgoing call-local
 description ** BRI pots dial-peer **
 destination-pattern 9T
 port 0/0/1
!
dial-peer voice 12 pots
 corlist outgoing call-domestic
 description ** BRI pots dial-peer **
 destination-pattern 91T
 port 0/0/1
!
dial-peer voice 13 pots
 corlist outgoing call-international
 description ** BRI pots dial-peer **
 destination-pattern 9011T
 port 0/0/1
!
dial-peer voice 14 pots
 corlist outgoing call-900
 description ** BRI pots dial-peer **
 destination-pattern 91900.......
 port 0/0/1
!
dial-peer voice 15 pots
 corlist outgoing call-976
 description ** BRI pots dial-peer **
 destination-pattern 91976.......
 port 0/0/1
!
dial-peer voice 16 pots
 description ** BRI pots dial-peer **
 translation-profile incoming Incoming
 incoming called-number .
 direct-inward-dial
 port 0/0/1
!
!
!
!
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00307020200
 load 7914 S00104000100
 load 7920 cmterm_7920.4.0-02-00
 max-ephones 96
 max-dn 192
 ip source-address 10.103.248.254 port 2000
 caller-id block code *916
 calling-number initiator
 service phone videoCapability 1
 system message SNCLC
 time-zone 21
 date-format dd-mm-yy
 voicemail 600
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh music-on-hold.au
 web admin system name cme secret 5 $1$WQEF$6FnBvKeo44cElD6QxX4JA/
 dn-webedit
 time-webedit
 transfer-system full-consult dss
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp 7960 Sep 09 2008 16:42:26
!
!
ephone-dn  1
 number 101
 name IP-Paging1
 paging ip 239.1.1.1 port 2000
!
!
ephone-dn  2
 number 102
 name IP-Paging2
 paging ip 239.1.1.2 port 2000
!
!
ephone-dn  3  dual-line
 number 201
 pickup-group 1
 label 201
 description Finance
 name Finance
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming user900-international
!
!
ephone-dn  4  dual-line
 number 202
 pickup-group 1
 label 202
 description Phil
 name Phil
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming user900-international
!
!
ephone-dn  5  dual-line
 number 203
 label 203
 description Finance2
 name Finance2
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming call-local
!
!
ephone-dn  6  dual-line
 number 204
 label 204
 description Dave
 name Dave
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming user900-international
!
!
ephone-dn  7  dual-line
 number 205 secondary 011424550824
 label 205
 description Sue
 name Sue
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming call-local
 corlist outgoing call-local
!
!
ephone-dn  8  dual-line
 number 206 secondary 4085551005
 label 206
 description User6
 name User6
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming user900-international
!
!
ephone-dn  9  dual-line
 number 207 secondary 4085551006
 label 207
 description User7
 name User7
 call-forward busy 600
 call-forward noan 600 timeout 15
 corlist incoming user900-international
!
!
ephone-dn  10  dual-line
 number 208 secondary 01142455082
 label 208
 description Reception
 name Reception
 call-forward busy 600
 call-forward noan 501 timeout 10
 corlist incoming user900-international
!
!
ephone-dn  12
 number 600
 name VOICEMAIL1
 no huntstop
!
!
ephone-dn  13
 number 600
 name VOICEMAIL2
 preference 1
 no huntstop
!
!
ephone-dn  14
 number 600
 name VOICEMAIL3
 preference 2
 no huntstop
!
!
ephone-dn  15
 number 600
 name VOICEMAIL4
 preference 3
 no huntstop
!
!
ephone-dn  16
 number 600
 name VOICEMAIL5
 preference 4
 no huntstop
!
!
ephone-dn  17
 number 600
 name VOICEMAIL6
 preference 5
 no huntstop
!
!
ephone-dn  18
 number 600
 name VOICEMAIL7
 preference 6
 no huntstop
!
!
ephone-dn  19
 number 800
 name VOICEMAIL8
 preference 7
 no huntstop
 mwi on
!
!
ephone-dn  20
 number 801
 mwi off
!
!
ephone-dn  21
 number 701
 park-slot
!
!
ephone-dn  22
 number 702
 park-slot
!
!
ephone  1
 video
 mac-address 0021.5553.ECFB
 username "fin" password 201
 speed-dial 1 208 label "Reception"
 paging-dn 1
 type 7940
 button  1:3
!
!
!
ephone  2
 video
 mac-address 0021.5553.ECB2
 username "phil" password 202
 speed-dial 1 208 label "Reception"
 paging-dn 1
 type 7940
 button  1:4
!
!
!
ephone  3
 video
 mac-address 0021.5553.E9C0
 username "fin2" password 203
 speed-dial 1 208 label "Reception"
 paging-dn 1
 type 7940
 button  1:5
!
!
!
ephone  4
 video
 mac-address 0021.5553.E70C
 username "Dave" password 204
 speed-dial 1 208 label "Reception"
 paging-dn 1
 type 7940
 button  1:6
!
!
!
ephone  5
 video
 mac-address 0021.5553.E724
 username "Sue" password 205
 speed-dial 1 208 label "Reception"
 paging-dn 1
 type 7940
 button  1:7
!
!
!
ephone  6
 video
 mac-address 0021.553F.0D65
 username "user6" password 206
 paging-dn 1
 type 7920
 button  1:8
!
!
!
ephone  7
 video
 mac-address 0021.553F.0DA4
 username "user7" password 207
 paging-dn 1
 type 7960
 button  1:9
!
!
!
ephone  8
 video
 mac-address 0021.5553.DA43
 username "Reception" password 208
 speed-dial 1 201 label "Finance"
 speed-dial 2 202 label "Phil"
 speed-dial 3 203 label "Finance2"
 speed-dial 4 204 label "Dave"
 speed-dial 5 205 label "Sue"
 type 7960 addon 1 7914
 button  1:10
 night-service bell
!
!
!
ephone  10
 vm-device-id CiscoUM-VI1
 button  1:10
!
!
!
ephone  11
 vm-device-id CiscoUM-VI2
!
!
!
ephone  12
 vm-device-id CiscoUM-VI3
 button  1:12
!
!
!
ephone  13
 vm-device-id CiscoUM-VI4
 button  1:13
!
!
!
ephone  14
 vm-device-id CiscoUM-VI5
 button  1:14
!
!
!
ephone  15
 vm-device-id CiscoUM-VI6
 button  1:15
!
!
!
ephone  16
 vm-device-id CiscoUM-VI7
 button  1:16
!
!
!
ephone  17
 vm-device-id CiscoUM-VI8
 button  1:17
!
!
ephone-hunt 1 sequential
 pilot 501
 list 201, 202, 203, 204, 205, 206, 207
 final 600
 timeout 8, 8, 8, 8, 8, 8, 8
 statistics collect
!
!
ephone-hunt 2 sequential
 pilot 502
 final 600
 statistics collect
!
!
!
line con 0
line aux 0
line vty 0 4
 password P@ssw0rd
 login
!
scheduler allocate 20000 1000
ntp master
ntp server 10.103.248.254
!
end
0
highlanderit
Asked:
highlanderit
  • 2
1 Solution
 
dgboydCommented:
Hi, it looks like you have left the dots (...) off the mwi ephone-dn.  You should have three dots after the extension number like I have added below.  In CUE, make sure you have Outcalling checked and the MWI number should be 800... and 801...  Make the changes below first and then check it in the CUE GUI.  

Let me know if this helps.

David

ephone-dn  19
 number 800...
 name VOICEMAIL8
 preference 7
 no huntstop
 mwi on
!
!
ephone-dn  20
 number 801...
 mwi off
!
0
 
highlanderitAuthor Commented:
Thanks for that I will try this tomorrow and submit tomorrow
0
 
highlanderitAuthor Commented:
Missing the following statements now all working
dial-peer voice 4400 voip
 description ==== VOICEMAIL ACCESS ====
 translation-profile outgoing tovm
 destination-pattern 4400
 session protocol sipv2
 session target ipv4:10.103.248.253
 incoming called-number 800T
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now