How can I setup the sonicwall tz170 to allow RDP on the failover connection?

I have a Sonicwall Tz170, i have it setup to allow RDP on the primary Wan connection. But I cant get RDP to work when the primary connection goes down and the failover connection takes over.
LVL 1
rodneygrayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dpk_walCommented:
How have you specified the the rule to forward the incoming RDP packets to the server. Do you get any log in Sonicwall that the RDP Traffic was denied when the failover happens.

Please update.

Thank you.
0
bignewfCommented:

Make sure the failover connection is configured just like the primary connection:

Statically map the server with a public ip from the failover circuit, either with its own seperate ip or using NAT(with the public interface ip of the sonicwall as the ip address of the rdp server).  You can do this with the public server wizard. Make sure you configure an inbound access rule that allows rdp port 3389 inbound to this static mapping.  Call this NAT rule something like "failover terminal server"  The firewall needs to have this secondary static (or NAT) translation to the failover ip address, so in the event the primary circuit goes down, it knows which outside ip to allow traffic to the terminal (rdp) server. The access list to allow inbound traffic on port 3389 must also correspond to the failover ip address so it knows how to allow traffic to the failover ip when the primary circuit goes down.
The sonicwall has a configuration for a failover internet circuit, so make sure you have these failover forwarding rules.
This procedure is the same for a server that you want failover for  the sonicwall needs to know how to map the outside ip to allow traffic to a tcp or udp service  i.e.  port 25 for mail, port 21 for ftp, etc.
Make sure logging is enabled, then test the connection by powering down the primary circuit


Hope this helps, and next time please paste your configuration so I can view it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.