CISCO Bridge 1300 series IOS command line question: Clock timezone command giving invalid input error

I'm troubleshooting some connectivity problems on two Cisco Wireless Bridges (1300 series) and am trying to get my logging set up in a useful way first. My first goal is to get the two bridges to display the same time in the logs, so that I can compare them easily.

After telnetting in, I reset the time using the set clock command to the same time, and that went fine.

I then tried to use the clock timezone command
clock timezone CST -6 to get the two bridges using the same time.
When I did that, I got, %Invalid input detected at marker, and the marker showed beneath the "t" in the word timezone.
I'm confused as to how to use this command, since I think I'm following the instructions from Cisco's help pretty explicitly.


Here's some background on how the time is set up on each bridge, in case anyone wants to comment on my larger goal of getting the times somewhat synced in the two logs. (I realize they could be getting the time from a definitive source, but i'm choosing to set the time manually for simplicity sake. )

Bridge 2's log (from the browser interface) was displaying the UTC time and was 6 hours off of local time ex: Nov 5 15:27:28.884 UTC. On the CLI, show clock returns 09:27:10.074 GMT Wed Nov 5 2008, which is the correct local time, though our timezone is CST.

Bridge 1's log (from the browser interface) was displaying correct local time with no timezone specified ex: Nov 5 09:21:09.416. On the CLI, show clock returns 09:21:41.194 UTC Wed Nov 5 2008.




youngslimAsked:
Who is Participating?
 
dkarpekinConnect With a Mentor Commented:
After each good know comand use "?" see following option availability.
You can set one of the router as an NTP server for your AP, and have this router pull time of somewhere else, or just hardware.
0
 
jermaingCommented:
If i recall correctly, commands are case sensitive. Try using a different case for the timezone command.
0
 
youngslimAuthor Commented:
I did that, and it showed that the only option is "set" to "set the time and date"

Looking at the Cisco Guide for this box
http://www.cisco.com/en/US/docs/wireless/access_point/1300/12.2_15_JA/configuration/guide/o13adm.html#wp1036928

shows me that i can use clock to set the timezone, but first I have to go into configure terminal mode. Then the timezone option will be available to me. I did it this way and things worked as expected.

The Question Mark was a hint to the answer, but not really the whole answer.


I copied the info below.

Step 1  
 configure terminal ( Enter global configuration mode. )
 
Step 2  
 clock timezone zone hours-offset [minutes-offset]  ( Set the time zone. )

The access point/bridge keeps internal time in universal time coordinated (UTC), so this command is used only for display purposes and when the time is manually set.

"For zone, enter the name of the time zone to be displayed when standard time is in effect. The default is UTC.

"For hours-offset, enter the hours offset from UTC.

"(Optional) For minutes-offset, enter the minutes offset from UTC.
 
Step 3  
 end
 Return to privileged EXEC mode.
 
Step 4  
 show running-config
 Verify your entries.
 
Step 5  
 copy running-config startup-config
 (Optional) Save your entries in the configuration file.
 

0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
dkarpekinCommented:
It might be simle just use SDM, not to look for "proper" command, and see in CLI, what code is executed.
0
 
youngslimAuthor Commented:
What's the fair thing as far as points? I'm happy to give them all to you, but not sure what the ethos is when someone points you to the right answer, but doesn't give you right answer.
0
 
dkarpekinCommented:
At your jugment.
0
 
youngslimAuthor Commented:
simle just use SDM? please explain,
0
 
dkarpekinCommented:
Sorry , did not realize right away, that you miss "config t" it is essential.
You config colcks in SDM, and than go back to CLI see what command was iisued.........will help clear confusing what commands nneds to be used for certain purposes, can help you now and in a future, using this comparing og GUI and CLI.
SDM-for-NTP.JPG
0
 
youngslimAuthor Commented:
What is SDM? Sorry, this is a new area for me.
0
 
youngslimAuthor Commented:
SDM is the Security Device Manager (which we don't have).

Anyway - I got what I needed. Thanks,

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.