DNS, nslookup and ping -n slow, sometimes.

I have one server running win2003 r2. It is the single AD and DNS a small network or 10 PC's. It was done for central administration of these machines but im not so sure that was a smart move anymore.

This server has 2 nics, I have one configured for the small network (10.x.x.x)with the dns setting pointing to itself, this DNS server is forwarded to out corporate DNS server.

The other nic on this machine is configured for the larger more public (192.x.x.x  intranet) lan segment, but not plugged into anything yet. Its purpose will be more public  (i.e. browser based) IIS presentation of information taken from the other, more locked down segment.

There are 2 other servers so far and they are just servers, no dns nothing else, they run a program that must be run on server platform. these both have 2 nics also, one 10.x.x.x and the other 11.x.x.x. The 11.x.x.x is a fiber nic that only goes to the other server, it is used exclusively for these two machine to sync their proprietary databases to each other.

The problem I am having is name resolution is slow, sometimes. I can sometimes ping and get <1ms response and everything is snappy and quick. Other times I get <44ms response and I have name resolution and general sluggish performance problems.

I can't locate any thing that would be variable in this way. I have the 2 servers pointing to the main server for DNS, the main server points to itself for DNS, and that DNS uses a forwarder. web browsing works.

This is intermittent but frequent.

All I can imagine is that the double NICs are somehow confounding this situation. But I am out of ideas. IS it possible that teh 2 servers are somehow sending DNS through the fiber link to each other and it's not getting out?  Would someone give me some
tests to run that can help locate the issue?

BTW all IP's are static so I could use a host file but since I can ping-n and get delayed results as well, I don't think that would fix this.
LVL 1
Salad-DodgerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RowleyCommented:
Have you managed to monitor network and system activity on these systems? Do you have any performance data? Assuming you've checked all application and system logs and there is nothing obvious glaring out at you, it's going to be difficult ascertaining what the issue is without having some kind of chronological system performance data.

Is there a lot of data that gets synced over the private interconnects? Are there any regular db maintenance or scheduled jobs?
0
RowleyCommented:
Just to add, the name resolution/ping issues you are seeing may the effects, but not necessarily the cause of your problem.
0
Salad-DodgerAuthor Commented:
The Syncing only occurs when the application runs and this symptom is there even when that app isn't running. The event log shows occasional 8032 and 8021 events, But search the web reveals that these 2 errors are very common.

What can I measure to give you more information?
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

RowleyCommented:
Information such as disk activity, memory and processor (system and kernel) utilisation, network activity, paging activity etc would all be useful in troubleshooting. You should be able to get most of this information from perfmon and will help you build up a picture of what is happening. You'll need to collect data over time.

Also, check your interfaces, ensure they are set to correct speeds and duplex settings, as well as check your switches loads. Hey, you may even have a faulty cable, nic port, switch, router...

Check everything you can along the path.
0
Salad-DodgerAuthor Commented:
I made a change and it seems to have worked for the moment, though I don't know why.  I changed the DC's NIC DNS address to 127.0.0.1 from it's own address. Seems to me that isn't really a change as they both point to the same thing, but it worked immediatly.  Alas it is a sporadic condition so we have to see if that luck holds.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Salad-DodgerAuthor Commented:
This didnt solve the problem. Its back with a vengance
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.