[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 836
  • Last Modified:

Users can't add network printer from a Windows 2000 print server.

Odd thing just popped up.  I moved a network printer from a 2003 server to a 2000 server.  It's been installed, tested to work, and shared, but when I try to add it for users on XP workstations, I get the message "A policy is in effect on your computer which prevents you from connecting to this print queue. Please contact your system administrator."

Never seen this message before, and I'm not really sure what it could be.  I've read few things mentioning policys, but if it was policy causing the problem then why wouldn't we have run into it before?
0
Go-GBS
Asked:
Go-GBS
  • 6
  • 4
  • 2
1 Solution
 
sliiconmanCommented:
0
 
sliiconmanCommented:
Also did you update your printer drivers to 2003 version. Also try chaging the print processor to the windows print processer under the printer.
0
 
sachiorossCommented:
If the above items don't work, I'd also make sure to check the following:

1.  You've granted the appropriate permissions for the printer(via the Printer's Permissions) for everyone (i.e. "Everyone" has access to print documents, pause, restart, resume and cancel their own documents, and connect to printer).  

2.  You've also done the same for the "spool" folder, located in '%SystemRoot%\system32\spool\PRINTERS' by default.  According to the MS Windows 2000 pocket admin manual: "all users who access the printer must have Change permissions on this directory."

You can easily find the location of the spool directory by checking 'Printers -> Server Properties -> Advanced -> [location of spool folder will be noted]'.  

Goodluck.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Go-GBSAuthor Commented:
I tried that policy but got the same result.  I have found that if I first login and add the printers with admin rights, it will then allow me to add the printer for the user.
0
 
Go-GBSAuthor Commented:
If I followed your instructions correctly, I gave authenticated users Modify permissions on the PRINTERS or the spool folder.
0
 
Go-GBSAuthor Commented:
Sorry, forgot to say that it did not work.
0
 
sachiorossCommented:
If you can install/add the printer with admin rights then it sounds like the overall group policy has the "install printers" or "install hardware/ software" rights denied for the User group of the aforementioned users.  I'd check your group policy settings (this time not the printer properties, but the overall domain group policy settings) and ensure that the group does have the ability to add printers.

Our organization (a university) doesn't allow users to add printers unless they have specific admin rights to the machine, and that's set via group policy.
0
 
sachiorossCommented:
And check this article, hopefully it helps a little...

http://support.microsoft.com/kb/307882

0
 
Go-GBSAuthor Commented:
My question is, people could add these printers w/o problem when they were on a Server 2003 print server, so would these policies only come into play once there trying to add from a Server 2000 print server?
0
 
sachiorossCommented:
Honestly, I can't answer that question fully.  I can only speculate.  I don't have enough experience with group policy yet to know how different they are between 2000 and 2003.  

The domain group policy should control the issues you're speaking of.  There might be specific settings on the Server that need to be overridden, but being that you can add the printers as an administrator but they can't as a user typically indicates it's a setting distinctive to the user or the user's group.  This is especially the case when you can replicate the exact same problem and work-around (add/install as admin) on the other XP systems.  

To further explore the above line-of-thought: on the user's computer, while logged in as the user, go to run and type "mmc."  Click on file and "add/remove snap-in."  On the first tab (standalone), click on "Add."  Look for: Group Policy Object Editor, select it, select local computer, and click add.  Under the policy snap-in, expand User Configuration, expand Administrative templates, expand Control Panel, and then select Printers.  Double check the settings there and see if they make sense.  

The only other thing I can think of is that maybe the 2003 server used a post-script only or other option in which the users didn't actually install any drivers, but simply mapped to the printer on the server (i.e. all drivers on server only), whereas the 2000 server might require that you have the print drivers installed on the machine that's connecting and therefore they actually have to add the drivers which would then invoke the group policy.  

I apologize, but anything further then the speculation above is beyond my current level of knowledge, and my gut-feeling on this is some sort of policy restriction.

Goodluck, and if none of the above helps then I do hope someone more knowledgeable than I can assist you in this issue.
0
 
Go-GBSAuthor Commented:
I appreciate the help, I'm going to mess around with the policies later on today.
0
 
Go-GBSAuthor Commented:
In the accepted solution above, setting the policy to disabled fixed the problem.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 6
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now