?
Solved

CRM 4 unable to generate reports - An error occured

Posted on 2008-11-05
24
Medium Priority
?
1,230 Views
Last Modified: 2012-05-05
We migrated from CRM 3 to CRM 4 a week or two ago and all functionlity was working after deployment.  We especially took notice to ensure our Reports were generating properly.

Now when we generate reports we get the error which I attached from a screeen shot.
crmreporting.jpg
0
Comment
Question by:sknoll84
  • 13
  • 11
24 Comments
 

Author Comment

by:sknoll84
ID: 22888253
I realized that CRM reporting was working fine until we had to make some URL changes because the Outlook addin install was failing.  Now our Outlook addin is working properly because we were able to sort out the certificate problems, but reporting is broken.

I hopped into Deployment Manager and disabled the organization.  I then did an EDIT on the organization.  Here it asks for the Microsoft Dynamics CRM SRS Data Connector URL.  Currently we have http://servername/reportserver listed, but this doesn't even work in a browser so I know this is incorrect.

If I browse to https://organizationname.companyname.com/reportserver this works fine.
But when I list that URL into Deployment Manager, it fails to validate the specified Reporting Services Report Server.  The request failed with HTTP status 401: Unauthorized.

0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22889800
SRS is on the same box as CRM or different?

Is the same redirector being applied to that website?
0
 

Author Comment

by:sknoll84
ID: 22889885
srs is on the same box, yes.  No redirection is in place for the https://organizationname.companyname.com/reportserver url as it is the primary crm url (organization name---needed for the external facing deployment).  We only have a redirection in place for https://crm.companyname.com as it is easy for our sales people to remember.  

for whatever reason when we try to update the srs url in the deployment manager it throws the unauthorized error.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
LVL 15

Expert Comment

by:WilyGuy
ID: 22889931
there is a registry key in the HKLM|Software|Microsoft|MSCRM that has the same information (look for the old SRS URL and try to update it there).

Do you have the two app pools running with different identities?  if so, did you install the SRS Data Connector?
0
 

Author Comment

by:sknoll84
ID: 22889995
I did update the registry keys for [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\ServerUrl] and [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\SQLRSServerURL] to reflect the correct url.

I will check on the app pools and get back with you
0
 

Author Comment

by:sknoll84
ID: 22890059
i just verified that both the crm website and reportingservices virtual directory (under the crm site) both are in the same app pool.  however when i run a test connection on the report server, it fails during the authorization test...see error below....

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22890169
I assume you didn't set the ServerUrl to the SRS url, right?

so you have specified that SSL is required on the website that encompasses both? (is that website on port 80 or is your redirect site)?
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22890186
And all the current work is being done on the server (you are testing using the Internet Explorer on the CRM server?)

That's a good place to start, but be sure to test from external clients AFTER that.

Likely you will have to alter the DataSource in Report Manager, but don't do that yet.
0
 

Author Comment

by:sknoll84
ID: 22890230
Your assumption is correct, the correct urls are in the registry. Yes, ssl is required, hence port 443.  The other website on the server listens on port 80 and redirects to the correct mscrm url.
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22890749
I know we had the SQL query in a previous post, can you refresh my memory on those results?
0
 

Author Comment

by:sknoll84
ID: 22891072
organizationname.companyname.com
organizationname.companyname.com
organizationname.companyname.com
https



0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22891844
You may have to reconfigure SRS as when you set it up, likely you weren't using SSL and the relative paths aren't correct.

Can you open https://organizationname.companyname.com/reports ?

There is a flag in the configuration to indicate you are using SSL and it prompts you for the cert.
0
 

Author Comment

by:sknoll84
ID: 22891864
when we browse to that url we get:
Error
The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version.

what route would you go to reconfigure SRS?
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22891877
There should be a SQL Reporting Services configuration wizard in the Start | Programs | Microsoft SQL Server (or something like that)

Don't worry about the Database or the Windows Service.  Focus on the Reports and ReportServer tabs. (likely it will seem to screw up the Web Service, but that is easily fixed).

I believe the SSL is on the ReportServer tab.
0
 

Author Comment

by:sknoll84
ID: 22892032
See attached screen shot.  Within the config wizard there is a Report Server Virtual Directory and Report Manager Virtual Directory tab.

Report Server Virtual Directory gives us an option to check SSL.  I listed the certificate name and applied the changes.  The other tab does not give you any SSL options.

I restarted SQL services and tried to generate a report in CRM but receive the same error.
Maybe additional services need restarted, or did I list the certificate name wrong?
crm1.jpg
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22894015
The certificate name should be the organization.companyname.com
0
 

Author Comment

by:sknoll84
ID: 22894814
cert name was changed within the config wizard, services restarted, no dice.
does the cert need to be renamed anywhere else?
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22894988
Does Report Manager work?  basically CRM isn't likely to work until Report Manager works.

There is a config file in the Report Manager directory that indicates the URL for the Report Server.
0
 

Author Comment

by:sknoll84
ID: 22895436
while googling the report manager error, I found a site that recommended updating the RSWebApplication.config file under the <sql home>/reporting services/reportmanager.......i updated the reportserverurl.......  output below...note* url has a placeholder for security reasons

<Configuration>
      <UI>
            <ReportServerUrl>https://orgname.companyname.com/ReportServer</ReportServerUrl>
            <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
            <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>
      </UI>
      <Extensions>
            <DeliveryUI>
                  <Extension Name="Report Server Email" Type="Microsoft.ReportingServices.EmailDeliveryProvider.EmailDeliveryProviderControl,ReportingServicesEmailDeliveryProvider">
                        <DefaultDeliveryExtension>True</DefaultDeliveryExtension>
                        <Configuration>
                              <RSEmailDPConfiguration>
                                    <DefaultRenderingExtension>MHTML</DefaultRenderingExtension>
                              </RSEmailDPConfiguration>
                        </Configuration>
                  </Extension>
                  <Extension Name="Report Server FileShare" Type="Microsoft.ReportingServices.FileShareDeliveryProvider.FileShareUIControl,ReportingServicesFileShareDeliveryProvider"/>
            </DeliveryUI>
      </Extensions>
      <Add Key="MaxActiveReqForOneUser" Value="20"/>
      <Add Key="DisplayErrorLink" Value="true"/>
</Configuration>
0
 

Author Comment

by:sknoll84
ID: 22895493
how can we test the report manager other than browsing to the url?  Also, on the "Reports" virtual directory, authentication types are "asp .net impersonation" and "windows auth"...keep in mind this is server 2008 and iis7
0
 
LVL 15

Accepted Solution

by:
WilyGuy earned 1500 total points
ID: 22895570
OH.....did I miss that in other posts as well.  Server 2008 and IIS7 are relatively new, so that changes the googling a bit.

You may want to close this question, open a new one in the SQL arena (with CC to IIS and Server 2008 groups, not sure on the exact names, maybe even SSL).

I wouldn't make it a CRM question until Reports Manager is working correctly.

Or you can leave this one open and come back to it when all is well there.
0
 

Author Comment

by:sknoll84
ID: 22896131
I will open a new question in the SQL zone, but how exactly should I go about this new question....?

I understand we need to ensure report manager is working properly, but what all should we see working before we begin talking CRM again?
0
 
LVL 15

Expert Comment

by:WilyGuy
ID: 22896257
Well, lay out your OS and IIS versions, the fact that you are requiring SSL for Reporting services.  Your Report Manager doesn't work and gives you X error.

Once ReportServer comes up on the SSL from a different box AND the Reports (Report Manager) come up fine, I think we are safe to come back to CRM.
0
 

Author Comment

by:sknoll84
ID: 22900710
Im going to go ahead and give you the points since you stuck it out so long.  In the end we involved Microsoft.  Their SQL and CRM teams were both involved.  It got pretty in depth and I really can't say what the final solution was.....thanks for your assistance.  After the /reports url was resolved, there was a Data Source that had to be changed.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: Leon
Software Metering within our group of companies has always been an afterthought until auditing of software and licensing became a pain point. Orchestrator and SCCM metering gave us the answer and it was an exciting process.
Excel can be a tricky bit of software to get your head around. Whilst you’ll be able to eventually get to grips with the basic understanding of how to get by, there are a few Excel tips that not everybody will even know about let alone know how to d…
The viewer will learn how to simulate a series of coin tosses with the rand() function and learn how to make these “tosses” depend on a predetermined probability. Flipping Coins in Excel: Enter =RAND() into cell A2: Recalculate the random variable…
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
Suggested Courses

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question