• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 849
  • Last Modified:

Unable to start the TFTPD service on Windows 2003 server in order to PXE boot.

When trying to startt the TFTPD service in Windows 2003 server, I get error message Error 11004:The requested name is valid, but no data of the requested type was found. Tried to start it logged in as administrator but got same error.
1 Solution
I've not personally used Microsoft's built-in TFTP server (I use TFTPD32), but I did come across this while doing some research:
Instructions for extracting TFTPD and setting it up as a service:
(NOT tested by me, but poster said "this seems to work thanks!")

expand tftpd.ex_ %windir%\system32\tftpd.exe
del tftpd.ex_
instsrv tftpd %windir%\system32\tftpd.exe
reg add hklm\system\currentcontrolset\services\tftpd\Parameters
reg add hklm\system\currentcontrolset\services\tftpd\Parameters /v Directory /t REG_SZ /d c:\tftproot
md c:\tftproot
net start tftpd

Open in new window

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now