?
Solved

Can someone help me out in setting up a 2811 router for VoIP from scratch?

Posted on 2008-11-05
8
Medium Priority
?
1,318 Views
Last Modified: 2012-05-05
Hi,

Can someone help me out in creating a config for the 2811 12.4.20T1 router to use it with a VIC2-2FXO card so i can receive calls from the outside and make calls to the outside?

I need the config from scratch, the router has the following:
12.4.20T1 ADVENTERPRISEK9_IVS-M  Firmware
PVDM2-8
VIC2-2FXO
256/256F

What i need is to receive calls from the outside via voice port 0/1/0 and make calls to the outside via the same port over POTS.

The router config is blank, i've only enabled telephony-service without any dialplan-patterns and i got 2 7970G phones.

Also, is there a way to factory reset the VIC2-2FXO?


Thanks!
0
Comment
Question by:PredatorGR
  • 5
  • 3
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 22890290
Not too complicated. If I were you, I would try using Cisco's QCT program to create the config for you after you fill in some information on a web page.
Else set up the CME for the 7970 phones first.
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a008042326b.shtml

Then add the following:

voice service voip
 allow-connections h323 to h323
  h323
  call start slow
!
voice class codec 1
 codec preference 1 g711ulaw
!
voice-port 0/1/0
 description PSTN Connection
 connection plar opx 500  <== where '100' is the dn you assigned to the 7970G that you want to ring on inbound calls
 caller-id enable
!
dial-peer voice 1 pots
 destination-pattern .T  <== all outbound numbers get sent to FXO port 0/1/0
 port 0/1/0
!
interface loopback 0
 ip add 10.9.5.235 255.255.255.252
!
!  ## use the latest, probably 8.x files for the phones ##
tftp-server flash:CVM70.2-0-2-26.sbn
tftp-server flash:Jar70.2-9-2-26.sbn
tftp-server flash:TERM70.7-0-3-0S.loads
tftp-server flash:cnu70.2-7-6-26.sbn
tftp-server flash:term70.default.loads

telephony-service
 load 7970 TERM70.7-0-3-0S  <== or whichever phone load files you use
 video
 max-ephones 4
 max-dn 8
 ip source-address 10.9.5.235 port 2000
 auto assign 1 to 8
 service phone videoCapability 1
 system message Have a Happy Day!
 time-zone 8
 max-conferences 4 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 web admin system name admin password cisco
 dn-webedit
 time-webedit
 transfer-system full-consult
 create cnf-files
!
ephone-dn  1  dual-line
 number 500
!
!
ephone-dn  2  dual-line
 number 501
!
ephone-dn  3  dual-line
 number 502
!
ephone-dn  4  dual-line
 number 503
!
ephone  1
mac-address 0011.2032.CABC
type 7970
button  1:1 2:2
!
ephone  1
mac-address 0011.2032.C999
type 7970
button  1:2 2:1
!



0
 

Author Comment

by:PredatorGR
ID: 22893432
Thanks for your reply, i will test this config when i go home, i am in the office right now! I ll post the results asap.

By the way, is there a way to reset the 2FXO card to factory defaults?

The config for the FXO are cptone GR and impedance  complex2. Nothing else. Do i need any other config for the voice card?
0
 

Author Comment

by:PredatorGR
ID: 22900660
Hi, i tried the config, i can call from the outside but i hear no voice in the 7970. The other guy could hear me very well!

I cannot make outbound calls, only inbound.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 79

Expert Comment

by:lrmoore
ID: 22901067
Can you post your running config?
Do the IP phones register?
0
 

Author Comment

by:PredatorGR
ID: 22902071
Yes, the phones do register! I will post the running config later, i am in the office now!
0
 

Author Comment

by:PredatorGR
ID: 22902763
Here's the sh conf command.

Note that the codec i use is alaw and not ulaw as i am in Greece, Europe.
2811#sh
Nov  7 11:15:01.311: %SYS-5-CONFIG_I: Configured from console by consoleconfig
Using 5708 out of 245752 bytes
!
! Last configuration change at 10:48:25 UTC Fri Nov 7 2008
! NVRAM config last updated at 10:48:27 UTC Fri Nov 7 2008
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $xxxxx
enable password xxxxxx!!
!
no aaa new-model
!
dot11 syslog
ip source-route
no ip routing
!
!
no ip cef
!
ip dhcp pool ITS
   network 192.168.111.0 255.255.255.0
   option 150 ip 192.168.111.1
   default-router 192.168.111.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice service voip
 allow-connections h323 to h323
!
!
!
voice class codec 1
 codec preference 1 g711alaw bytes 160
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.111.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.111.1 255.255.255.0
 no ip route-cache
 duplex full
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 encapsulation hdlc
 no ip route-cache
 shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip http path flash:/gui
!
!
!
!
!
!
!
!
!
tftp-server flash:Desktops/320x212x12/CampusNight.png
tftp-server flash:Desktops/320x212x12/CiscoFountain.png
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x212x12/MorroRock.png
tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:Desktops/320x212x12/TN-Fountain.png
tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/Fountain.png
tftp-server flash:gui/admin_user.html
tftp-server flash:gui/admin_user.js
tftp-server flash:gui/CiscoLogo.gif
tftp-server flash:gui/Delete.gif
tftp-server flash:gui/dom.js
tftp-server flash:gui/downarrow.gif
tftp-server flash:gui/ephone_admin.html
tftp-server flash:gui/logohome.gif
tftp-server flash:gui/normal_user.html
tftp-server flash:gui/normal_user.js
tftp-server flash:gui/Plus.gif
tftp-server flash:gui/sxiconad.gif
tftp-server flash:gui/Tab.gif
tftp-server flash:gui/telephony_service.html
tftp-server flash:gui/uparrow.gif
tftp-server flash:gui/xml-test.html
tftp-server flash:gui/xml.template
tftp-server flash:phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-2
7.sbn
tftp-server flash:phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-2
7.sbn
tftp-server flash:phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
tftp-server flash:phone/7970-7971/term70.default.loads alias term70.default.load
s
tftp-server flash:phone/7970-7971/term71.default.loads alias term71.default.load
s
tftp-server flash:ringtones/Analog1.raw
tftp-server flash:ringtones/Analog2.raw
tftp-server flash:ringtones/AreYouThere.raw
tftp-server flash:ringtones/AreYouThereF.raw
tftp-server flash:ringtones/Bass.raw
tftp-server flash:ringtones/CallBack.raw
tftp-server flash:ringtones/Chime.raw
tftp-server flash:ringtones/Classic1.raw
tftp-server flash:ringtones/Classic2.raw
tftp-server flash:ringtones/ClockShop.raw
tftp-server flash:ringtones/DistinctiveRingList.xml
tftp-server flash:ringtones/Drums1.raw
tftp-server flash:ringtones/Drums2.raw
tftp-server flash:ringtones/FilmScore.raw
tftp-server flash:ringtones/HarpSynth.raw
tftp-server flash:ringtones/Jamaica.raw
tftp-server flash:ringtones/KotoEffect.raw
tftp-server flash:ringtones/MusicBox.raw
tftp-server flash:ringtones/Piano1.raw
tftp-server flash:ringtones/Piano2.raw
tftp-server flash:ringtones/Pop.raw
tftp-server flash:ringtones/Pulse1.raw
tftp-server flash:ringtones/Ring1.raw
tftp-server flash:ringtones/Ring2.raw
tftp-server flash:ringtones/Ring3.raw
tftp-server flash:ringtones/Ring4.raw
tftp-server flash:ringtones/Ring5.raw
tftp-server flash:ringtones/Ring6.raw
tftp-server flash:ringtones/Ring7.raw
tftp-server flash:ringtones/RingList.xml
tftp-server flash:ringtones/Sax1.raw
tftp-server flash:ringtones/Sax2.raw
tftp-server flash:ringtones/Vibe.raw
!
control-plane
!
!
!
voice-port 0/1/0
 connection plar opx 1000
 description PSTN Connection
 caller-id enable
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 1 pots
 destination-pattern .T
 port 0/1/0
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 video
 max-ephones 3
 max-dn 3
 ip source-address 192.168.111.1 port 2000
 auto assign 1 to 3
 max-conferences 8 gain -6
 transfer-system full-consult
 server-security-mode non-secure
 create cnf-files version-stamp 7960 Nov 07 2008 10:48:05
!
!
ephone-dn  1  dual-line
 number 1000
!
!
ephone-dn  2  dual-line
 number 1001
!
!
ephone-dn  3  dual-line
 number 1002
!
!
ephone  1
 no phone-ui speeddial-fastdial
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
 codec g729r8 pre-ietf
!
!
!
ephone  2
 no phone-ui speeddial-fastdial
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
 codec g729r8 pre-ietf
!
!
!
ephone  3
 no phone-ui speeddial-fastdial
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
 codec g729r8 pre-ietf
!
!
!
line con 0
line aux 0
line vty 0 4
 password xxxxxxx!!
 login
!
scheduler allocate 20000 1000
end

Open in new window

0
 

Author Comment

by:PredatorGR
ID: 22902815
If i make a test call from router i get this:

2811#csim start 6973xxxxx
csim: called number = 6973xxxxx, loop count = 1 ping count = 0

csim err csimDisconnected recvd DISC cid(24)
csim: loop = 1, failed = 1
csim: call attempted = 1, setup failed = 1, tone failed = 0

What might go wrong? Note that i can make calls from my mobile to my PSTN at home, the phone rings, problem is the i cannot hear my voice in the 7970 phone when i talk from my moblie phone.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 22904191
>no ip routing

Enable routing
 ip routing

Don't make both of these interfaces the same ip address
>interface Loopback0
> ip address 192.168.111.1 255.255.255.0  <==
>interface FastEthernet0/0
> ip address 192.168.111.1 255.255.255.0  <== should be different

ephone  1
 no phone-ui speeddial-fastdial
 no multicast-moh
 device-security-mode none
 keepalive 30 auxiliary 0
 codec g729r8 pre-ietf  <== try removing this command

I don't see any button assignments for the ephones.
Try it with a simple ephone config
ephone  1
mac-address 0011.2032.CABC  <== Mac address of phone1
type 7970
button  1:1 2:2




0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question