• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 764
  • Last Modified:

ASPX Website Not Displaying

Hi All,

I'm having an issue with my aspx website. I'm creating an internal site for the company using Visual Web Developer 2008 Express. When I test everything through the program (VWD2008) it all works fine and dandy. But when I transfer the files to a different machine with IIS installed on XP Pro, (using IE) all it shows is the code behind, it doesn't matter what page I goto, it's always the same. nothing but code
if I test it on chrome or firefox, all the browser does is download the file, ie default.aspx


0
ccpjc
Asked:
ccpjc
  • 10
  • 7
  • 6
2 Solutions
 
KirrilianCommented:
You have to install the asp.net extensions and then register them.

Make sure you have asp.net selected in the add/remove windows components and then follow the instructions on this site:

http://www.devx.com/vb2themax/Tip/18849
0
 
ccpjcAuthor Commented:
didn't seem to work, now it's throwing me errors
if I access the webpage from a remote machine I get this
Server Error in '/iweb' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 

Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
If i access it on the local machine it gives me this

Server Error in '/iweb' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. (C:\Inetpub\wwwroot\iweb\web.config line 77)

Source Error:


Line 75:     </httpHandlers>
Line 76:     <httpModules>
Line 77:       <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
Line 78:     </httpModules>
Line 79:   </system.web>
 

Source File: C:\Inetpub\wwwroot\iweb\web.config    Line: 77


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
0
 
KirrilianCommented:
If you are getting asp.net errors it worked, now the problem lies elsewhere. Are you using the same version of .Net on each machine? It looks like you developed against 3.5 and you have 2.0 on your xp box.
0
Transaction-level recovery for Oracle database

Veeam Explore for Oracle delivers low RTOs and RPOs with agentless transaction log backup and transaction-level recovery of Oracle databases. You can restore the database to a precise point in time, even to a specific transaction.

 
KirrilianCommented:
Also, if you install a newer version of .Net you have to re-register it with IIS
0
 
ccpjcAuthor Commented:
it gives me those errors in IE only, Firefox and Chrome still download the asp file instead of loading anything..

I'll try update the XP machine to 3.5
0
 
KirrilianCommented:
Then IIS still isn't setup properly, I believe that you also need to add the asp and aspx extensions on the website too.
0
 
ccpjcAuthor Commented:
ok before when I tried the website, I would goto default.aspx  all it was is an intro page with company logo, a flash animation and a enter link, it would show fine, i would click the enter (main.aspx) link and all it would show is the code behind
now it's nothing but errors on any page

if i do http://localhost/ it shows the localstart.asp page without issue
0
 
wildwoodweedCommented:
Open IIS manager on the server.  Right click on the website in question.  Select properties.  Select Home Directory.  Press the Configuration... button and verify that .asp and .aspx files are in the list.  Report your results back to us.  Thanks.
0
 
ccpjcAuthor Commented:
It's setup with a Virtual Directory. but yes .asp and .aspx are listed in there
0
 
wildwoodweedCommented:
Ok, if you open the root of the virtual directory on the server, what is the error reported to you?
0
 
wildwoodweedCommented:
that is, open the default page of that virtual directory in a browser on the server.
0
 
ccpjcAuthor Commented:
the site is set to be the root
if i put in http://web

on the local machine i get error 403

on a remote machine i get this
Directory Listing Denied

This Virtual Directory does not allow contents to be listed.
if i put in http://web/default.aspx
i get the errors listed above
0
 
ccpjcAuthor Commented:
by errors listed above i mean the long post with the ASP errors
0
 
KirrilianCommented:
Ok, I just noticed that you had 2 different errors above, a remote machine and your local machine. You need to change the parameter in the web.config file like the message says and you will get an error message then. Not sure what is going on with the error from your local machine.
0
 
wildwoodweedCommented:
Oh, my fault.  I didn't know if that was still the errors you were getting.

Ok, I believe this issue with ScriptModule is indeed caused by your using VWD 2008 and ASP.NET 2.0 together.

A couple questions before we jump to a solution.
-Did you recently update to VWD 2008?
-Are you using AJAX and/or the AJAX control toolkit?
0
 
ccpjcAuthor Commented:
I've been using VWD2008 from the start
Not using AJAX as far as i know

if i test the site with VWD it works flawlessly

right now it's a pretty basic site, later on it will include a database but i want to get the site going

i put the
<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 
i now get this

Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized configuration section customerrors.

Source Error:


Line 25:   <connectionStrings />
Line 26:
Line 27:   <customerrors>
Line 28:   <!-- Web.Config Configuration File -->
Line 29:
 

Source File: C:\Inetpub\wwwroot\iweb\web.config    Line: 27


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
0
 
wildwoodweedCommented:
The <customErrors /> is not a section tag, it is to set an attribute.  You must have it between the <System.Web> tags or else it wont work.  Just like in the code above.  the custom errors should look like what you have at the top of your last post.  It must end with a /> also as it does not have an opening and closing tag.
0
 
wildwoodweedCommented:
You may also try this script from Microsoft.  It is related to the issue you were originally having.  Once you get your web.config file fixed.  Run the script on your development machine.

http://go.microsoft.com/fwlink/?linkid=95792
0
 
ccpjcAuthor Commented:
it is in there here's a brief cut from the web.config fiel
<system.web>
    <!-- Web.Config Configuration File -->

    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>

    <!--
            Set compilation debug="true" to insert debugging
            symbols into the compiled page. Because this
            affects performance, set this value to true only
            during development.
        -->


    <compilation debug="true">
      <assemblies>
        <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="Sys
0
 
ccpjcAuthor Commented:
I gave up on v3.5 and just reverted back to v2.0

even after installing v3.5 i still couldn't select it from the list in IIS

works fine with v2.0
0
 
KirrilianCommented:
You wont be able to see it in the list in IIS until you register it, did you do that?
0
 
ccpjcAuthor Commented:
there's no reg application with 3.5 or can I use the same one in the link you put in before?

i'm not at the office anymore, so I'll have to try tomorrow
0
 
KirrilianCommented:
I just researched that as well and it seems that 2.0 is the last full framework, 3.0 and 3.5 are just extensions to 2.0, sorry about that, I was misinformed.

What machine do you want to get this working on? Lets just focus on that machine and get it working and then we can go on to the other ones if you want.

I think there are different issues with different machines and it is becoming confusing which one we are talking about or working on.


0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 10
  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now