How to block a particular email address in exchange 2003?

I have noticed that a user is sending confidential information to a particular email address. Besides the legal ramifications, I need to block any and all my users from sending to this external email address from here on. I have seen posts to create a contact...

"Sembee:
Blocking individual addresses is very easy.
On the Exchange server, open up ADUC and create a new Contact. Step through the wizard, giving it an SMTP address that matches the email address you want to block.
Once complete, open the properties of the contact. Click on the Exchange advanced tab and enable the option "Hide from Exchange address lists" - otherwise the contact will appear in the GAL.
Finally, click on the Exchange general tab and change the settings under Message Restrictions.
You will probably want "From Everyone except" and select your equivalent of "All Staff".

Users send a message to the email address on the contact, it will be rejected with a permissions error.
You will need a separate contact for each email address.

Simon."

But this is somehow not working. I have also tried recipient filtering and that somehow is not working either. AM I MISSING SOMETHING??

thanks in advance!
LVL 1
CarlosTerronAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Exchange_GeekCommented:
"I have noticed that a user is sending confidential information to a particular email address. Besides the legal ramifications, I need to block any and all my users from sending to this external email address from here on. I have seen posts to create a contact"

Are we talking about an internal user or external in this case ?

Recipient filtering needs to be enabled at SMTP Virtual Server level also. Have you done that ?
Ensure the check box "Apply Recipient Filter" is checked.

Also, after doing all this troubleshooting, how long did you wait before concluding that the entire experiment was a flop.

Ideally you should wait for more than 2hrs. Or restart IS service and SMTP.
Have you tried to send the message using your own OL client and did a message tracking ?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CarlosTerronAuthor Commented:
Thank you sir, looks like all I had left to do was restart the SMTP virtual server. Everything else was correct.

Thanks
0
Exchange_GeekCommented:
If there is something that does not solve your issue, please do inform me via the same thread so I could look into it and if required have our friend Simon suggest some magic wands too.

Take Care.

Cheers..
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.