• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 430
  • Last Modified:

How do I register a DNS record for a DC?

Hi,
I am trying to figure out what is going on with my new DC.

I run the netdiag.exe and get the following results.

    Computer Name: ServerName
    DNS Host Name: servername.domain
    System info : Windows 2000 Server (Build 3790)
    Processor : EM64T Family 6 Model 15 Stepping 11, GenuineIntel
    List of installed hotfixes :
        Q147222

Netcard queries test . . . . . . . : Passed

Per interface results:

    Adapter : Local Area Connection

        Netcard queries test . . . : Passed

        Host Name. . . . . . . . . : servername
        IP Address . . . . . . . . : xxx.xxx.xxx.xxx
        Subnet Mask. . . . . . . . : xxx.xxx.xxx.xxx
        Default Gateway. . . . . . : xxx.xxx.xxx.xxx
        Dns Servers. . . . . . . . : xxx.xxx.xxx.xxx
                                     xxx.xxx.xxx.xxx
                                     xxx.xxx.xxx.xxx


        AutoConfiguration results. . . . . . : Passed

        Default gateway test . . . : Passed

        NetBT name test. . . . . . : Passed
            No names have been found.

        WINS service test. . . . . : Skipped
            There are no WINS servers configured for this interface.

Global results:

Domain membership test . . . . . . : Passed

NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{E4F28C2F-0AA4-4A3C-955B-CE298367AEF3}
    1 NetBt transport currently configured.

Autonet address test . . . . . . . : Passed

IP loopback ping test. . . . . . . : Passed

Default gateway test . . . . . . . : Passed

NetBT name test. . . . . . . . . . : Passed
    [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.

Winsock test . . . . . . . . . . . : Passed

DNS test . . . . . . . . . . . . . : Failed
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
    [FATAL] No DNS servers have the DNS records for this DC registered.

Redir and Browser test . . . . . . : Failed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{E4F28C2F-0AA4-4A3C-955B-CE298367AEF3}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{E4F28C2F-0AA4-4A3C-955B-CE298367AEF3}
    The browser is bound to 1 NetBt transport.
    [FATAL] Cannot send mailslot message to 'SSCC*' via browser. [ERROR_INVALID_FUNCTION]

DC discovery test. . . . . . . . . : Passed

DC list test . . . . . . . . . . . : Passed

Trust relationship test. . . . . . : Passed
    Secure channel for domain 'SSCC' is to '\\webmail.sscc.edu'.

Kerberos test. . . . . . . . . . . : Failed
    [FATAL] Cannot lookup package Kerberos.
    The error occurred was: (null)

LDAP test. . . . . . . . . . . . . : Passed

Bindings test. . . . . . . . . . . : Passed

WAN configuration test . . . . . . : Skipped
    No active remote access connections.

Modem diagnostics test . . . . . . : Passed

IP Security test . . . . . . . . . : Skipped

    Note: run "netsh ipsec dynamic show /?" for more detailed information

The command completed successfully

I have followed the detailed step-by-step intstructions :      http://www.block.net.au/help/replace-dc/
So, I believe the new DC is setup correctly.  

I was wondering how can I confirm or register a DC in the DNS records?

Thanks for your time.

Bob


0
rsnellman
Asked:
rsnellman
  • 14
  • 9
  • 3
  • +2
2 Solutions
 
Darius GhassemCommented:
Make sure you are running  the test under domain admin account
0
 
Darius GhassemCommented:
Also, make sure you don't have any external DNS servers listed in your TCP\IP properties.
0
 
rsnellmanAuthor Commented:
Ok, I am running in the domain admin account and no external DNS servers listed as suggested.

Now what?
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 
ryansotoCommented:
run a netdiag /fix

Then repeat this test
0
 
ryansotoCommented:
Do the records exist in DNS?  Have you created them?
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
It would be helpful if you could actually post the DNS settings on your server in question.  IT SOUNDS like your DNS server that TCP/IP refers to is a non-Active Directory DNS server that does not support dynamic updates.  If it WERE properly configured, a reboot would solve the problem as wood restarting the netlogon service.  But if you want this solved QUICKLY, then run IPCONFIG /ALL and post the results here.
0
 
rsnellmanAuthor Commented:
Yes the records exist in DNS Server.  They were created by the AD.

I have stopped the DNS and netlogon services...deleted the netlogon.dns / dnb files then restarted the services to recreate the files.

Then ran the netdiag /fix  and I still get the same results.

DNS test . . . . . . . . . . . . . : Failed
    [FATAL] Could not open file C:\WINDOWS\system32\config\netlogon.dns for reading.
    [FATAL] No DNS servers have the DNS records for this DC registered.

Redir and Browser test . . . . . . : Failed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{E4F28C2F-0AA4-4A3C-955B-CE298367AEF3}
    The redir is bound to 1 NetBt transport.

    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{E4F28C2F-0AA4-4A3C-955B-CE298367AEF3}
    The browser is bound to 1 NetBt transport.
    [FATAL] Cannot send mailslot message to 'SSCC*' via browser. [ERROR_INVALID_FUNCTION]

Kerberos test. . . . . . . . . . . : Failed
    [FATAL] Cannot lookup package Kerberos.
    The error occurred was: (null)

anymore ideas, please?
0
 
Darius GhassemCommented:
Do you have two NICs?
0
 
rsnellmanAuthor Commented:
Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator.Domain>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ServerName
   Primary Dns Suffix  . . . . . . . : domain.edu
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : domain.edu

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 PM Network Connection
   Physical Address. . . . . . . . . : 00-30-48-66-A6-16
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 199.30.32.3
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 199.30.32.1
   DNS Servers . . . . . . . . . . . : 199.30.32.3

The DNS Entries were created by the AD.

I followed these steps to create the new DC.           http://www.block.net.au/help/replace-dc/

Does this help?
0
 
Darius GhassemCommented:
Sorry posted to quick make sure you are using the correct verison of support tools 64-bit or 32-bit. Also, if they are the correct tools for the OS 2003.

These are the 32-bit verison for 2003.

http://www.microsoft.com/downloads/details.aspx?FamilyId=6EC50B78-8BE1-4E81-B3BE-4E7AC4F0912D&displaylang=en
0
 
Darius GhassemCommented:
One more question. What verison is this OS?
0
 
rsnellmanAuthor Commented:
Yes, I have dual Intel Pro/1000 PM/PL NICs.  However, I have another server identical with hardware setup and the PL NIC is disabled, just like this server is.  And it does not have any issues when I run the netdiag on it.  Everything seems identical configuration wise.
0
 
Darius GhassemCommented:
If you have another DNS server then you need to point this DC to have the second DC listed as the secondary DNS server at least until replication has fully completed.
0
 
rsnellmanAuthor Commented:
Microsoft Windows Server 2003 R2 64-bit.

Also, the DNS is setup to allow AD dynamic update / secure only.
0
 
rsnellmanAuthor Commented:
I am using the correct support tools for x64-bit OS.
0
 
Darius GhassemCommented:
Is the SYSVOL running? I would put the second DNS server in your TCP\IP properties. Make sure the DNS ZONE is AD integrated. Are you getting any errors in the Event Log?
0
 
rsnellmanAuthor Commented:
What if it has been this way for a couple of months?  Will replication still complete if I just now added the secondary DNS for the current DC?
0
 
rsnellmanAuthor Commented:
Oh, one last thing.  My network engineer told me that this server is not a FQDN.  If that makes sense.
Does it need to be if it is going to act as a bridgehead for an off-site?
0
 
Darius GhassemCommented:
0
 
rsnellmanAuthor Commented:
One more thing.  It passed the DCDiag.exe just fine.
0
 
rsnellmanAuthor Commented:
I believe so.  I can make changes in the ADUC console from this server and it replicates to the other DCs on the domain just fine.
Yes, the DNS Zone is AD Integrated.  In fact, that is how the DNS replicated is after I dcpromoed the server I installed DNS and the AD did the rest...seemingly flawlessly.

Yes, I am getting an error in the System Event Logs.
Event ID: 4321  Source: NetBT

I have researched this to no avail either.

Any more suggestions would be greatly appreciated.  I really do appreciate all your efforts in assistancing me in troubleshooting this issue.

0
 
rsnellmanAuthor Commented:
The ICS (Windows Firewall) is disabled on the DC.
0
 
rsnellmanAuthor Commented:
Oh, forgot to mention that DFS & FRS services are running.
0
 
snusgubbenCommented:
>"I am using the correct support tools for x64-bit OS."

Have you downloaded the tools from the MS website? If you have, uninstall the tools and install the tools from your Microsoft Windows Server 2003 R2 64-bit CD.

Run netdiag again.


SG
0
 
rsnellmanAuthor Commented:
Yes, I did download the tools from the MS website, but in the system requirements of the website it does say support for 64-bit OS too.

I will uninstall and use the CD.

Thanks.

So, if this doesn't work, what might my next step(s) be?
0
 
Darius GhassemCommented:
Start checking permissions.
0
 
rsnellmanAuthor Commented:
Ok, I installed the 64-bit Support Tools from the CD and guess what...you're the best.

Thank you all for your great help and support on this matter.  I couldn't have done it without you.

Have a great day.

Bob
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 14
  • 9
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now