FireFox Prompts "Opening" Dialogue Pop Up - Looks for "application/octet-stream"

Im having a problem with a page (www.securitypartners.com) showing up in FireFox. It shows up fine in IE. When I load the page in FF it prompts a dialogue box to open the file which it says is "application/octet-stream". The files are HTML and PHP based. It looks like a header issue but Im not too familiar with server errors and things of this nature. Any help is appreciated.
it-kourtAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MMDeveloperCommented:
yeah sounds like the .php filetype is not properly registered in the server/system.

the php mimetype is application/x-httpd-php

If you are running apache on windows, you probably need to add this to your httpd.conf and restart apache


AddHandler application/x-httpd-php .php
WerrockCommented:
The webserver probably has an incorrect mimetype and firefox will not open it by default. Internet explorer is not be that picky of what it opens and does not follow the RFC as firefox does.
jausionsCommented:
Your IIS server is not properly configured to interpret PHP scripts. The pages are returned as-is. The source shows: <?php header("Content-type:text/html"); ?> which means that IIS doesn't pass the file to the PHP interpreter.

Go through the whole PHP / IIS configuration again, to make sure you didn't skip a step somewhere.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MMDeveloperCommented:
If PHP was installed on your machine and you are using IIS, go to your IIS manager and find your "website" and somewhere in there you have to allow/deny services that can run on that website. When you install PHP, it's not "enabled" by default, you have to go in there and allow it to run.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.