?
Solved

Network Timeout - The server at <myStaticIp> is taking too long to respond.

Posted on 2008-11-05
6
Medium Priority
?
1,543 Views
Last Modified: 2008-11-11
I've noticed a few people post this same question, unfortunately I didn't see any answers - only suggestions - which I've tried. If you recognize this question and know a thread that answers it please post. Otherwise I am stuck.

 

I recently bought a static ip from ACS (in Alaska).They don't block port 80.

My goal is to make available a website. I have Windows XP Pro 64 bit with IIS 5.1/6.0 installed. I am using a Linksys WRT54G. I have a PPPoE connection with my ISP (requires username/password).

Skipping ahead a bit, after I perform what seems like all necessary steps (I explain them below) I get the following message when I try to access http://<mystaticip>/index.htm:

,<b>Network Timeout</b>

The server at <mystaticip> is taking too long to respond.

Here are my setup thoughts:

I configured my computer/server to use a static ip.  start->control panel->network connections. I selected my network connection and "properties". Then TCP/IP->Properties->Use the Following IP Address

192.168.1.2 (same ip I used for port forwarding)

255.255.255.0

192.168.1.1

For DNS server addresses I clicked Start->Run->"cmd" and in the command prompt I typed "ipconfig /all". This showed me two DNS server address which I used for  TCP/IP->Properties->Use the Following DNS Server Addresses

To test this static ip configuration I opened a browser and was able to cruise the internet without issue. Static IP setup seems to be good.

I then setup IIS 5.1/6 (how can you tell which version? someone told me xp uses 5.1, we can assume that). I used default settings.

 I used microsoft publisher to make a silly website and published it to C:\Inetpub\wwwroot
I opened a browser and navigated to http://localhost/index.htm and sure enough my website is shown. This makes me think IIS is setup.

 

I followed these instructions for port forwarding setup (WRT54G Linksys router):

http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/HTTP.htm

By the way, if I disable port forwarding and browse http://<mystaticip>/ it pops up the login screen for my linksys router. This suggests to me that setup is good up until my router. Only when I enable port forwarding do I get the above message.

 

I then navigated to http://<mystaticip>/index.htm and get the above message that you see in bold.

Any help? Not sure what to try next. My intuition suggests its a setup issue with IIS - perhaps the default settings are not allowing access to my computer (server)?

Thanks in advance!

Tom

 
0
Comment
Question by:embalism
  • 3
  • 2
6 Comments
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22889450
Can you browse to your website by using http://192.168.1.2/ ?
0
 
LVL 24

Expert Comment

by:andrew_aj1
ID: 22889464
If you can do that and it works is should not be an IIS issue, but a networking issue instead.
0
 

Expert Comment

by:touchstar-brady
ID: 22892793
I would try disabling remote administration on your router.  It's not the ISP blocking if you get the router administration page just by doing http://yourstaticIP.  If that still doesnt work, try putting your computer in the router's DMZ TEMPORARILY.  This is probably the router using port 80 (REALLY REALLY BAD!) for it's remote administration.

Also, and just a thought here, I probably dont have to say this, but you have made sure that is actually your static IP, right?  Go to ipchicken.com and make sure, sometimes ISP's do funny things.

Hope this helps.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 

Author Comment

by:embalism
ID: 22899361
andrew_aj1:
Can you browse to your website by using http://192.168.1.2/ ?

If I navigate to 192.168.1.2 I can see my website.


andrew_aj1:             If you can do that and it works is should not be an IIS issue, but a networking issue instead.

"should" is bandied way too much! I had my friend bring over his laptop configured with IIS 5.1 -  a known working setup. We assigned him a static IP and pointed to his laptop using the linksys port forwarding table and I was able to use my static ip to view his webpage. It worked!! This gave me the thought it truely is an IIS issue. Any thoughts on this andrew_aj1?


touchstar-brady:
Also, and just a thought here, I probably dont have to say this, but you have made sure that is actually your static IP, right?  Go to ipchicken.com and make sure, sometimes ISP's do funny things.

Good advice, I went to ipchicken.com, and also whatismyip.com, and both show that I am indeed using my ISP's assigned static ip.

touchstar-brady:
I would try disabling remote administration on your router.  It's not the ISP blocking if you get the router administration page just by doing http://yourstaticIP.  If that still doesnt work, try putting your computer in the router's DMZ TEMPORARILY.  This is probably the router using port 80 (REALLY REALLY BAD!) for it's remote administration.

I will give this a try now and see what happens. This is something I haven't done before, I will take a few minutes to study it and then I will get back to you.

Thanks!
0
 

Accepted Solution

by:
embalism earned 0 total points
ID: 22900387

 I figured it out after much sweat work. I hope what I say here helps someone else with this issue, it was a headache. The solution is simple.
 
If you are using Windows XP, you will not encounter this issue upto SP2. After SP3, and all Vista products, you may find your self boggled like I was.
 
We have 11 computers here. 3 running XP SP2 (all of which I could configure IIS and deliver a website through my router using my static ip, first attempt). This was frustrating: why did XP work and all of our Vista machines (and XP SP3) machines not work?

We thought it had to do with the router being 32 bit, the OS being 64 bit, but this wasn't the case. After all, almost all servers are 64 bit these days. This idea lasted about 2 minutes.

 Then we thought, what's the difference between XP SP2, and all future variants of Vista/XP? Well, it turns out IIS was upgraded (to 6.0 and 7.0). I spent a couple hours with a XP SP2 machine on my left, and a Vista machine on my right matching up the settings. Since I managed to pair them up exactly, and it didn't fix the issue this ruled out IIS.

Are there other differences? There is a big one! The Windows Firewall drastically changed with XP SP3/Vista. Then I thought, "maybe there are different defaults?". Sure enough, by default, XP SP3/Vista has "beefed up" port access defaults. BINGO!

The solution to this issue is to open up your Windows Firewall and click "allow programs through" (or something similar). Then go ahead and check all the check boxes you want to allow: HTTP, HTTPS, SMTP, etc. This will allow communications along respective ports to your server. Issue resolved!


 
0
 

Author Comment

by:embalism
ID: 22900393
I closed out this because I found the best solution myself. I appreciate your suggestions everyone.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Make the most of your online learning experience.
How to fix a SonicWall Gateway Anti-Virus firewall blocking automatic updates to apps like Windows, Adobe, Symantec, etc.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question