• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1331
  • Last Modified:

how to setup shared iSCSI SAN storage on Wndows Server 2008

I have an iSCSI SAN storage and I have 2 Windows 2008 servers that have the iSCSI initiator software installed.  I have given access to both servers so they can both access the array.

For now, I've just had them access it one at a time.  (i.e. connect server 1 to the array, then disconnect and then connect server 2 to it).

I have the Failover Clustering feature installed on both servers.  

When I run the Validation Wizard it fais and it says that "no disks were found on which to perform cluster validation tests".  At this point both of the servers were disconnected from the array.  I even tried to connect one of the servers to the array but it's telling me the same thing.

I've read thru Microsoft documentation but I cannot find any clear direction on how to set this up.  

Am I supposed to have the disks dsconnected?  Or connected only on 1 host?  At what point do I connect both hosts to it?  
0
Florescu
Asked:
Florescu
  • 10
  • 8
1 Solution
 
willettmeisterCommented:
You need to first ensure that the array can be seen on both servers to do this.  Start server make the connection.  Let windows do it's initialization and format it and assign it a drive letter.  Then shutdown server 1.  Start server 2.  Connect the array to server 2.  DO NOT let windows initalize the array.  You shoudl be able be see it correctly and assign it the SAME drive letter that you assigned on server 1.  Add the array to the cluster as a physical disk and assign it to a group.  Start server 1.  Server 1 should join the cluster.  Fail the array to server 1 and back to server 2.  Do whatever else you need to do Shares etc.

0
 
FlorescuAuthor Commented:
I already let windows initialize the array on the 2nd server by mistake.  What do I do now?
0
 
willettmeisterCommented:
You will have to remove it from the first server and then readd it with the same drive letter not a big deal.  
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
willettmeisterCommented:
BTW if that doens't work.  Delete the array and just redo it.
0
 
FlorescuAuthor Commented:
Ok, I created a new 5 GB test volume just to play with and test.   followed your steps in the original post.  After formatting the volume on Server1, I shut it down,then I started server 2.  I connected to the volume and it didn't even prompt me to "Initialize", even though you say DO NOT let windows initialize it.

I assigned it the same drive letter and then attempted to create a new cluster.  I have 3 NICs installed in the server:
1 Public netwok  172.16.0.x
1 Private cluster heartbeat  192.168.50.x
1 iSCSI netwok 172.30.7.x

In the wizard, I got this: "One or more IPV4 addresses could not be configured automatically".  the only option I see  is the 172.16.0.x network.  

Also, how am I going to pass the "validation tests" ?
0
 
willettmeisterCommented:
Try to run the validation test and post the results.  If I remember correctly that message can be safely ignored.  

My comment about letting the server initalize the volume was just to ensure that you didn't if it asked.  I couldn't remember how Windows 2008 did it.  The different versions of windows work a little differently there.  
0
 
FlorescuAuthor Commented:
What about when I actually go through Creating a cluster?  The only network that shows up is the 172.16.0.x
0
 
willettmeisterCommented:
Do you have DHCP enabled on the cluster heartbeat and the iSCSI network.  If so give them static addresses.  
0
 
FlorescuAuthor Commented:
No, I don't.  They're all static.

There's probably a good reason that Microsoft has the Cluster Validation tests.  I'm thinking if I'm not passing the tests, I must not have something configured correctly.  
0
 
willettmeisterCommented:
Have you turned off any of the default network services like netbios or file and print services.
0
 
FlorescuAuthor Commented:
Ok, I got the validation tests to pass by having 1 disk online and the other
disk offline but both connected to the iSCSI target at the same time.

Now when I go to create a new cluster, I get to the point where it says:
"Create access point for cluster".  The only network that shows up is the
172.16.0.x network.  The manual says "this ip will probably not be what the
clients use to access the server, it's just to administer the cluster".  

I'm a little confused by that.  Here's what my NICs look like:

NIC 1  - Public network   172.16.0.x
ip 172.16.0.63
subnet 255.255.252.0
gateway 172.16.0.1

NIC 2 - Private cluster heartbeat - 192.168.50.x
192.168.50.2
255.255.255.0
no gateway configured

NIC 3 -iSCSI
172.30.7.x

NIC 4 -iSCSI
172.30.7.x

1.  Am I supposed to see more than 1 network listed when I run thru the
Cluster Wizard?
2.  What IP address should I use for the "access point" ?  Something in my
Public network 172.16.0.x or the private cluster 192.168.50.x ?
3.  What IP and hostname will the clients connect to?  (I was thinking if I
had Server3 and Server4, the clients would connect to a name like Server2
which would be the cluster name...is that right?)

0
 
willettmeisterCommented:
Since you do have a second "public" ip you should use the only one that is available.  Sometime you will have a NIC that is just for management but it is not a requirement.  

BTW best practices is to have your heartbeat network configure at 10MB/s half dupplex jsut as an FYI won't really affected what you are doing now.
0
 
willettmeisterCommented:
Even after he "figured it out on his own" he continued to ask questions.  It seems that he picked my brain and then once I got him pointed in the right direction said he figured it out.
0
 
willettmeisterCommented:
Even after he "figured it out on his own" he continued to ask questions.  It seems that he picked my brain and then once I got him pointed in the right direction said he figured it out.
0
 
FlorescuAuthor Commented:
You sitll did not resolve my problem with all of the troubleshooting steps you had me do.  I don't think it's fair to award points if I found the solution elsewhere.
0
 
FlorescuAuthor Commented:
I had both servers on at the same time (not 1 at a time like the response suggested).  
1.  Then I used the iSCSI initiator to conncect the SAN disks on server 1.  2.  I assigned drive letters and formatted the disks  3.  I connected server 2 via iSCSI but let the drive status stay "OFFLINE" in Disk management.  

So at this point iSCSI was connected to both servers at the same time.  The only difference was that SAN disks were online on server 1 and offline on server 2.  

Then the validation test passed.
0
 
willettmeisterCommented:
By having the disks on the second server offline you in essence had the second server offline since the resources you were trying to add were not available.  I was telling you the Microsoft recommended way to configure a cluster and you found around.  

You answer also does not address how you resolved the IP question that you had.
0
 
FlorescuAuthor Commented:
Having the disk offline was not the same thing as having the whole sever offline.  It did not work with the 2nd server completely turned off.  iSCSI Initiator had to be connected to the disk, even though it was in "offline mode".  

As far as the IP address, that was just the management IP address and it was ok for me to just choose the public network since that was the only one available.  Sometimes people have other NICs specifically for management purposes.  
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 10
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now