[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

No internet access on ASA 5505

Posted on 2008-11-05
5
Medium Priority
?
660 Views
Last Modified: 2012-04-01
Hi,

I am trying to setup a basic cisco ASA 5505 configuration, for internet access for a remote office, and i am having problems.
Form withing the device i can ping the default gateway, but nothing from the hosts.

here is the config file

: Saved
:
ASA Version 7.2(4) 
!
hostname warehouse
domain-name xxx.com
enable password 3YasdvgaekrKf6efSlH encrypted
passwd 2KFQnbNdsdIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.162.0.1 255.255.0.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 67.226.157.xxx 255.255.255.248 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
 speed 10
 duplex full
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name xxx.com
access-list 100 extended permit icmp any any echo-reply 
access-list 100 extended permit icmp any any time-exceeded 
access-list 100 extended permit icmp any any unreachable 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
access-group 100 in interface outside
route inside 0.0.0.0 0.0.0.0 67.226.157.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.162.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 64.201.167.193
dhcpd auto_config outside
!
dhcpd address 10.162.0.2-10.162.1.1 inside
dhcpd dns 64.201.167.193 interface inside
dhcpd enable inside
!
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:b3eb74d386db98f323684e8d1b12cc0c
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Open in new window

0
Comment
Question by:iFroyd
  • 2
  • 2
5 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 1600 total points
ID: 22889625
Your route is incorrect (pointing to the inside instead of to the outside):

conf t
no route inside 0.0.0.0 0.0.0.0 67.226.157.145
route outside 0.0.0.0 0.0.0.0 67.226.157.145
0
 

Author Comment

by:iFroyd
ID: 22889695
Nope, did not work.
I am not an expert, but really did not work.....
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22889747
Can you post an "ipconfig /all" from a client PC?
0
 

Author Comment

by:iFroyd
ID: 22889841
Windows IP Configuration
        Host Name . . . . . . . . . . . . : D610-EngToolSet
        Primary Dns Suffix  . . . . . . . : wheelsgroup.com
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : wheelsgroup.com
Ethernet adapter WiFi:
        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2915ABG Network Connection
        Physical Address. . . . . . . . . : 00-16-6F-6C-83-F3
Ethernet adapter Internet:
        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
        Physical Address. . . . . . . . . : 00-14-22-D8-9F-6C
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 10.162.0.2
        Subnet Mask . . . . . . . . . . . : 255.255.0.0
        Default Gateway . . . . . . . . . : 10.162.0.1
        DHCP Server . . . . . . . . . . . : 10.162.0.1
        DNS Servers . . . . . . . . . . . : 64.201.167.193
        Lease Obtained. . . . . . . . . . : Wednesday, November 05, 2008 3:48:03 PM
        Lease Expires . . . . . . . . . . : Wednesday, November 05, 2008 4:48:03 PM
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 400 total points
ID: 22890647
Did you delete the route inside line after you added the route outside line?
Make sure you don't see them both in the config.
With the only route to the outside, can you now ping the default gateway from the pix console?

warehouse#ping 67.226.157.145
Yes? Then ping something else
warehouse#ping 198.6.1.2
Yes? Then ping the dns server used by clients
warehouse#ping 64.201.167.193
Yes? You should be good to go.
0

Featured Post

Exciting career futures for women in IT

Education has the power to transform lives and open the door to new career opportunities. By earning an IT degree from WGU, you can become a highly skilled IT professional. Get the credentials and certifications you need to become a leader in this rewarding field.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There’s a movement in Information Technology (IT), and while it’s hard to define, it is gaining momentum. Some call it “stream-lined IT;” others call it “thin-model IT.”
Considering cloud tradeoffs and determining the right mix for your organization.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month17 days, 17 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question