Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

while restoring exchange information store backup error

Posted on 2008-11-05
17
Medium Priority
?
352 Views
Last Modified: 2013-12-01
http://www.msexchange.org/tutorials/Configuring-Exchange-Server-2007-Preview-Chapter9-Disaster-Recovery-Exchange-Server-2007.html i will read this document & try to restore the database on a new desktop assemble machine. for that first i will install windows 2003 then run dcpromo & give the same name which is currently of my running exchnage server (i am restoring backup to a different network& hardware) but while restoring exchnage information store i am getting an error the specified computer is not a exchnage server or its services are not started but actually all the services are running proper.
0
Comment
Question by:sudeep1242
  • 9
  • 8
17 Comments
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22893947
It would be good if you specify a bit more about your production and test environment.

  • Is the domain naming context the same ?
  • Are the Operating Systems of Exchange being used the same ?
  • Is Exchange installed in a domain in test environment or a work group ?
  • Which versions of Exchange are installed on both environments ?
  • What are the events that you face while performing the restore ?
  • Do you have the information stores in dismounted / mounted state ?
  • Please attach the restore logs from the tool being used
Thanks.
0
 

Author Comment

by:sudeep1242
ID: 22894312
domain name is same
operating system is same on both the environment windows 2003 enterprise x 64 bit edition
create new seprate domain in different network & install AD in the same doamin (dcpromo) also
install exchange 2007 means my AD & exchange is on the single server.
i install exchange 2007 sp1 on my running server & exchange 2007 without sp1 on test server but will it matters for the restoration process.
while restoring exchange information store backup i am getting the error ;- the specified computer is not a exchange server or its services are not started. but actually services are started proper.
information store is in mounted condition
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22894373
i install exchange 2007 sp1 on my running server & exchange 2007 without sp1 on test server but will it matters for the restoration process.

It does, whats the harm in having SP1 installed on test box ?? Try it out.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:sudeep1242
ID: 22937614
actually when i am trying to install exchange server sp1 i am receving an error:-
internet explorer script error
line 263
char 4
the system cannot locate the resource specified
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22938329
More than looking at this error, it would help us better if you paste exchange setup log errors.
Thanks.
0
 

Author Comment

by:sudeep1242
ID: 22938465
please find the exchange setup log file for you referance.
ExchangeSetup.log
0
 

Author Comment

by:sudeep1242
ID: 22938835
11/12/2008 3:16:34 PM] [0] Starting Microsoft Exchange 2007 Setup
[11/12/2008 3:16:34 PM] [0] **********************************************
[11/12/2008 3:16:34 PM] [0] Setup version: 8.0.813.0.
[11/12/2008 3:16:34 PM] [0] Logged on user: CONNECTWELL\administrator.
[11/12/2008 3:16:36 PM] [0] Command Line Parameter Name='mode', Value='Install'.
[11/12/2008 3:16:36 PM] [0] Command Line Parameter Name='sourcedir', Value='F:\'.
[11/12/2008 3:16:36 PM] [0] Command Line Parameter Name='fromsetup', Value=''.
[11/12/2008 3:16:36 PM] [0] ExSetupUI was started with the following command: '-mode:install -sourcedir:F:" /FromSetup'.
[11/12/2008 3:16:43 PM] [0] Setup is choosing the domain controller to use
[11/12/2008 3:16:44 PM] [0] The MSExchangeADTopology has a persisted domain controller: email.connectwell.com
[11/12/2008 3:16:46 PM] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use email.connectwell.com
[11/12/2008 3:16:46 PM] [0] Setup is choosing a global catalog...
[11/12/2008 3:16:46 PM] [0] Setup has chosen the global catalog server email.connectwell.com.
[11/12/2008 3:16:46 PM] [0] Setup will use the domain controller 'email.connectwell.com'.
[11/12/2008 3:16:46 PM] [0] Setup will use the global catalog 'email.connectwell.com'.
[11/12/2008 3:16:46 PM] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:16:46 PM] [0] Exchange organization container for the organization is 'CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:16:47 PM] [0] Setup will search for an Exchange Server object for the local machine with name 'EMAIL'.
[11/12/2008 3:16:48 PM] [0] Exchange Server object found : 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:16:48 PM] [0] The following roles are unpacked: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 3:16:48 PM] [0] The following roles are installed: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 3:16:48 PM] [0] The local server has some Exchange files installed.
[11/12/2008 3:16:48 PM] [0] Setup will use the path 'F:\' for installing Exchange.
[11/12/2008 3:16:48 PM] [0] Setup will discover the installed roles from server object 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:16:48 PM] [0] 'BridgeheadRole' is installed on the server object.
[11/12/2008 3:16:48 PM] [0] 'ClientAccessRole' is installed on the server object.
[11/12/2008 3:16:48 PM] [0] 'MailboxRole' is installed on the server object.
[11/12/2008 3:16:48 PM] [0] The server is cluster type: 'None'.
[11/12/2008 3:16:48 PM] [0] The requested cluster type: 'None'.
[11/12/2008 3:16:48 PM] [0] The installation mode is set to: 'Install'.
[11/12/2008 3:16:48 PM] [0] An Exchange organization with name 'First Organization' was found in this forest.
[11/12/2008 3:16:48 PM] [0] Active Directory Initialization status : 'True'.
[11/12/2008 3:16:48 PM] [0] Schema Update Required Status : 'False'.
[11/12/2008 3:16:48 PM] [0] Organization Configuration Update Required Status : 'False'.
[11/12/2008 3:16:48 PM] [0] Domain Configuration Update Required Status : 'False'.
[11/12/2008 3:16:48 PM] [0] The locally installed version is 8.1.240.6.
[11/12/2008 3:16:48 PM] [0] Exchange Installation Directory : 'C:\Program Files\Microsoft\Exchange Server'.
[11/12/2008 3:16:51 PM] [0] Applying default role selection state
[11/12/2008 3:41:16 PM] [0] **********************************************
[11/12/2008 3:41:16 PM] [0] Starting Microsoft Exchange 2007 Setup
[11/12/2008 3:41:16 PM] [0] **********************************************
[11/12/2008 3:41:16 PM] [0] Setup version: 8.0.813.0.
[11/12/2008 3:41:16 PM] [0] Logged on user: CONNECTWELL\administrator.
[11/12/2008 3:41:17 PM] [0] Command Line Parameter Name='mode', Value='Install'.
[11/12/2008 3:41:17 PM] [0] Command Line Parameter Name='sourcedir', Value='F:\'.
[11/12/2008 3:41:17 PM] [0] Command Line Parameter Name='fromsetup', Value=''.
[11/12/2008 3:41:17 PM] [0] ExSetupUI was started with the following command: '-mode:install -sourcedir:F:" /FromSetup'.
[11/12/2008 3:41:24 PM] [0] Setup is choosing the domain controller to use
[11/12/2008 3:41:24 PM] [0] The MSExchangeADTopology has a persisted domain controller: email.connectwell.com
[11/12/2008 3:41:26 PM] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use email.connectwell.com
[11/12/2008 3:41:26 PM] [0] Setup is choosing a global catalog...
[11/12/2008 3:41:26 PM] [0] Setup has chosen the global catalog server email.connectwell.com.
[11/12/2008 3:41:26 PM] [0] Setup will use the domain controller 'email.connectwell.com'.
[11/12/2008 3:41:26 PM] [0] Setup will use the global catalog 'email.connectwell.com'.
[11/12/2008 3:41:26 PM] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:41:26 PM] [0] Exchange organization container for the organization is 'CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:41:26 PM] [0] Setup will search for an Exchange Server object for the local machine with name 'EMAIL'.
[11/12/2008 3:41:28 PM] [0] Exchange Server object found : 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:41:28 PM] [0] The following roles are unpacked: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 3:41:28 PM] [0] The following roles are installed: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 3:41:28 PM] [0] The local server has some Exchange files installed.
[11/12/2008 3:41:28 PM] [0] Setup will use the path 'F:\' for installing Exchange.
[11/12/2008 3:41:28 PM] [0] Setup will discover the installed roles from server object 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 3:41:28 PM] [0] 'BridgeheadRole' is installed on the server object.
[11/12/2008 3:41:28 PM] [0] 'ClientAccessRole' is installed on the server object.
[11/12/2008 3:41:28 PM] [0] 'MailboxRole' is installed on the server object.
[11/12/2008 3:41:28 PM] [0] The server is cluster type: 'None'.
[11/12/2008 3:41:28 PM] [0] The requested cluster type: 'None'.
[11/12/2008 3:41:28 PM] [0] The installation mode is set to: 'Install'.
[11/12/2008 3:41:28 PM] [0] An Exchange organization with name 'First Organization' was found in this forest.
[11/12/2008 3:41:28 PM] [0] Active Directory Initialization status : 'True'.
[11/12/2008 3:41:28 PM] [0] Schema Update Required Status : 'False'.
[11/12/2008 3:41:28 PM] [0] Organization Configuration Update Required Status : 'False'.
[11/12/2008 3:41:28 PM] [0] Domain Configuration Update Required Status : 'False'.
[11/12/2008 3:41:28 PM] [0] The locally installed version is 8.1.240.6.
[11/12/2008 3:41:28 PM] [0] Exchange Installation Directory : 'C:\Program Files\Microsoft\Exchange Server'.
[11/12/2008 3:41:30 PM] [0] Applying default role selection state
[11/12/2008 3:41:42 PM] [0] Setup is determining what organization-level operations to perform.
[11/12/2008 3:41:42 PM] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
[11/12/2008 3:41:42 PM] [0] Setup will run from path 'C:\Program Files\Microsoft\Exchange Server\'.
[11/12/2008 3:41:42 PM] [0] InstallModeDataHandler has 2 DataHandlers
[11/12/2008 3:41:44 PM] [0] Setup is determining what organization-level operations to perform.
[11/12/2008 3:41:44 PM] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
[11/12/2008 3:41:44 PM] [0] Setup will run from path 'C:\Program Files\Microsoft\Exchange Server\'.
[11/12/2008 3:41:44 PM] [0] InstallModeDataHandler has 0 DataHandlers
[11/12/2008 3:42:02 PM] [0] End of Setup
[11/12/2008 3:42:02 PM] [0] **********************************************
[11/12/2008 4:50:20 PM] [0] **********************************************
[11/12/2008 4:50:20 PM] [0] Starting Microsoft Exchange 2007 Setup
[11/12/2008 4:50:20 PM] [0] **********************************************
[11/12/2008 4:50:20 PM] [0] Setup version: 8.0.813.0.
[11/12/2008 4:50:20 PM] [0] Logged on user: CONNECTWELL\administrator.
[11/12/2008 4:50:20 PM] [0] Command Line Parameter Name='mode', Value='Install'.
[11/12/2008 4:50:20 PM] [0] Command Line Parameter Name='sourcedir', Value='F:\'.
[11/12/2008 4:50:20 PM] [0] Command Line Parameter Name='fromsetup', Value=''.
[11/12/2008 4:50:20 PM] [0] ExSetupUI was started with the following command: '-mode:install -sourcedir:F:" /FromSetup'.
[11/12/2008 4:50:26 PM] [0] Setup is choosing the domain controller to use
[11/12/2008 4:50:27 PM] [0] The MSExchangeADTopology has a persisted domain controller: email.connectwell.com
[11/12/2008 4:50:29 PM] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use email.connectwell.com
[11/12/2008 4:50:29 PM] [0] Setup is choosing a global catalog...
[11/12/2008 4:50:29 PM] [0] Setup has chosen the global catalog server email.connectwell.com.
[11/12/2008 4:50:29 PM] [0] Setup will use the domain controller 'email.connectwell.com'.
[11/12/2008 4:50:29 PM] [0] Setup will use the global catalog 'email.connectwell.com'.
[11/12/2008 4:50:29 PM] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 4:50:29 PM] [0] Exchange organization container for the organization is 'CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 4:50:29 PM] [0] Setup will search for an Exchange Server object for the local machine with name 'EMAIL'.
[11/12/2008 4:50:30 PM] [0] Exchange Server object found : 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 4:50:31 PM] [0] The following roles are unpacked: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 4:50:31 PM] [0] The following roles are installed: BridgeheadRole ClientAccessRole MailboxRole
[11/12/2008 4:50:31 PM] [0] The local server has some Exchange files installed.
[11/12/2008 4:50:31 PM] [0] Setup will use the path 'F:\' for installing Exchange.
[11/12/2008 4:50:31 PM] [0] Setup will discover the installed roles from server object 'CN=EMAIL,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=connectwell,DC=com'.
[11/12/2008 4:50:31 PM] [0] 'BridgeheadRole' is installed on the server object.
[11/12/2008 4:50:31 PM] [0] 'ClientAccessRole' is installed on the server object.
[11/12/2008 4:50:31 PM] [0] 'MailboxRole' is installed on the server object.
[11/12/2008 4:50:31 PM] [0] The server is cluster type: 'None'.
[11/12/2008 4:50:31 PM] [0] The requested cluster type: 'None'.
[11/12/2008 4:50:31 PM] [0] The installation mode is set to: 'Install'.
[11/12/2008 4:50:31 PM] [0] An Exchange organization with name 'First Organization' was found in this forest.
[11/12/2008 4:50:31 PM] [0] Active Directory Initialization status : 'True'.
[11/12/2008 4:50:31 PM] [0] Schema Update Required Status : 'False'.
[11/12/2008 4:50:31 PM] [0] Organization Configuration Update Required Status : 'False'.
[11/12/2008 4:50:31 PM] [0] Domain Configuration Update Required Status : 'False'.
[11/12/2008 4:50:31 PM] [0] The locally installed version is 8.1.240.6.
[11/12/2008 4:50:31 PM] [0] Exchange Installation Directory : 'C:\Program Files\Microsoft\Exchange Server'.
[11/12/2008 4:50:33 PM] [0] Applying default role selection state
[11/12/2008 4:50:39 PM] [0] Setup is determining what organization-level operations to perform.
[11/12/2008 4:50:39 PM] [0] Because the value was specified, setup is setting the argument OrganizationName to the value First Organization.
[11/12/2008 4:50:39 PM] [0] Setup will run from path 'C:\Program Files\Microsoft\Exchange Server\'.
[11/12/2008 4:50:39 PM] [0] InstallModeDataHandler has 2 DataHandlers
[11/12/2008 4:50:40 PM] [0] Validating options for the 0 requested roles
[11/12/2008 4:50:40 PM] [0] Validating options for the 0 requested roles
[11/12/2008 4:50:41 PM] [0] **************
[11/12/2008 4:50:41 PM] [0] Setup will run the task 'test-setuphealth'
[11/12/2008 4:50:41 PM] [1] Setup launched task 'test-setuphealth -DomainController 'email.connectwell.com' -DownloadConfigurationUpdates $true -ExchangeVersion '8.0.813.0' -Roles 'UnifiedMessaging' -ScanType 'PrecheckInstall' -SetupRoles 'UnifiedMessaging' -TargetDir 'C:\Program Files\Microsoft\Exchange Server''  
[11/12/2008 4:50:41 PM] [1] Beginning processing.
[11/12/2008 4:51:29 PM] [1] [ERROR] This computer requires Windows Media Encoder update http://go.microsoft.com/fwlink/?LinkId=67406.
[11/12/2008 4:51:29 PM] [1] [ERROR] This computer requires Windows Media Audio Voice Codec update http://go.microsoft.com/fwlink/?LinkId=67407.
[11/12/2008 4:51:29 PM] [1] Ending processing.
[11/12/2008 4:51:55 PM] [0] End of Setup
[11/12/2008 4:51:55 PM] [0] **********************************************
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22938896
Please install from link as per setup log.

http://go.microsoft.com/fwlink/?LinkId=67407.
0
 

Author Comment

by:sudeep1242
ID: 22942497
i have download & install windows media encoder by following this link but no luck same error.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22943905
One quick guess - which version of windows are you installing this SP1 setup - on 32 bit or 64 bit O/s ??
0
 

Author Comment

by:sudeep1242
ID: 22947357
on 64 bit os
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22948058
I guess its getting a bit messy and of course time is precious.
Since, this box is being used in test environment - why not format and install using SP1 installation media ?

Since, I did consult many other friends at MS and few consultants, none tend to agree that after installing from the link and re-do the setup of SP1 - it should fail with same error.

Ideally, speaking the SP1 if it fails should have failed with a different error.

However, if you do not want to get into the nitty gritty a simple format and installation would save time and we can focus on the original issue - restore.

Please tell me your views on this suggestion.
0
 

Author Comment

by:sudeep1242
ID: 22948171
ok, i will do one thing i will completely reformat my test server then follow the steps below
1) install win 2003 server R2 x 64 bit enterprise edition
2) run dcpromo & install domain with new domain in a new forest ( totally different network)
3) then install exchange 2007 with their prerequisites
4) install exchange server sp1
5) restore system state data ( that i have take from my running live server)
6) restore exchange information store
is this the correct way to restore the database if not please suggest what to do ?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22948257

1) install win 2003 server R2 x 64 bit enterprise edition
2) run dcpromo & install domain with new domain in a new forest ( totally different network)

Note: Domain Name has to be the same with same IP address as original.

3) restore system state data ( that i have take from my running live server)

This would bring back your Exchange server information too (in AD of course).
This makes me think - on your original server is Exchange and DC on same server.
If you can answer this I could provide you an action plan.

Thanks.


0
 

Author Comment

by:sudeep1242
ID: 22948286
actually when we install our live exchange server at that time also we install it as a new domain in a new forest otherwise my actual domain controller is different where the users can regularly logged on.
0
 

Author Comment

by:sudeep1242
ID: 22948324
one thing i have mark is when i install windows 2003 on my test server ( assemble machine )
after instalation complete when i go to the properties of my computer in general tab it shows
windows 2003 x 64 bit enterprise edition it dosent shows R2 but when i looks same in my running server it shows windows 2003 R2 x 64 bit enterprise edition. actually i am using same media for
both the server live as well as test. whats wrong & will this is the reason for the failure of my restoration process.
0
 
LVL 33

Accepted Solution

by:
Exchange_Geek earned 750 total points
ID: 22948586
Well, if your actual DC and Exchange are on different server what you would have to do is.

Production Environment
DNS = GC =DC =  dc.domain.com
Exchange = Mail.domain.com

Test Environment
DNS = GC = DC = dc.domain.com

Now, if you restore system state backup. AD would have an information about an exchange server existing with the name of mail.domain.com.

Hence, Plan A
1) promote another box as mail.domain.com into your test environment with same configuration (ip address / service packs)
2) run setup.exe /recoverserver from SP1 media (this would bring back all the configuration that original box had)
3) restore from backup - simple.

Plan B
1) installing exchange on the dc.domain.com (due to lack of new hardware)
2) since you would have performed a system state restore - exchange would know which organization and AG (by default there would be only 1)
3) install exchange using SP1 media.
4) Perform a restore on this box - however you would find that the mailboxes would still be pointing to old server (since this information would not change in AD or database).

0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
In my humble opinion (IMHO), TouchDown from Symantec is the best in class for this type of application, but Symantec has end-of-lifed it and although one can keep using it, it will no longer be supported or upgraded.  Time to look for alternatives t…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question