eclipse executable launcher was unable to locate its companion shared library

That's the error I now get when I try loading up eclipse:

"eclipse executable launcher was unable to locate its companion shared library"

 I've googled this error but it seems most others that had this problem were installing this for the first time.

I've been using it on my Windows XP for some time.

The error came after I tried switching workspaces.

The new workspace never loaded, and when I tried rerunning eclipse, I got the error.

Rebooting the computer did not help.

Thanks !


Bryan

bryanbergAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sciuriwareCommented:
Is it an old version? 3.5M3 is actual.

May be you should delete C:\eclipse and unzip the new one.

;JOOP!
0
bryanbergAuthor Commented:
Yeah,

I'm thinkin about doing that ... but I did not want to lose all of my workspace references.

Anyone know how to keep them ?

Bryan
0
sciuriwareCommented:
Your ".metadata" should be in your own space, NEVER in a system area or under
C:\eclipse.

You can move that "tree" without a problem,
as long as you start eclipse (example from my PC) as:

C:\eclipse\eclipse.exe -data D:\JOOP\JAVA\Work -vmargs -Xmx256m -Xms128m

and of course my .metadata is in D:\JOOP\JAVA\Work

;JOOP!
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

bryanbergAuthor Commented:
Hmmm,

Eclipse IDE remembers where all of my workspaces are, so when I go to file --> switch workspace --> it shows a list of them.

I was wondering if this will be lost when I install the latest version of eclipse.
0
sciuriwareCommented:
As far as I know no user info is recorded either in the registry nor in the tree
under C:\eclipse\...

That's probably because eclipse must run on several operating systems.
On Linux it is just the same.
So, I think you'll find one or more directories .metadata with all project data in there.

;JOOP!
0
mmoore500Commented:
Anyone come up with a solution to this yet? I just had this problem.
0
sciuriwareCommented:
1) save .metadata trees if they are inside C:\eclipse, mover them to your own area.
2) delete C:\eclipse
3) unzip the latest version
4) run eclipse again with the -data switch as above.

I have run eclipse on several OS's since years and this is the best way to overcome damage in the installation.

;JOOP!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mmoore500Commented:
That is what I did and it worked like a charm. The person who originally asked this question should award points.
0
sciuriwareCommented:
Thank you.

;JOOP!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.