?
Solved

problem with ISDN indial - q931 output attached

Posted on 2008-11-05
3
Medium Priority
?
2,509 Views
Last Modified: 2008-11-11
Just set up a new 2811 with an e1. I can dial out from the router, however it wont take calls. Here is the q931 err i am getting can you help??:

Nov  6 04:30:18.355: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0015
        Sending Complete
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA18397
                Preferred, Channel 23
        Called Party Number i = 0xC1, '43217400'
                Plan:ISDN, Type:Subscriber(local)
Nov  6 04:30:18.371: ISDN Se0/0/0:15 SERROR: process_pri_simple: NO name in GTD
Nov  6 04:30:18.371: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8015
        Channel ID i = 0xA98397
                Exclusive, Channel 23
WCLSPR1(config-if)#
Nov  6 04:30:18.379: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x8015
        Cause i = 0x8081 - Unallocated/unassigned number
Nov  6 04:30:18.483: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x0015
Nov  6 04:30:18.487: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8015
0
Comment
Question by:workcover
  • 2
3 Comments
 
LVL 5

Expert Comment

by:devangshroff
ID: 22893489
have u specified username and password
plz pase sh isdn status
0
 
LVL 1

Author Comment

by:workcover
ID: 22899427
Username and passowrd? Here is the sho isdn stat. The config is below that.

#sho isdn stat
Global ISDN Switchtype = primary-net5
ISDN Serial0/0/0:15 interface
        dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0xFFFF7FFF
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0

sho run:
Current configuration : 5535 bytes
!
! Last configuration change at 07:47:13 AEST Fri Nov 7 2008
! NVRAM config last updated at 15:24:57 AEST Thu Nov 6 2008
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WCLSPR1
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging buffered 1000000 debugging
no logging console
enable secret 5
enable password 7
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
clock timezone AEST 10
clock summer-time AEST recurring last Sun Oct 0:00 last Sun Mar 0:00
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
!
!
ip domain name wca.gov.au
ip name-server 172.22.1.000
ip name-server 172.22.1.000
!
isdn switch-type primary-net5
!
voice-card 0
 dspfarm
!
!
voice call carrier capacity active
voice rtp send-recv
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
fax interface-type fax-mail
username wcoxfr3 password 7
!
!
controller E1 0/0/0
 framing CRC4 Australia
 pri-group timeslots 1-31
 description Voice Onramp30 02 4321 47xx
!
class-map match-all VoIP-Sig
 match access-group 121
class-map match-all VoIP-RTP
 match access-group 120
!
!
policy-map DSCP2COS
 class VoIP-RTP
  set cos 5
 class VoIP-Sig
  set cos 3
policy-map 15-CALLS
  description Voice Onramp20 02 432147xx
 class VoIP-RTP
  priority 405
 class VoIP-Sig
  bandwidth percent 2
 class class-default
  fair-queue
!
!
translation-rule 2
 Rule 0 ^. 0
!
!
translation-rule 1
 Rule 0 ^4321 47
 Rule 1 ^024321 47
 Rule 3 ^. 9999
!
!
!
!
!
!
interface Loopback0
 ip address 172.22.zzzz.zzz 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 172.22.zzz.zzz
!
interface FastEthernet0/0
 description ***-Voice and Data connection to
 no ip address
 duplex full
 speed 100
 no cdp enable
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 no snmp trap link-status
 no cdp enable
!
interface FastEthernet0/0.42
 description Voice VLAN
 encapsulation dot1Q 42
 ip address 172.22.zzz.zzz 255.255.255.0
 ip helper-address 172.22.1.zzz
 no snmp trap link-status
 no cdp enable
 service-policy output DSCP2COS
!
interface FastEthernet0/0.142
 encapsulation dot1Q 142
 ip address 172.22.142.zzz 255.255.255.0
 ip helper-address 172.22.1.zzz
 no snmp trap link-status
 no cdp enable
!
interface FastEthernet0/1
 description *** 10MB GWIP ***
 bandwidth 10240
 ip address 172.22.222.xxx 255.255.255.zzz
 duplex full
 speed 100
 no cdp enable
!
interface Serial0/0/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bchan-number-order ascending
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.2xx.xxx
!
!
ip http server
no ip http secure-server
!
!
map-class frame-relay PVC-15-CALLS
 frame-relay cir 1024000
 frame-relay bc 10240
 frame-relay be 0
 frame-relay mincir 1024000
 service-policy output 15-CALLS
logging 164.80.130.36
access-list 101 deny   ospf any any
access-list 101 permit ip any any
access-list 120 remark VoIP-RTP-Bearer
access-list 120 permit udp any any range 16384 32767
access-list 120 permit ip any any dscp ef
access-list 120 remark VoIP-RTP-Bearer
access-list 120 remark VoIP-RTP-Bearer
access-list 120 remark VoIP-RTP-Bearer
access-list 121 remark VoIP-Sig-Call-Signalling
access-list 121 permit ip any any dscp af31
access-list 121 permit tcp any eq 1720 any
 --More--
access-list 121 permit tcp any any eq 1720
access-list 121 permit tcp any eq 2000 any
access-list 121 permit tcp any any eq 2000
access-list 121 remark VoIP-Sig-Call-Signalling
access-list 121 remark VoIP-Sig-Call-Signalling
access-list 121 remark VoIP-Sig-Call-Signalling
dialer watch-list 1 ip 164.80.224.xxx 255.255.255.xxx
dialer-list 2 protocol ip list 101
snmp-server community WC-
snmp-server community WC-
snmp-server system-shutdown
snmp-server enable traps tty
snmp-server host 164.80.130.44 version 2c SNMPv2C
no cdp run
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:15
 translate calling 2
 translate called 1
 echo-cancel coverage 32
!
!
no mgcp timer receive-rtcp
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 preference 1
 destination-pattern 0T
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 7400 voip
 preference 1
 destination-pattern 74..
 voice-class codec 1
 session target ipv4:164.80.35.xxx
 incoming called-number .
 dtmf-relay h245-signal h245-alphanumeric
 no vad
!
dial-peer voice 7401 voip
 preference 2
 destination-pattern 74..
 voice-class codec 1
 session target ipv4:164.80.35.xxx
 incoming called-number .
 dtmf-relay h245-signal h245-alphanumeric
 no vad
!
dial-peer voice 2 pots
 preference 2
 destination-pattern 0T
 direct-inward-dial
!
dial-peer voice 188 voip
 preference 9
 destination-pattern 74..
 voice-class codec 1
 session target ipv4:172.22.188.xxx
 incoming called-number .
 dtmf-relay h245-alphanumeric
 no vad
!
!
!
!
call-manager-fallback
 max-conferences 8 gain -6
 ip source-address 172.22.254.xxx port 2000
 max-ephones 42
 max-dn 144
 keepalive 15
 voicemail 0024
 call-forward busy 0024
 call-forward noan 0024 timeout 6
 time-format 24
 date-format dd-mm-yy
!
!
line con 0
 password 7
 login
line aux 0
 password 7 0
 login
line vty 0 4
 exec-timeout 0 0
 password 7
 logging synchronous
 login
!
scheduler allocate 20000 1000
ntp clock-period 17180186
ntp server
!
end

0
 
LVL 1

Accepted Solution

by:
workcover earned 0 total points
ID: 22901047
Sorry Dislexia strikes again. have a look at my translation pattern..it was 47 when it should be 74. thanks anyway.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question