[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1728
  • Last Modified:

Problems Configuring phpMyAdmin

I have installed MySQL server and it is runningI can access and operate properly through the command line interface (XP) and MySQL GUI Tools.  I am testing the waters with phpMyAdmin.  I believe I have followed the configuration instructions correctly, but I'm getting a peculiar error.

 Here are the steps I took:
1) Unzipped the phpMyAdmin package to ~apache2.2\htdocs\phpmyadmin
2) created the folder ~phpmyadmin\config
3) copied the file config.sample.inc.php to ~\config and renamed to config.inc.php
4) accessed ~phpmyadmin/scripts/setup.php
5) Clicked Servers->"ADD"
6) Changed the authentication type to "cookie"
7) Entered "root" for  "User for config auth"
8) Entered my password for "Password for config auth"
9) Clicked "ADD"

When I did this, phpMyAdmin displays this message at the top of the page:
"You didn't set phpMyAdmin database, so you can not use all phpMyAdmin features."

What does this mean and how can I solve this problem?

I cleaned up the config.inc.php file a bit.  Here is the file in its entirety:
<?php
$cfg['blowfish_secret'] = 'Blah';
$cfg['Servers'][1]['auth_type'] = 'cookie';
$cfg['Servers'][1]['host'] = 'localhost';
$cfg['Servers'][1]['connect_type'] = 'tcp';
$cfg['Servers'][1]['compress'] = false;
$cfg['Servers'][1]['extension'] = 'mysql';
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>


Mike

0
shacho
Asked:
shacho
  • 4
  • 3
1 Solution
 
shachoAuthor Commented:
I'm not convinced that phpMyAdmin is actually looking at my config file.  If I click "DISPLAY"  under configuration, it displays a page that looks like the config script default.  Is that what it's supposed to do?

Here is what gets displayed:

<?php
/*
 * Generated configuration file
 * Generated by: phpMyAdmin 3.0.1.1 setup script by Michal ihaY <michal@cihar.com>
 * Version: $Id: setup.php 11423 2008-07-24 17:26:05Z lem9 $
 * Date: Thu, 06 Nov 2008 06:35:04 GMT
 */

/* Servers configuration */
$i = 0;

/* Server localhost (cookie) [1] */
$i++;
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['auth_type'] = 'cookie';

/* End of servers configuration */

$cfg['blowfish_secret'] = '49128f89d06085.02874880';
?>

0
 
fouriceCommented:
I'm not entirly sure, but I never placed the config.inc.php file in a seperate folder. I think it should be in ~apache2.2\htdocs\phpmyadmin
0
 
shachoAuthor Commented:
If I try to put it anywhere else, phpMyAdmin/scripts/setup.php says:

Can not load or save configuration.
Please create web server writable folder config in phpMyAdmin toplevel directory as described in documentation. Otherwise you will be only able to download or display it.

Mike


0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
fouriceCommented:
"phpMyAdmin toplevel directory", so that means that it indeed cannot be in a subdirectory.
Is the phpMyAdmin directory writable like the message says?
0
 
shachoAuthor Commented:
I see what's happened here.  config.inc.php needs to be in the /phpmyadmin/config directory while it's being edited by /phpmyadmin/scripts/setup.php.  The error I am getting is from setup.php.  The problem doesn't seem to be with phpMyAdmin.  I think there's a problem with the PHP configuration.  Here is the error phpMyAdmin gives me on top:

Could not load either mysql or mysqli extension, you might not be able to use phpMyAdmin! Check your PHP configuration.

This suggests to me that I have a configuration problem with PHP or Apache.  Do you have an idea what might be the cause?

Mike

0
 
fouriceCommented:
Use phpinfo() to see if mysql is enabled, I think there should be something like:
'--with-mysql=shared,/usr'
in the configure command. And there should also be a mysql section further below in the phpinfo().
0
 
fouriceCommented:
Another thing, you are on Windows right? Check your php.ini file for:
extension=php_mysql.dll
This line should not have a semicolon (;) before it.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now