?
Solved

Mapped drives lose login info after reboot/logout

Posted on 2008-11-05
8
Medium Priority
?
2,563 Views
Last Modified: 2010-04-21
More an annoyance than anything...  I have a customer running WinXP Home on a workstation.  She has two mapped drives - F and H - and connect to shared folders on the office "server" (i.e., beefed up PC running Vista Biz).  Oddly, she can open/utilize the H-drive w/o a problem, but when she tries to connect to the F-drive, she is prompted for login info.  Her user name is already listed in the box, and she uses "no"/"blank" password.  In other words, here, she just hits OK, and she connects to the folder.

The annoyance is, if she forgets to run through this login procedure when first booting, or after logging out/in Windows, apps like Word and Excel throw an error when trying to access the mapped drive.  Logging into the drive first, allows apps to use them normally.

My quandry is...where is this login prompt coming from?  The "server"'s shared folder setup, or from the workstation mapping the drive?  Why does H work w/o the prompt, but F prompts?  Is this a Home vs. Pro thing?

Thanks very much, in advance, for any suggestions.  As they are a distance away, and I'm not due back there for a few days, I won't be able to try solutions right away.  When I get on-site again, I will take and try all solutions and report back as to what worked.  Thanks much for your help and patience!
0
Comment
Question by:CThomp2005
8 Comments
 
LVL 10

Expert Comment

by:itsmein
ID: 22892792
To solve this , on the XP Home workstation, do this.

Start - Control Panel(Clasic View) - User Accounts - Advanced (tab)- Manage Password - click Add

Enter the Server IP and then the username password. It shouldnt prompt for passwords again.

SC
0
 
LVL 15

Accepted Solution

by:
tenaj-207 earned 500 total points
ID: 22892894
Try running this batch file in her startup folder

net use f: \\server\share /user:username /persistent:yes
net use h: \\server\share /user:username /persistent:yes
0
 
LVL 3

Expert Comment

by:Styphon
ID: 22892967
I had a very similar problem to this. I had set my folders up using advanced folder settings. From the Window go into the folder settings and in the view tab and at the bottom check the "Use simple file sharing" box and then reboot.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 25

Expert Comment

by:slam69
ID: 22894909
just remap the driver and click the remember password box when mapping
0
 
LVL 3

Expert Comment

by:Styphon
ID: 22920107
Did you get anywhere with this?
0
 
LVL 3

Author Comment

by:CThomp2005
ID: 22956660
My apologies for not getting back with this....  I'm actually heading out there now (literally) to try the approaches listed above.

I will report back as to what solution worked.

Thanks much for all the input and your patience...  Be back soon!
0
 
LVL 3

Author Comment

by:CThomp2005
ID: 22959179
Okay...the verdict is in...  Thanks to everyone who submitted.  I went through the solutions one by one and here are the results...  Reminder, this was for XP Home (SP3)...

itsmein:  There is no Advanced tab in the User Accounts area (actually, there aren't *any* tabs here - even in Pro).
slam69:  There isn't a Remember Password checkbox (I believe that is found in Pro, not Home).
Styphon:  Their server is running a version of Vista Biz.  Don't think simple file sharing is an option in that.  Honestly, I didn't even check - really didn't want to dig into the server.
tanaj-207:  Tried this solution last, and with a minor tweak, it works like a charm.

At first, the net use didn't solve anything, as I was still prompted for login info.  I found that there is a password parameter than can be entered after the share:
     net use f: \\server\share [password] /user:  /persistent=yes
Entering an empty string "" to simulate the blank password solved that - no more login prompt.  Secondly, with persitent=yes, upon boot, the user would get a message in the notification area saying that not all network drives could reconnect (very annoying).  I'm guessing the net use didn't kick in and pass in the login info before Windows tried to reconnect the mapped drives - thus the error.  I changed persistent to "no" so the drives would be "destoyed" at shutdown/logoff, and recreated at login, and that took care of the warning message.

Again, thanks much all for the various solutions...and for being patient until I could get back to the system...
0
 
LVL 3

Author Closing Comment

by:CThomp2005
ID: 31513799
Thanks much, tenaj-207.  Funny how, even now, we need to fall back on DOS once in awhile...
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…
Suggested Courses

616 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question