Cannot configure XAMPP for local root

I use XAMPP and Dreamweaver CS3 for web development and I have an irritating problem i just can't get.

XAMPP is installed in C:\ so the site I'm currently trying to design is in C:\Xampp\Htdocs\Aryakas .

I have an index.php file in this folder which contains the following testing  menu...

               <li><a href="index.php" title="Home"><span>Home</span></a></li>
            <li><a href="about.php" title="About"><span>About</span></a></li>
            <li><a href="/dogs/boys/boy1.php" title="Our Dogs"><span>Our Dogs</span></a></li>
            <li><a href="#" title="Contact"><span>Contact</span></a></li>

However , when I hover over the third link the browser shows

http://127.0.0.1/dogs/boys/boy1.php whereas the page is actually at

http://127.0.0.1/aryakas/dogs/boys/boy1.php so I get page not found

What am I doing wrong?

I've attached the FTP settings in Dreamweaver
ar.jpg
LVL 1
chrisfixitAsked:
Who is Participating?
 
caterham_wwwConnect With a Mentor Commented:
You used an absolute path, but it looks like the full path is "/aryakas/dogs/boys/boy1.php", so you've to include the folder /aryakas/, too, because it's part of your path. The domain does not point to C:\Xampp\Htdocs\Aryakas (in that case "/dogs/boys/boy1.php", would be correct) but C:\Xampp\Htdocs\.

If you'd lik to use a relative link, remove the leading slash  -> "dogs/boys/boy1.php".  But if you're e.g. in the folder /aryakas/dogs/, a relative link must be adjusted.
0
 
shiraztiConnect With a Mentor Commented:
Try this "dogs/boys/boy1.php"
<a href="dogs/boys/boy1.php" title="Our Dogs"><span>Our Dogs</span></a>

Open in new window

0
 
yessirnosirConnect With a Mentor Commented:
Hi chrisfixit, not sure if you have a reason for using FTP for your testing server, but just in case you weren't aware, you do have the option of using the "Local/Network" access option.  Have attached a screenshot showing you my setup for testing, with a local XAMPP testing server.  

Also, each of my sites is setup with an entry in the hosts file to allow me to refer to the local version of the website by name, rather than "127.0.0.1/....".

eg for a real website www.mydomain.com, I add this line to my "hosts" file:
127.0.0.1       mydomain.local
Then I just type "mydomain.local" in my browser to view the local testing version of the site.  

I originally followed these instructions for setting up my testing server:  http://drupal.org/node/161975

testing-server-local.jpg
0
 
chrisfixitAuthor Commented:
Thanks all ;-))
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.