Perl Command Line Interpreter has stopped working (windows vista)

Hi All

I have this program that I think is developed using Perl (from the error message i am getting).
When I try to run the program (.exe) it tells me that "Perl Command Line Interpreter has stopped working".
This program used to work but now it doesnt. I am running windows vista.

many thanks
devguru001DevAsked:
Who is Participating?
 
Adam314Connect With a Mentor Commented:
The default perl interpreter will be perl.exe, usually located at c:\perl\bin on windows systems.  You don't tell the program which dll's to use, the program specifies which dll's it'll use.

If you are missing a required library, you should try re-installing the program.
0
 
Adam314Commented:
Do you have perl installed?  Try typing "perl -v" at a prompt.
0
 
devguru001DevAuthor Commented:
no i dont have perl installed, it a stand alone .exe program.
it really strange, because it was working and then suddenly broke.

0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Adam314Commented:
Did you ever have perl installed?  Is this program trying to use perl?

Do you have the source code for this program?
0
 
devguru001DevAuthor Commented:
i am not sure if i have perl installed, i have been installing some pdf apps that might have installed perl at the same time, but i am not sure.

also i think this .exe might be trying to use perl, but also i am not sure, it just a stand alone .exe file that i could just run at any time.

and i dont have the source for the .exe it was given to me as is.

thanks
0
 
devguru001DevAuthor Commented:
the problem details i get is this, dont know if this helps:

Problem signature:
  Problem Event Name:      APPCRASH
  Application Name:      mcl.exe
  Application Version:      5.6.1.626
  Application Timestamp:      3bb8b21c
  Fault Module Name:      DBI.dll
  Fault Module Version:      0.0.0.0
  Fault Module Timestamp:      4106da77
  Exception Code:      c0000005
  Exception Offset:      0000dc2a
  OS Version:      6.0.6001.2.1.0.256.6
  Locale ID:      7177
  Additional Information 1:      db48
  Additional Information 2:      a1297ea7751292612e9aa4839fbcf610
  Additional Information 3:      2781
  Additional Information 4:      32752a31f647775074d2a538a9cfc6f7

Read our privacy statement:
  http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409
 
0
 
Adam314Commented:
The error message "Perl Command Line Interpreter has stopped working" is not very helpful.  You could try installing perl.  You can download it from www.activestate.com.  

If the problem is with this program, you should contact the supplier of this program, and let them know the error you are getting.  They may be able to help you.
0
 
TintinConnect With a Mentor Commented:
Where did the program come from?
What changes happened on your system between it working and not working?
Did you post the *exact* error message you are getting?
0
 
devguru001DevAuthor Commented:
i tried with installing activeperl, but still the same problem.
i was doing some testing with htmldoc and PDFcamp (PDF Writer) + DocConverter COM. So I installed those programs. but then i uninstalled them... and i think those could have been the cause but i am not sure.

I could possibly attach the program i am running, it quite small...
please let me know, thanks
0
 
devguru001DevAuthor Commented:
after some investigation, apparently p2x561.dll and perl58 are both perl interpreters and i think the program i am running uses p2x561.dll which i have on my machine, but somehow windows vista is telling the program to use perl58.dll as the interpreter but perl58.dll is not the compatible with the program.

so, how do i set the default perl interpreter on my windows vista.

thanks
0
 
devguru001DevAuthor Commented:
oh ok, i get what you saying...  did some further testing... it seems like if p2x561.dll doesnt exist the program doesnt run at all (no error either), when p2x561.dll exists, it looks for per58.dll, but it never required this perl58.dll to run the program until recently so i made perl58.dll available and then it throws the error: "Perl Command Line Interpreter has stopped working".

and also i dont have the install files, it just a standalone .exe that i copy and paste.

anyways, i am going to leave it for now, maybe it will come right again some other.

thanks for you assistance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.