• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8447
  • Last Modified:

Active Desktop Recovery

Active Destkop Recovery.

We have all seen this before. I found a solution to it.
The edit the registry fix.

precisely :
Run Regedit

Find this entry - HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components

Change the Key value  - DeskHhmlVersion REG_DWORD 0x00000110(272) to decimal zero

close regedit and log off and back on.



I have found that this is no longer working, does anyone have any other more permentant solutions?

Thanks
0
Alex-Kay
Asked:
Alex-Kay
2 Solutions
 
samiam41Commented:
I'm not sure what you are trying to accomplish.  Are you wanting to remove the ADR option?

http://www.computerhope.com/issues/ch000593.htm
0
 
Alex-KayAuthor Commented:
we have an issue where if an ms office app crashes, it corrupts the desktop.
this has also happened on one machine where when I close My Computer the Active Desktop Recovery came up.

It is becoming a problem as our directors are getting it and sometimes the above fix does not work.
0
 
Alex-KayAuthor Commented:
Active desktop is NOT enable on any of our machines... sorry should have mentioned that before!
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
samiam41Commented:
You're fine.  I just wanted to make sure I knew what you wanted to accomplish before I started giving you options.

So ADR isn't enabled by default but if an ms app crashes, the user receives a prompt to recover their active desktop?  And you want an option that does what?  Doesn't allow ADR to be used?
0
 
Alex-KayAuthor Commented:
Ok,

when an app crashes it brings up the ADR desktop, the one where it asks you to click on the button to recover the desktop.
however as ADR is not enabled clicking on here does not do anything.

The other problem is that it does not appear to be only MS apps causing this now.

When it 1st started I did some research and found out that the issue is caused by IE7 (hence the reg key quoted earlier) I am begining to think that there may be something else behind it as well though.

Thank you for all your help by the way
0
 
Alex-KayAuthor Commented:
any ideas guys?
0
 
samiam41Commented:
Let's try it from this angle.

Take the pc where this happens the most and run SuperAntiSpyware on it.  See if the results are as clean as you would prefer.  Next verify that your video card has the most up-to-date drivers installed.  Follow that by posting the warnings and errors recorded in your event-viewer that relate to this problem.  Lastly, let me know what OS/ SP you have for these pc's.
0
 
Alex-KayAuthor Commented:
ok well it has happened on XP pro SP2 (sp3 breaks our VPN) machines and also on a Server 2000R2 machine.
They have all be scanned with antispyware and all drivers are up to date.

And unfortunatley I cannot give you the logs, as none of them go back far enough, and unless I have one happen in front of me I will not be able to get to one.
0
 
Alex-KayAuthor Commented:
Any help with this would be really helpful.
0
 
Alex-KayAuthor Commented:
These are the other two solutions that I have come across however these are single time solutions and are not permenant.

1.      Open an explorer window (open My Computer for example)
2.      Tools
3.      Folder Options
4.      View
5.      Uncheck Hide protected operating system files
6.      Now do a search for desktop.htt&it should be on your C: normally
7.      Delete any desktop.htt files you find (there could be more than one depending on how many user profiles are on the machine)  They should be located in Documents and Settings\User\Application Data\Microsoft\Internet Explorer
8.      Close all windows you have open
9.      Now reboot your PC..Windows will recreate desktop.htt for you and it should work!
 oops&I almost forgot&.go ahead a place a check back in Hide protected operating system files

1) Right-click on desktop and select Properties
2) Click on Desktop tab then on Customise Desktop...
3) Click on Web tab
4) In the "Web pages" window should be - "My Current Homepage"
5) Untick this box. Click OK, then on Apply in Display Properties Window, then OK.


0
 
Alex-KayAuthor Commented:
Come on guys someone on here must have some ideas...
I have searched and searched the internet and I cannot find anything related to my situation.

The primary difference being that Active Desktop is NOT enabled on our machines!
On all the posts I have found the people HAVE got it enabled.

As we have asertained this problem is caused by IE7!!

Someone help me please....
0
 
Alex-KayAuthor Commented:
Anyone?
0
 
Alex-KayAuthor Commented:
Right to let you know if anyone ever searches this, we have a call open with Microsoft and there is no given solution to the problem.
Although they are pushing towards the reg key edit via a logon script to stop the issue happening.
0
 
kibatsuCommented:
Thanks for the Reg fix in the initial post Alex. I hadn't seen it before and it solved an issue I was having with Active Desktop.
0
 
DTS-TechCommented:
Hey all,

Just thought I'd let you know that I tried the OP's suggestion of:

"Run Regedit

Find this entry - HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components

Change the Key value  - DeskHhmlVersion REG_DWORD 0x00000110(272) to decimal zero

close regedit and log off and back on."

Now what isn't specified is that most would likely be running in a domain environment with GPO's that disallow access to system resources such as regedit and whatnot.

I tried running the regedit executable as administrator, tried the above fix and it failed.

My colleague then suggested the following:

1. Log into the workstation as a local or domain administrator
2. Access the local users and groups snap-in
3. Add the domain user that is having the Active Desktop issue to the local administrators group
4. Log out as administrator
5. Log in as the domain user with the Active Desktop issue
6. Make the registry change suggested by the OP (as follows)

Run Regedit

Find this entry - HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components

Change the Key value  - DeskHhmlVersion REG_DWORD 0x00000110(272) to decimal zero

close regedit and log off and back on.

7. Log out and back in again (by now the issue should be resolved!)
8. Of course, remove the domain user from the local administrators group.

Hope this helps!

DTS Tech Support
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now