[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Force all users to use 24 hour time

Posted on 2008-11-06
16
Medium Priority
?
3,766 Views
Last Modified: 2013-11-05
I have a box that is shared amongst multiple users and I need to force all login's to use 24 hour time. I am admin on the box but I don't have access to group policy's or the actual users themselves. I would like a solution that would work for any user who logs in, not just a preset list of users. I tried looking around for a command line process that I could put in the startup folder but I couldn't find anything. I modified the date time settings for myself hoping that it would propogate down to all users but it didn't. Please provide some direction.
0
Comment
Question by:justinbillig
  • 11
  • 3
14 Comments
 
LVL 9

Expert Comment

by:samiam41
ID: 22895089
Greetings.  A similar question was asked before and an expert provided this answer.  See if it matches your needs:

http://www.experts-exchange.com/Networking/Windows_Networking/Q_21488663.html
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22895098
You can use a local group policy on that pc.  From the start > run menu, enter in gpedit.msc
0
 
LVL 15

Author Comment

by:justinbillig
ID: 22895379
samiam41

That solution looks good but I have very little knowledge on how to do this. I opened up the group policy editor on my machine ( I am going to test it there first ) but I found no way to import it in. Where do I put it?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 9

Expert Comment

by:samiam41
ID: 22897362
Gotcha.  Let me write a quick guide on how to do this.
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22897735
Here we go.  

-Open up notepad and copy/paste the settings from the other post (I included them below to save a step).
-Save the notepad doc as MilitaryTime.adm in the c:\Windows\Inf directory
-Run gpedit.msc from start > run
-Under "Computer Configuration" > Administrative Templates (right click Admin Templates and choose View > Filtering > and uncheck "Only show settings that can be fully managed")
-Right click on Administrative Templates again and now choose "Add/Remove Templates"
-Choose Add > browse to the c:\windows\inf directory and select the militarytime.adm
-choose "Close"

*Restart pc
----[MilitaryTime.adm]----
CLASS USER
CATEGORY "Time settings"
POLICY "Use military time"
KEYNAME "Control Panel\International"
ACTIONLISTON
; Settings for military time:
  VALUENAME "iTime" VALUE "1"
  VALUENAME "iTLZero" VALUE "1"
  VALUENAME "s1159" VALUE ""
  VALUENAME "s2359" VALUE ""
  VALUENAME "sTime" VALUE ":"
  VALUENAME "sTimeFormat" VALUE "HH:mm:ss"
  VALUENAME "iTimePrefix" VALUE "0"
  VALUENAME "sDate" VALUE "."
  VALUENAME "sShortDate" VALUE "dd.MM.yyyy"
  VALUENAME "sLongDate" VALUE "dddd, d. MMMM yyyy"
END ACTIONLISTON
ACTIONLISTOFF
; Settings for normal time:
  VALUENAME "iTime" VALUE "0"
  VALUENAME "iTLZero" VALUE "0"
  VALUENAME "s1159" VALUE "am"
  VALUENAME "s2359" VALUE "pm"
  VALUENAME "sTime" VALUE ":"
  VALUENAME "sTimeFormat" VALUE "h:mm"
  VALUENAME "iTimePrefix" VALUE "0"
  VALUENAME "sDate" VALUE "/"
  VALUENAME "sShortDate" VALUE "mm/dd/yyyy"
  VALUENAME "sLongDate" VALUE "dddd, d. MMMM yyyy"
END ACTIONLISTOFF
END POLICY
END CATEGORY
----[MilitaryTime.adm]----

Open in new window

0
 
LVL 9

Expert Comment

by:samiam41
ID: 22898848
Correction!

Please see updated code below!
CLASS USER
CATEGORY "Time settings"
POLICY "Use military time"
KEYNAME "Control Panel\International"
ACTIONLISTON
; Settings for military time:
  VALUENAME "iTime" VALUE "1"
  VALUENAME "iTLZero" VALUE "1"
  VALUENAME "s1159" VALUE ""
  VALUENAME "s2359" VALUE ""
  VALUENAME "sTime" VALUE ":"
  VALUENAME "sTimeFormat" VALUE "HH:mm:ss"
  VALUENAME "iTimePrefix" VALUE "0"
  VALUENAME "sDate" VALUE "."
  VALUENAME "sShortDate" VALUE "dd.MM.yyyy"
  VALUENAME "sLongDate" VALUE "dddd, d. MMMM yyyy"
END ACTIONLISTON
ACTIONLISTOFF
; Settings for normal time:
  VALUENAME "iTime" VALUE "0"
  VALUENAME "iTLZero" VALUE "0"
  VALUENAME "s1159" VALUE "am"
  VALUENAME "s2359" VALUE "pm"
  VALUENAME "sTime" VALUE ":"
  VALUENAME "sTimeFormat" VALUE "h:mm"
  VALUENAME "iTimePrefix" VALUE "0"
  VALUENAME "sDate" VALUE "/"
  VALUENAME "sShortDate" VALUE "mm/dd/yyyy"
  VALUENAME "sLongDate" VALUE "dddd, d. MMMM yyyy"
END ACTIONLISTOFF
END POLICY
END CATEGORY

Open in new window

0
 
LVL 9

Expert Comment

by:samiam41
ID: 22898877
Also, when I tested it on a virtual pc, I put the militarytime.adm template under "Computer Configuration" first and then removed it. I left it under "User Configuration" and got the best results.
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22913893
Any update?
0
 
LVL 15

Author Comment

by:justinbillig
ID: 22933676
Sam,
         It didnt seem to work. I added it under user configuration > administrative emplates. If i open the add / remove templates dialog box it is there (MilitaryTime, size 1kb, modified today) but My time is still in AM/PM.

Any direction or thoughts?
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22934930
Interesting.  Looks like I will be testing this further.  Just to make sure I ask all the stupid questions, did you reboot this computer twice after applying the lgpo?
0
 
LVL 15

Author Comment

by:justinbillig
ID: 22939869
Twice. Not at the time but I have since restarted now 3 times and it still is AM / PM.
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22940144
; )  

That should be enough.  I had to ask.  Working on it now.
0
 
LVL 9

Expert Comment

by:samiam41
ID: 22985249
Got stuck in our building's remodeling when it got to our server room.  Sorry for the hang up.

I am going to spend some time this morning on this and will have you a concrete answer.
0
 
LVL 9

Accepted Solution

by:
samiam41 earned 500 total points
ID: 22985553
Ugh!  Leave it to me to make things difficult.

Forget the admin template.  Just make the following changes in your registry.  The first way is manual, the second is in script form in case you want to run it in your network.

Option 1
A.  Open registry editor (regedit) and browse to HKU > .Default > Control Panel > International
B.  When Internation is selected, on the right find the value "sTimeFormat"
C.  Change the value to HH:mm:ss (remove the tt since it relates to am/pm)
D.  If you don't want the time to show the zero (0100), just enter in H and you will get (100)

*Restart

Option 2
reg add "HKU\.DEFAULT\Control Panel\International" /V sTimeFormat /F /D "HH:mm:ss"

-I just ran it on a virtual pc and it works.  Give it a shot when you have a second.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses
Course of the Month20 days, 3 hours left to enroll

872 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question