Authentication problem with OpenSSH and SSH2-RSA Key Pair

Can anyone help me with this issue? Basically, I have a client trying to connect to my SCP server via ssh2-rsa key pair authentication. I've tested the connect from my desktop to the server, no problem, with PuTTy. However the client generated their keypair using OpenSSH. I've installed the key correct, and it looks like things are setup right on their end, but authentication process is still prompting the client for a password even though it recognizes and does not indicate any issue with the private key. Here's the log, I replaced my company's name with [host] and the clients name with [client].
Executing: program /usr/bin/ssh host files.[host].net, user [client]_scp, command scp -v -t upload/
OpenSSH_3.9p1, OpenSSL 0.9.7a Feb 19 2003
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to files.[host].net [] port 22.
debug1: Connection established.
debug1: identity file [host] type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.9p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'files.[host].net' is known and matches the RSA host key.
debug1: Found key in /home/[client]/.ssh/known_hosts:12
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: [host]
debug1: read PEM private key done: type RSA
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: password
[client]_scp@files.[host].net's password:
Who is Participating?
woolmilkporcConnect With a Mentor Commented:
did you generate and try the dsa keys (option -i [idfile])  or the version 1 keys (option -1)?
I know, your debug listing above doesn't indicate that there could be a problem, it's just to make the picture complete.


Are the permissions on the client side correct? (600 for the private key)
Not only key has to be 0600, but also $HOME must not be writable by anyone but owner, and $HOME/.ssh should be 0700 as well.
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

silentguyAuthor Commented:
Thanks for tips guys. The client has verified that the permissions are set correctly on their side and I've verified the correct permissions are set on my end. Unfortunately, it's still a no go. What's strange is that the log *seems* to indicate that there is no issue with the key pair itself. It just keeps asking for the password. Is there something specific that needs to be configured on the OpenSSH client side?
Another thing:
I've seen more than once that people simply copy and paste keys into their keyring files, not recognizing the eventually inserted LF.
Just one more place to look at.
And, it's not only file permissions, but also file ownership ...
ai_ja_naiConnect With a Mentor Commented:
If you are asked for a password and, after you typed, you are allowed to connect it means you gave a pass during the process of creation. Setup again the keys without typing passwords and it will not ask you
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.