Howto disable MSIE Certificate Errors permanently?

Hi, I when I open a certain page I get the message: "There is a problem with this website's security certificate. Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.  We recommend that you close this webpage and do not continue to this website."

When I click "continue to this website" I can continue. But I have to open this page a lot and I know I can trust this page. The certificate has expired, but that is no problem for me.

Now I am looking for a solution to disable this security check in MSIE7 for this site only or for all the SSL pages I visit.

Who knows the solution to this problem?
bijtvuurAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jcimarronCommented:
bijtvuur-- Internet Explorer Tools menu and select Internet Options, Advanced tab. Scroll down to the bottom (under Security) and disable/uncheck "Warn about certificate address mismatch" .  Apply|OK
You will have to reboot.
0
easyDKCommented:
When opening the site, as there's displayed security alert of MSIE, click on ---> Display certificate, then ---> Install certificate. Should work smoothly.
0
bijtvuurAuthor Commented:
Hi jcimarron,
"Warn about certificate address mismatch" I already have unchecked and I have rebooted my desktop. This did not solve the problem for me.
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

bijtvuurAuthor Commented:
Hi easyDK, I already did that one aswell. This didn't solve the problem either.

But the strange thing is that I cannot find the certificate in Tools > Internet Options > Tab Content > Button Certificates. It should be over there right?
0
bijtvuurAuthor Commented:
Anyone knows howto disbable the security check completely (in registry for example)? I will increase the reward to 350
0
ParanormasticCryptographic EngineerCommented:
Under internet options - advanced tab- security section:
Uncheck the following:
- Allow software to run or install even if the signature is invalid
- Check for publisher's certificate revocation
- Check for server certificate revocation (requires restart) -- (restart browser, not box)
- Check for signatures on downloaded programs
- Warn about invalid site certificates
- Warn if changning between secure and not secure mode


Sorry, I'm taking this from IE6, so there may be some slight wording differences for IE7.  If this still doesn't do it I will check IE7 at home, but this type of thing will generally show up in this same area.
0
ParanormasticCryptographic EngineerCommented:
From my previous post, 'Check for server certificate revocation' is the one that will usually do it, the rest are there for sake of getting rid of pretty much everything.
0
bijtvuurAuthor Commented:
'Check for server certificate revocation'  was already unchecked and this didn't solve the problem either.
0
Steve BinkCommented:
Did you check the rest of the settings he mentioned?  This one is probably responsible for a host of issues:

Warn about invalid site certificates

Your problem does not indicate a revoked certificate or an address mismatch.  It is expired.  That's a little different.  The invalid option should handle that, as well as self-signed warnings.

IMHO, the better question you should be asking is how to add a permanent exception for JUST THAT CERTIFICATE.  Disabling SSL warnings across the board is like killing all the plants in your house just because you don't like how one of them looks.  Those SSL warnings are there for a reason.  Perhaps you should contact the webmaster of the site in question and inform him of the problem.  Most responsible webmaster will want to fix that issue.
0
bijtvuurAuthor Commented:
I was again looking at the options Paranormastic has suggested and I saw 1 important option I cannot find "Warn about invalid site certificates". Mabye this is dissappeared in MSIE7 or do I need glasses? Does someone know if I can change this one in the registry? I think this could be the solution to the problem!
0
Steve BinkCommented:
Judging from my installation here, it looks like the option to disable that generic warning was removed in IE7.  Looks like you'll have to go another route.  

Still, probably for the best.  If the webserver is using SSL, they should invest in a proper certificate to avoid these problems.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bijtvuurAuthor Commented:
I understand that the certificate should be like it should, but in this situation it is best to disable the client. I think there will be an option to shut the check down, but it has to be changed right into the registry. Does anyone know?
0
easyDKCommented:
The site, where from goes the cert has the same name in the certificate, as FQDN you are using to connect to?
0
bijtvuurAuthor Commented:
It is a different subdomain so x.domain.com instead of y.domain.com and it is expired.
0
Steve BinkCommented:
I believe my answer of "can't be done" (#22941415) fits the bill.  I've seen no other ways to disable that warning.
0
I_S_F_C_OCommented:
Go to Tools, Internet Options.
Click on the Security Tab at the top, click on the Internet icon and then 'Custom Level'.
Scroll down about 60% and 'Enable' Dont prompt for clients certificate selection
see if that is what you need.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.