Windows 2003 DNS - IE - problem

I have a strange problem.  I have a Windows 2003 DC.  It runs AD and DNS.  From a command prompt I can ping google.com or other sites and get a valid IP response..thats good.  But when I open up IE and put in google.com or another site it says it "Cant Display the web page".  Even when I put in the ip address in the url bar it cant display the web page.  However, if I enter https://server1.myfdomaino.owa it will open OWA.  So it almost feels like a port 80 issue.  I have made sure the firwall is off and poked around did an nslookup and got the results back as expected.   I dont recall anything been changed on the server in the past 3 months except applying the regular patches.  Any clues?
martinmcginleyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

alienvoiceCommented:
Are you running a proxy? Do you need to add the proxy settings to your IE?

If so, this may help.

http://support.microsoft.com/kb/135982
0
martinmcginleyAuthor Commented:
nope
0
kdtreshCommented:
If you're doing this on the server, make sure IE Enhanced Security Configuration is disabled. In Control Panel > Add/Remove Programs, Add/Remove Windows Components, uncheck IE Enhanced Security Configuration.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

martinmcginleyAuthor Commented:
removed the enhanced feature.  The problem appears to be going out over port 80.  IE works if I put in:

http://server1.mydomiain.com:5858

but it wont work if i go to http://google.com
0
alienvoiceCommented:
I know this seems strange, but try the ip of google only in your web browser(as below). Even thou NSlookup worked on www.google.com

209.85.173.104

Also another weird test. Did you try putting a www infront of google.com?
0
kdtreshCommented:
Is "automatically detect settings" selected in Tools > Internet Options > Connections Tab > Lan Settings?
0
martinmcginleyAuthor Commented:
i did both tests and they both failed.  It seemed I had a dns problem when this all started, i chaged from root hints and then back again.  ping and nslookup woirk as they should.  If I was answering my own question I would think the problem is firewall associated becuase it seems the IE only fails on port 80 urls.  
0
martinmcginleyAuthor Commented:
auto detect setting is now on.  It was off, I have tested this setting...no change
0
kdtreshCommented:
Do you get the same problem when you type the address into a "My Computer" window? Do you have any other browsers you can try? Is there a firewall-type device, as you suggested, that could be filtering the traffic?

I assume it was working recently, since you mentioned nothing had changed.
0
martinmcginleyAuthor Commented:
No other browsers, I have started downloading firefox and see ihow that works.  there is a firewal device but the ohter computers on the network are ok...I will try firefox and check the router again
0
martinmcginleyAuthor Commented:
Tried Firefox - no luck.  There has to be something blocking port 80 outbound.  My antivirus update service is failed too, it cant get out on port 80 to update its dats.  

Any ideas how to check if a port is closed or is been used by another process ??
0
kdtreshCommented:
What kind of firewall device are you using? Can you check the logs?
0
ChiefITCommented:
NSlookup and ping are not conclusive. Things like google.com may likely be in the local computer's DNS resolver cache. So, that skips a DNS resolution from a Forwarder or Root hints server.

If you flush the DNS cache, you might not be able to perform NSlookup or Ping as you are currently doing.

Firewalls don't often block port 80, unless it is a prolific firewall like ISA. If ISA was blocking port 80 on your server, you would be able to get DNS resolution to the client and not be able to use the internet on your local server. However, a more likely scenario is your don't have your gateway configured with the correct IP. OR, you may have a multihomed server with two gateways configured.

If you have a multihomed server, that is a different story. So, please post back if you have a multihomed server. A multihomed server is simply defined as a server with two or more IPs. That could mean a single nic with multiple IPs, multiple NICs, or VPN connections on top of your LAN based NIC. There are very specific configurations when dealing with a multihomed server. Especially, when it is an AD/DNS server.
0
martinmcginleyAuthor Commented:
No ISA, I have already cleared cache.   I doubt it is a firewall issue I am going to check.   No multi homed server
0
martinmcginleyAuthor Commented:
This whole issue started with DNS. I gave the server a new IP to make sure the ip was not been blocked on port 80.  I found this in the event log:

DNS server has updated its own host (A) records.  In order to ensure that its DS-integrated peer DNS servers are able to replicate with this server, an attempt was made to update them with the new records through dynamic update.  An error was encountered during this update, the record data is the error code.
 
If this DNS server does not have any DS-integrated peers, then this error
should be ignored.
0
ChiefITCommented:
If this were 100% just this server, It could be a firewall. But, It would have to be a software firewall on the server.

It's my guess there is something wrong with the gateway.

Now, you are not receiving any errors, but the "page can not be found" error.
0
ChiefITCommented:
Let's see what that computer is doing on ports:

Go to the command prompt and type:
netstat -noa     (Look for ports 80-->>HTTP and 53-->DNS)

Let's look at services:
Go to Start>>Run>> and type in Services.MSC
Make sure the ""DNS client"" and ""Web client"" services are set for auto and started.

Let's check the gateway for a mistyped or missing gateway:

Let's run DCdiag and Netdiag to check DNS:

Also look at IPconfig /all to see if your have a funky looking IP and something that says "Toredo Tunnel":

0
ChiefITCommented:
Another thing you can do is reset the winsock:
At the command prompt:
netsh winsock reset

If zone alarm is on the server, or any other firewall, you might try to disable it and see if the problem remains.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
martinmcginleyAuthor Commented:
thanks - I will do these things as soon as I can get back to the server
0
martinmcginleyAuthor Commented:
thankls
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.