?
Solved

What is causing routing loop?

Posted on 2008-11-06
5
Medium Priority
?
1,639 Views
Last Modified: 2012-05-05
In the process of setting up a frame relay link with a vendor.  Connectivity was finally worked out but now appears something wrong with routintg.

We can ping from My laptop to Vendor router.
When vendor performs a tracert from his side to my router it begins to loop as shown below.
I have included the sho ip route for my router and the ip route command setting.
Vendor claims my routing is set incorrectly.
For clarity each section is section off with asterisks.

Question: What is causing the looping?



My laptop             My router                      My router           Cloud       Vendor router
192.168.177.5 <--> 192.168.177.1 <--> 192.168.151.86 <--------> 192.168.151.85

**************************************************************************

tracert -d 192.168.177.1

Tracing route to 192.168.177.1 over a maximum of 30 hops

  4     3 ms     1 ms     1 ms  Last hop before the circuit
  5     5 ms     5 ms     5 ms  192.168.151.86
  6     5 ms     4 ms     4 ms  192.168.151.85
  7     8 ms     8 ms     8 ms  192.168.151.86
  8     8 ms     8 ms     8 ms  192.168.151.85
  9    11 ms    11 ms    11 ms  192.168.151.86
 10    14 ms    11 ms    11 ms  192.168.151.85
 11    14 ms    14 ms    14 ms  192.168.151.86
 12    14 ms    14 ms    14 ms  192.168.151.85
 13    17 ms    17 ms    17 ms  192.168.151.86
 14    17 ms    17 ms    17 ms  192.168.151.85
 15    21 ms    22 ms    21 ms  192.168.151.86


**************************************************************************
ip route command from My router

!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.151.85
!
**************************************************************************

sho ip route from router 192.168.151.86

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.151.85 to network 0.0.0.0

     192.168.151.0/30 is subnetted, 1 subnets
C       192.168.151.84 is directly connected, Serial0/0/0
     192.168.177.0/28 is subnetted, 1 subnets
C       192.168.177.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.151.85

**************************************************************************

0
Comment
Question by:dalva
  • 2
  • 2
5 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22900919
Doesn't make any sense that your router would use the default route when the destination IP address IS the router.

Can you post the config of your router?
0
 
LVL 1

Author Comment

by:dalva
ID: 22901448
frcnty1841#sho run
Building configuration...

Current configuration : 2140 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname frcnty1841
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 xxxxxxx
!
no aaa new-model
!
resource policy
!
clock timezone PSTime -8
clock summer-time PDT recurring
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
ip tcp synwait-time 10
!
!
no ip bootp server
no ip domain lookup
ip domain name shra.org
ip name-server 10.10.120.60
!
username root privilege 15 secret 5 xxxxx
!
!
!
interface FastEthernet0/0
 description Inside link facing ASA
 ip address 192.168.177.1 255.255.255.240
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 shutdown
 duplex auto
 speed auto
 no mop enabled
!
interface Serial0/0/0
 ip address 192.168.151.86 255.255.255.252
 encapsulation frame-relay IETF
 frame-relay map ip 192.168.151.85 16 IETF
 frame-relay interface-dlci 16
 frame-relay lmi-type ansi
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.151.85
!
no ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
logging trap debugging
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 password 7 xxxx
 login
 transport output telnet
line aux 0
 password 7 xxxx
 login
 transport output telnet
line vty 0 4
 password 7 xxxx
 private
 login
 transport input telnet
line vty 5 15
 privilege level 15
 no login
 transport input telnet
!
scheduler allocate 4000 1000
end
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22901470
This is certainly strange.

What happens when you do a trace from your router using the 192.168.177.1 as the source address? Does it still loop?
0
 
LVL 13

Expert Comment

by:Quori
ID: 22901540
Able to get the routing table of the vendor router?
0
 
LVL 1

Accepted Solution

by:
dalva earned 0 total points
ID: 22909430
Finally got the vendor to spend some time debugging this.  Turns out their routing configs were not correct.
Everything appears to be working now.  My next step is to introduce the firewall and ACL's.  If I run into issues... I'll be back...

Thanks for your time.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question